PDA

View Full Version : vfat mount permissions



crainey69
30th July 2008, 03:28 PM
Hello all!

I feel stupid! I did a couple of quick searches on the forum but didn't find anything probably not using the right search terms.

I set Windows up in Vmware a couple of days ago and love it. However, It was having problems accessing my music files which were on an EXT3 drive. I made the decision to burn those files to DVD, reformat the drive to Fat32 and then put them back.

Windows doesn't have a problem now but, I can't seem to get rw access for my users in linux to that partition.

What have I screwed up?

Thanks!

Cory

bee
30th July 2008, 04:01 PM
Try to mount that partition with this option:
umask=000

bye :)

crainey69
31st July 2008, 11:32 AM
Thanks,

I doubt that will help as that will mount the partition with system defaults which only allow owner write access (as I understand umask).

However, my Fedora Hard drive decided that it was time to try and die today. For a while the controller wasn't even seeing it. Just for the heck of it, I let the drive set unhooked all day and tried again now and got the system up.

I'm backing up all I can and have a a new drive on the way.

oneofmany
31st July 2008, 11:37 AM
no, that will give rwx to all users, though i typically just do umask=0