PDA

View Full Version : SCSI Tape Drive cannot find proper /dev/???



simpzoid
30th July 2008, 10:02 AM
I got this DLT tape drive cheap on ebay and cannot get it to work on Fedora. It used to work on RH so I don't think its the drive. cat /proc/scsi/scsi has 'Type: Direct-Access' in the output which seems different to most of the documentation i've read.

My setup is as follows:
Fedora Core 5
Compaq 20/40 DLT SCSI Tape Drive
LSI PCI SCSI card - LSIU80LUDB Ultra2 SCSI PCI Host

The diagnostic input I've got is as follows:
# dmesg | grep -i scsi
SCSI subsystem initialized
scsi0 : ahci
scsi 0:0:0:0: Direct-Access ATA ST3120827AS 3.42 PQ: 0 ANSI: 5
SCSI device sda: 234441648 512-byte hdwr sectors (120034 MB)
SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
SCSI device sda: 234441648 512-byte hdwr sectors (120034 MB)
SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sd 0:0:0:0: Attached scsi disk sda
sym0: SCSI BUS has been reset.
scsi1 : sym-2.2.3
sd 0:0:0:0: Attached scsi generic sg0 type 0

# cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
Vendor: ATA Model: ST3120827AS Rev: 3.42
Type: Direct-Access ANSI SCSI revision: 05


# mtx -f /dev/sg0 status
mtx -f /dev/sg0 status
mtx: Request Sense: Long Report=yes
mtx: Request Sense: Valid Residual=no
mtx: Request Sense: Error Code=70 (Current)
mtx: Request Sense: Sense Key=Illegal Request
mtx: Request Sense: FileMark=no
mtx: Request Sense: EOM=no
mtx: Request Sense: ILI=no
mtx: Request Sense: Additional Sense Code = 20
mtx: Request Sense: Additional Sense Qualifier = 00
mtx: Request Sense: BPV=no
mtx: Request Sense: Error in CDB=no
mtx: Request Sense: SKSV=no
READ ELEMENT STATUS Command Failed

# mtx -f /dev/sg0 status
mtx: Request Sense: Long Report=yes
mtx: Request Sense: Valid Residual=no
mtx: Request Sense: Error Code=70 (Current)
mtx: Request Sense: Sense Key=Illegal Request
mtx: Request Sense: FileMark=no
mtx: Request Sense: EOM=no
mtx: Request Sense: ILI=no
mtx: Request Sense: Additional Sense Code = 20
mtx: Request Sense: Additional Sense Qualifier = 00
mtx: Request Sense: BPV=no
mtx: Request Sense: Error in CDB=no
mtx: Request Sense: SKSV=no
READ ELEMENT STATUS Command Failed

# mtx -f /dev/sda1 status
no Data Transfer Element reported

# mtx -f /dev/sda status
mtx: Request Sense: Long Report=yes
mtx: Request Sense: Valid Residual=no
mtx: Request Sense: Error Code=3 (Unknown?!)
mtx: Request Sense: Sense Key=No Sense
mtx: Request Sense: FileMark=yes
mtx: Request Sense: EOM=no
mtx: Request Sense: ILI=no
mtx: Request Sense: Additional Sense Code = FA
mtx: Request Sense: Additional Sense Qualifier = 90
mtx: Request Sense: Field in Error = 06
mtx: Request Sense: BPV=no
mtx: Request Sense: Error in CDB=yes
mtx: Request Sense: SKSV=yes
mtx: Request Sense: Field Pointer = E0 3F
INQUIRY command Failed

# mtx -f /dev/sda2 status
mtx: Request Sense: Long Report=yes
mtx: Request Sense: Valid Residual=no
mtx: Request Sense: Error Code=20 (Unknown?!)
mtx: Request Sense: Sense Key=No Sense
mtx: Request Sense: FileMark=no
mtx: Request Sense: EOM=no
mtx: Request Sense: ILI=yes
mtx: Request Sense: Additional Sense Code = 58
mtx: Request Sense: Additional Sense Qualifier = 71
mtx: Request Sense: BPV=no
mtx: Request Sense: Error in CDB=yes
mtx: Request Sense: SKSV=no
READ ELEMENT STATUS Command Failed

briantan
31st July 2008, 02:30 AM
Vendor: ATA Model: ST3120827AS Rev: 3.42
Type: Direct-Access ANSI SCSI revision: 05
I don't think FC5 recognized your scsi card. It is reporting only your Seagate harddisk.

Check for proper and secure scsi cable connection and termination.

Update to latest kernel may help
# yum update kernel

Try loading mptscsih or sym53c8xx driver module

# modprobe mptscsih
# tail -50 /var/log/messages
to check for proper initialization. If not, try the other module.

If it does work, your tape device should be at /dev/st0