PDA

View Full Version : User/password Help!



mmmikeW
29th July 2008, 11:26 PM
First time Linux user, and I like what I see from Fedora 9. The transition from Windows has been smooth so far, except for a few issues. I've tried searching the forum but couldn't find any help.


So I'm only able to log on under the ROOT account. Whenever I create a new user and set the password, it seems the password automatically changes to something different.

Example: I set my password to be 8 letters long, and when I check the user information the password mysteriously changes to something 5 digits long. I've tried making several shadow accounts and all of them have their passwords changed.

I figured maybe I was missing an update. So I go ahead and check for updates and I have around 300+ waiting for me. Great. Only problem is I get an error message when I actually try to run the update, but I got around this one by typing in the "yum update" thing in the command prompt.

So does anyone have any idea what could be causing the password problem? Signing in under ROOT is just a hastle.

JEO
30th July 2008, 12:27 AM
It always displays the password as 5 stars in the Users and Groups application. Don't worry, the real password is the length that you typed in.

mmmikeW
30th July 2008, 05:02 PM
I didn't know that it always displays the password as 5 stars, but that still doesn't solve my problem.

My password is pretty simple, and I'm positive it's not my spelling's fault. Nothing case sensitive. No numbers. Just to be sure I created yet another user with yet a simpler password, and whenever I try to log in as that regular user I'm told that it can't autheticate the user.

Help.

JEO
30th July 2008, 06:33 PM
Well, what happens when you press control-alt-f2 and try to login as a user from that text terminal window? If you receive an error message please copy the exact message here don't paraphrase it. You can type alt-f7 to get back to your graphical session.

JohnVV
30th July 2008, 07:27 PM
did you not make a user account on the FIRST boot after install
And to make a new user you are doing this from the root account
System / Administration / Users and Groups
http://img205.imagevenue.com/loc513/th_41508_UsersAndGroups_122_513lo.jpg (http://img205.imagevenue.com/img.php?image=41508_UsersAndGroups_122_513lo.jpg)
click on " Add user "
http://img111.imagevenue.com/loc814/th_41740_AddUser_122_814lo.jpg (http://img111.imagevenue.com/img.php?image=41740_AddUser_122_814lo.jpg)
then fill out the form then hit " ok "
and reboot . You should see the new user on the login screen .

oneofmany
30th July 2008, 07:40 PM
just from the sound of what you've said i wonder if you're attempting to authenticate logins from an alternate source, such as ldap or samba/active directory

mmmikeW
30th July 2008, 11:18 PM
What I did is just reinstall Fedora again and it somehow fixed the problem. I'm logging in as a regular user with no problem now.

I'm not crazy though. There really was a problem there. Thanks for the support.