PDA

View Full Version : Small firefox/thunderbird fonts



mcgd
29th July 2008, 11:21 AM
Hi,

I've had this problem for a while and haven't worked out how to get rid of it. Since I upgraded from F7 to F8, I've found that the fonts used by Firefox and Thunderbird are sometimes quite small. Initially the menu fonts were small, but I fixed that by setting layout.css.dpi to 0 as some have suggested.

However, some web pages and HTML email messages still appear in ridiculously small fonts. Is there some way I can fix this? I have tried increasing the DPI in the System -> Preferences -> Look and Feel -> Fonts control panel, but this seems to affect almost everything except these applications.

Oddly, only some messages and web pages are affected - for example http://www.bom.gov.au/products/IDS65000.shtml

drokmed
29th July 2008, 05:40 PM
In Firefox:

Edit -> Preferences -> Content -> (Fonts & Colors) Advanced -> Minimum font size

Change from NONE to 9 (or whatever).

mcgd
30th July 2008, 01:43 PM
In Firefox:
Edit -> Preferences -> Content -> (Fonts & Colors) Advanced -> Minimum font size
Change from NONE to 9 (or whatever).

Thanks for the suggestion, but this hasn't helped. I seems that the URL I listed is already displaying in 10 point, but it's being rendered very small for some reason. The same happens to quite a few other pages and also some mail messages in Thunderbird.

AutoStatic
30th July 2008, 01:56 PM
Try pressing ctrl + mousewheel.

mcgd
31st July 2008, 10:53 AM
Try pressing ctrl + mousewheel.

Yes, I can manually make the fonts bigger, but then the text on the next page is huge. It's not a showstopper, but it is a nuisance. I didn't have this problem before upgrading to F8, and I'm wondering why. Sounds like it's not a common problem, though I thought I had a fairly vanilla setup.

brebs
31st July 2008, 11:34 AM
Try dpi setting (http://opensuse-community.org/SubpixelHinting).

AutoStatic
31st July 2008, 11:39 AM
What I always do is installing some extra TTF fonts from a Windows installation (like Arial, Georgia, Verdana etc.) so that a lot of pages look better simply because the html or CSS code refers to one of those fonts. If that is your problem too than add a folder in /usr/share/fonts (mine is called ms) and copy the most commonly used fonts from a Windows installation into that folder. Restart FF and TB and see if that works for you.

jsalvo
31st July 2008, 11:57 AM
Hi,

I've had this problem for a while and haven't worked out how to get rid of it. Since I upgraded from F7 to F8, I've found that the fonts used by Firefox and Thunderbird are sometimes quite small. Initially the menu fonts were small, but I fixed that by setting layout.css.dpi to 0 as some have suggested.

However, some web pages and HTML email messages still appear in ridiculously small fonts. Is there some way I can fix this? I have tried increasing the DPI in the System -> Preferences -> Look and Feel -> Fonts control panel, but this seems to affect almost everything except these applications.

Oddly, only some messages and web pages are affected - for example http://www.bom.gov.au/products/IDS65000.shtml

The BOM site looks fine from my end using F9. See the screenshot attachment I added:

mcgd
11th August 2008, 10:39 AM
Try dpi setting (http://opensuse-community.org/SubpixelHinting).
Yeah I've done that - it helps the menus, but not the text of the pages


What I always do is installing some extra TTF fonts from a Windows installation
Hmm, that might help, but I didn't have these in F7, and fonts were fine.


The BOM site looks fine from my end using F9.
That's interesting - maybe it's an F8 problem. Might just have to wait until I upgrade.

tekknokrat
1st April 2009, 08:32 PM
same issue with f10 and thunderbird 2.0.0.21.

The font when writing a message is way to small.

all font size is set to 10
Someone a solution? Other application are fine.

EDIT: After changing fontsize in preferences a restart of thunderbird is neccessary to apply the settings. so it now works.