PDA

View Full Version : F9 Yum Broken ? Wrong MirrorList URL



agilotra
29th July 2008, 10:05 AM
I wanted to build Anaconda.
When I tried to do:
yum -v install git

It got stuck at:

Setting up Package Sacks

I checked /etc/yum.repos.d/fedora.repo and found that mirrorlist URL is incorrect.

It is: http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=$basearch
Put that in browser and it says invalid page i.e. there is no such URL
Correct entry is:
http://mirrors.fedoraproject.org/publiclist?repo=rawhide&arch=$basearch

Br
Ashish

Seve
29th July 2008, 10:11 AM
Hello:
It would help if you could provide the complete error list, i.e. copy and paste the complete terminal output. Otherwise, everyone is left to guess at what actually happened.

Also, can you post the output of

cat /etc/fedora-release
and
yum repolist

Seve

agilotra
29th July 2008, 10:58 AM
Terminal Output:

[agilotra~]# yum -v install git
Loading "refresh-packagekit" plugin
Loaded plugins: refresh-packagekit
Config time: 0.247
Yum Version: 3.2.14
COMMAND: yum -v install git
Installroot: /
Ext Commands:

git
Reading Local RPMDB
rpmdb time: 0.001
Setting up Package Sacks

-------------- and it remain stuck here forever -------------------------------------

[agilotra~]# cat /etc/fedora-release
Fedora release 9 (Sulphur)
[agilotra ~]# yum repolist
Loaded plugins: refresh-packagekit
repo id repo name status
fedora Fedora 9 - i386 enabled
fedora-source Fedora 9 - Source enabled
updates Fedora 9 - i386 - Updates enabled
updates-source Fedora 9 - Updates Source enabled

Seve
29th July 2008, 11:03 AM
Hello:
You need to disable the repos that are not by default enabled.

fedora-source Fedora 9
updates-source Fedora 9

Since you had to have manually enabled them, just do the reverse to disable them.

Then try

yum clean all
and
yum install git

Seve

agilotra
29th July 2008, 11:06 AM
And after sometimes, it spits following message:

Could not retrieve mirrorlist http://mirrors.fedoraproject.org/publiclist?repo=fedora-9&arch=i386 error was
[Errno 4] IOError: <urlopen error (110, 'Connection timed out')>
Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again

I checked above URL from browser [so network/fedora server is working fine] and it does point to list of mirrors.

-A

Demz
29th July 2008, 11:21 AM
did you do a
yum clean all coz i get that error in yum sometimes to but all i do is a yum clean all an then a yum update which fix's it..

the error your getting maybe well a yum Bug, but by doing a

yum clean all

should fix it

agilotra
29th July 2008, 11:24 AM
I tried to disable source. But No use. Here is the terminal output

[agilotra~]# yum repolist
Loaded plugins: refresh-packagekit
repo id repo name status
fedora Fedora 9 - i386 enabled
updates Fedora 9 - i386 - Updates enabled
[agilotra~]# yum clean all
Loaded plugins: refresh-packagekit
Cleaning up Everything
[agilotra~]# yum -v install git
Loading "refresh-packagekit" plugin
Loaded plugins: refresh-packagekit
Config time: 0.247
Yum Version: 3.2.14
COMMAND: yum -v install git
Installroot: /
Ext Commands:

git
Reading Local RPMDB
rpmdb time: 0.000
Setting up Package Sacks

-------- and it is stuck here again ------------------------------

and after sometime, 'connection time out' message is thrown.

agilotra
1st August 2008, 07:05 AM
Problem got resolved when I declared ENV variable HTTP_PROXY. It shall point to proxy ip. It now works fine.

marko
1st August 2008, 04:44 PM
I wanted to build Anaconda.
When I tried to do:
yum -v install git

It got stuck at:

Setting up Package Sacks

I checked /etc/yum.repos.d/fedora.repo and found that mirrorlist URL is incorrect.

It is: http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=$basearch
Put that in browser and it says invalid page i.e. there is no such URL
Correct entry is:
http://mirrors.fedoraproject.org/publiclist?repo=rawhide&arch=$basearch

Br
Ashish

You might be just glossing over this because you know better and did
it right in the browser but to be sure, you can't
literally put "$basearch" in the URL in your browser, you have to
insert the "i386" or "x86_64" that yum would have inserted.
You did that right?