PDA

View Full Version : How Do You Switch Window Managers?



NoSalt
29th July 2008, 03:09 AM
Hello All

I have Fedora 9 (ppc) installed and everything seems to be working well. I have an older, slower computer so I want to run a more lightweight window manager. I have installed XFCE but I have no idea how to switch from Gnome to XFCE. I thought there was a way at the login screen but there is nothing there. Would somebody out there and lend a hand?

Thanks for reading :)

JN4OldSchool
29th July 2008, 03:29 AM
Just for your information, Xfce and Gnome and KDE are what are known as desktop environments or DEs. They each contain a window manager or WM and there are also many stand alone window managers such as Fluxbox, Openbox, Hackedbox, all the other boces...e17, IceWM, Windowmaker...These allow a graphic user environment but are much more limited than a desktop environment. Though e17 is pretty darn nice and bears looking at.

When you hit the greeter screen or login screen you should see the option on the bottom as soon as you select a user. If not then dont sweat, this SEEMS to be a problem, though i havent verified it as a bug myself. I would suggest trying to also install fluxbox using yum and see if that doesnt cause the sessions option to appear. It could be your Xfce install is missing something.

This whole greeter issue burns my butt! Who was the rocket scientist who thought about "hiding" the sessions option in the first place? And then the dorks wont even let us change their stupid default greeter!

Be sure to post back with your findings, i am interested in this matter.

RonPolley
29th July 2008, 03:52 AM
I had to do a yum groupinstall XFCE to get a correct install,then I had the option of Gnome or XFCE at the bottom of the login screen " after " selecting a user. Runs terrific now.

RonPolley
29th July 2008, 04:18 AM
Here is the simple how-to of what I described above

Open a terminal
login as superuser
su - (thats su space - )
enter
enter your root password
xxxxxxxx
enter
type yum groupinstall XFCE
enter
type y when asked
enter
at installation complete exit the terminal
log out of x
at login select a user and then look to the bottom of your screen,you will see a selection box with XFCE as one of the options. Select XFCE and continue your login with your password. Now XFCE will start

NoSalt
29th July 2008, 04:24 PM
That worked great ... thank you all very much for your help.

Have a good one.