View Full Version : Boot hangs at 'Initializing usb controller (usb-uhci)...'

15th May 2004, 03:48 PM

I recently spent a fortnight getting wireless internet working on my linux machine (running Fedora Core 1, kernel 2.4.22-2115.nptl). It worked.

BUT, on to the problem. I then felt proud enough to tackle configuring sound on my linux machine, so I run the Fedora Sound Card Detector. But when I pressed the Play test sound button, I heard a moment of static and then the screen froze. So I rebooted...

What does this have to do with my problem? That's a GREAT question. I have no idea! When the machine rebooted, I selected my kernel from grub and was treated to the text-based (not graphical-based) startup. When startup reached the 'Initializing usb controller' step, it hung and hung and ....

My usb mouse has worked everytime I have rebooted or (reinstalled) FC1 on my machine. And now this...

Any assistance would be greatly appreciated, as I am stumped and a little disheartened after having labored so long to finally get the internet working.

Thanks much.


15th May 2004, 09:09 PM
No sweat. Fixed it. (Although a separate issue has arisen: details forthcoming)

I just disabled usb in the BIOS. Told Kudzu to 'Do Nothing' with the configuration. And rebuilt the old kernel (make oldconfig, make dep, etc.) Rebooted and everything was cool.