PDA

View Full Version : yum glibc-common problem



tau0
28th July 2008, 05:40 PM
Earlier this week I attempted a 'yum update' on one of my Fedora 9
systems and it failed. I have two Fedora 9 systems behind my
firewall and the firewall machine itself runs an earlier version of
Fedora communicating with the net via DSL.
The yum failure was because I could not download
glibc-common-2.8-8.i386 (22386485 bytes).
I got the following error messages:

Downloading Packages:
http://mirrors.kernel.org/fedora/updates/9/i386/glibc-common-2.8-8.i386.rpm: [Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.
(1/3): glibc-common-2.8-8.i386.rpm | 11 MB 00:00
http://linux.nssl.noaa.gov/fedora/linux/updates/9/i386/glibc-common-2.8-8.i386.rpm: [Errno 4] Socket Error: timed out
Trying other mirror.
(1/3): glibc-common-2.8-8.i386.rpm | 11 MB 00:00
http://mirrors.usc.edu/pub/linux/distributions/fedora/linux/updates/9/i386/glibc-common-2.8-8.i386.rpm: [Errno 4] Socket Error: timed out
Trying other mirror.
(1/3): glibc-common-2.8-8.i386.rpm | 11 MB 00:00
http://mirror.anl.gov/pub/fedora/linux/updates/9/i386/glibc-common-2.8-8.i386.rpm: [Errno 4] Socket Error: timed out
Trying other mirror.
ftp://fedora.bu.edu/updates/9/i386/glibc-common-2.8-8.i386.rpm: [Errno 4] IOError: [Errno ftp error] Requested Range Not Satisfiable
Trying other mirror.
(1/3): glibc-common-2.8-8.i386.rpm | 11 MB 00:00
http://fedora.mirrors.tds.net/pub/fedora/updates/9/i386/glibc-common-2.8-8.i386.rpm: [Errno 4] Socket Error: timed out
Trying other mirror.
(1/3): glibc-common-2.8-8.i386.rpm | 11 MB 00:00
http://archive.linux.duke.edu/pub/fedora/linux/updates/9/i386/glibc-common-2.8-8.i386.rpm: [Errno 4] Socket Error: timed out
Trying other mirror.
ETC.

So, after a couple of attempts ('yum clean all; yum update', etc.),
I attempted to update my other Fedora 9 system - same problem.
I increased the yum timeout in yum.conf - same problem.

So, I googled about and found this link:

http://www.linux-faqs.com/archive/redhat/fedora-list/2005-August/msg04665.html

This is exactly the problem I am currently facing.
I thus tried the various suggestions in the link's email trail.

wget:
hung after a couple of MBytes - about 6%.

curl -C - -v --retry 10 --remote-time --remote-name --location
hangs at 6% or sometimes after repeated attempts switching
mirrors it would hang at 52%.

command-line ftp client:
ftp://ftp.software.umn.edu/linux/fedora/updates/9/i386/glibc-common-2.8-8.i386.rpm
ftp://ftp.mirrorservice.org/sites/download.fedora.redhat.com/pub/fedora/linux/updates/9/i386/glibc-common-2.8-8.i386.rpm
hang after a couple of MBytes.

firefox ftp:
hangs at 6% and sometimes at 52%

firefox http:
hangs at 6% and sometimes at 52%

rsync:
rsync -av
or
rsync -azv
rsync://rsync.mirrorservice.org:873/download.fedora.redhat.com/pub/fedora/linux/updates/9/i386/glibc-common-2.8-8.i386.rpm /tmp
nothing seemed to happen

At this point I tried some of the above download mechanisms directly on
my firewall machine - who knows... Anyway, none of those tried on the
firewall worked either.
So, I assumed something was wrong with my firewall machine, so
I re-installed Fedora on it, upgrading from an earlier version of
Fedora to a later version (complete re-install) but not Fedora 9.
After the new install, still same problem.
But I did notice that on the firewall when I did a 'yum update'
it tried a number of mirror machines attempting to download its
update version of the glib-common rpm, but if finally succeeded.
Its version of the glib-common rpm is about 5 MB smaller than the
current Fedora 9 version.

I also tried to download files larger than the glibc-common-2.8-8.i386.rpm
from the mirrors, for example R-2.7.1-1.fc9.i386.rpm which is 26MB.
Well, this downloads just fine.

During all my attempts, from the firewall machine bouncing
between mirrors using 'curl' I did get one download of the
glibc-common-2.8-8.i386.rpm file but because it took many
invocations of 'curl' I am not sure I trust it to be all there.
Its the correct number of bytes but I don't trust the content
of the file so I am certainly not going to update any machines
with it until I can verify the files content.

So, my questions:

Why can I not download the glibc-common file?
Does my ISP have an issue?
What could possibly be stopping the download when the file
name is glibc-common?
The time it happened as documented by the above link was there
a solution?
Does yum have a sha1 checksum that I can check against the
one glibc-common-2.8-8.i386.rpm file that I did get so that
I can see if its ok? If not, can someone post such a checksum for me?

Thanks.

Richard

tau0
30th July 2008, 07:00 PM
Apologies to anyone searching this thread for a solution.
None has been found as yet.