View Full Version : FC9 Update System cannot retrieve repository repomd.xml

28th July 2008, 08:06 AM
Dear all,

I have recently installed FC9 from scratch. After the installation, I run a system update and ran straight into the following problem: :eek:

Problem connecting to a software source
There was a (possibly temporary) problem connecting to a software source.
Please check the detailed error for further details.

More details:
Cannot retrieve repository metadata (repomd.xml) for repository: updates. Please verify its path and try again.

I try to locate the file "repomd.xml" but couldn't find it. :( I have tried to reinstall a few times, but problem remains. :mad: Could someone help me please!

Thank you in advance.


28th July 2008, 08:41 AM
The file contains the available updates and is located on the update server. After installation you should have a clean setup regarding the updates.
At first, please check you network connectivity! Then open a konsole window, do a 'su' and type in 'yum update'!

Please post the output!

28th July 2008, 05:55 PM
You may need to "yum clean metadata" or "yum clean all" before you try to update. This happens on my system from time to time, and that always works.

28th July 2008, 06:35 PM
After cleaning yum and before updating, it might be a good idea to "yum install yum-fastestmirror".

29th July 2008, 08:46 AM
Thank you for all the advices.

My problem has been resolved. I have tried the following:
1. execute "yum update" by "root";
2. execute "yum clean all" by "root";

None of them work. Finally, I add the following line into "/etc/yum.conf":

proxy=http://<your proxy address>:<your proxy port number>

and it works and my package manager is updating the system now. I guess I have not actually touched the repo of yum.