PDA

View Full Version : How to use Emerald Theme Manager with Compiz?



tron_thomas
28th July 2008, 03:53 AM
I am using Compiz in Fedora 9 on my Intel Core2 Duo system with an nVidia graphics card.

I just installed the Emerald Theme Manager, and nothing changes when I try to select different themes.

How can I get the Emerald Theme Manager working with Compiz?

joebrueske
28th July 2008, 09:17 AM
I'm having the same problem and I'm working on finding a solution. I'll let you know when I do.

chousho
28th July 2008, 09:49 AM
Hey, make sure you've installed the packages as seen in #2 in this thread
http://forums.fedoraforum.org/showthread.php?t=173317

After that, go to Applications -> System Tools -> Compiz Fusion Icon

joebrueske
28th July 2008, 09:49 AM
Okay, I got it working. It's different than Ubuntu, which is what I'm use to. But I like it this way. You need to get the fusion-icon. There is no RPM and it's not in the repos. So, attached is the icon. That's the easy way to get it. I have found many people use an application called git.

su -
(password)
yum install git-core
git-clone git://anongit.compiz-fusion.org/users/crdlb/fusion-icon
Once you have the fusion-icon

cd fusion-icon
make && make install
I found out that I did not have the development package for python installed. If you receive an error from the make install that a directory can't be found in the python directory, install the devel package.

yum install python-devel python-setuptools-devel
Once that's done, go to System > Personal > Session. Hit +Add. In the name and command spot type the following

Fusion Icon
/usr/bin/fusion-icon
Restart X but logging out and logging in and there will be this blue box icon on the top panel. Right click on it, that's the fusion-icon. This is how you can quickly manage which manager to use for the gui. Change Window decorator from GTK to Emerald.

I frequently had Emerald crap out on me, or something, so I'd have to run gldesktop in ubuntu or something like that. This is a nice back up on controlling all of this.

COOL huh?! Golly, this is my first time helping some one else out with Linux! WOo hoo! Go me!

Seve
28th July 2008, 09:54 AM
Hello:
If you had of searched or even looked at the first page of the How-To Section you would find everything you needed.
http://forums.fedoraforum.org/forumdisplay.php?f=12
See http://forums.fedoraforum.org/showthread.php?t=173317


BTW I'm glad you got it sorted out, but usually there is a rpm solution available.

Seve

joebrueske
28th July 2008, 10:05 AM
lol or that. Yeah the easiest solution is usually right in front of your face. :rolleyes:

tron_thomas
29th July 2008, 05:33 AM
I think I already have fusion icon installed. When I start up my system it always starts without any window manager, so I have no decorations on my windows and can't move or resize anything.

I always select Compiz Fusion Icon from the Systems Tools menu after clicking on the Gnome icon on the main panel located at the bottom of my screen. This corrects my system and gives me a window manager with decorations so everything works properly.

If I already have Compiz Fusion Icon installed what is needed to get the Emerald Theme Manager working with it?

Hlingler
29th July 2008, 08:23 AM
Start fusion-icon (if not already running). Right-click on fusion-icon systray applet. Select "Select Window Decorator" from context menu => Emerald. And/or, select "Emerald Theme Manager" to set up Emerald theme(s).

V

Surajprakash
29th July 2008, 04:12 PM
Hello
i done same thing as you said but after clicking fusion-icon my screen is goes reverse. i mean to say all characters are mirror. i cant work on system tray also. and main KDE menu also.

Pl. help
suraj

Hlingler
29th July 2008, 04:39 PM
Hello
i done same thing as you said but after clicking fusion-icon my screen is goes reverse. i mean to say all characters are mirror. i cant work on system tray also. and main KDE menu also.

Pl. help
surajKewl. I don't think I've heard of this one before. How did you manage to do that?

Try:
Press ALT-CTL-Backspace to re-start the X-server. You will be automatically logged out of the desktop. Log in again. Then go visit the "Guides and How-Tos" forum here, and find and read the sticky-threads on Compiz-Fusion installation and usage. Suggest you do so before trying to start Compiz-Fusion again.

V

tron_thomas
3rd August 2008, 09:46 PM
I tried that and it worked. Thanks.