PDA

View Full Version : avi files



spyr0s
27th July 2008, 08:18 PM
I can't play avi and other multimedia files.
When I open the avi movies with MPlayer, Gnome MPlayer, Banshee media player or VLC media player, the window close after 1-2 seconds without playing anything.
Only the KPlayer window doesn't close, but there is only sound without the video.
I use fedora-9 with ATI Mobility Radeon X1400.

Does anyone else have a similar problem?
Thanks in advance for your time and your help. Your help is really appreciated.
spyr0s

marko
27th July 2008, 11:22 PM
Fedora's license doesn't accept non free codecs in the distribution.
You'll need to put in the non-free codecs by using the Livna third party
repository, see these instructions:

Add the Livna third party repository:

"Third Party Repositories"
http://www.mjmwired.net/resources/mjm-fedora-f9.html#yum

Add/setup MP3 playing
http://www.mjmwired.net/resources/mjm-fedora-f9.html#mp3

How to setup the Media players and codecs for them:
http://www.mjmwired.net/resources/mjm-fedora-f9.html#mediaplayers

spyr0s
29th July 2008, 10:37 PM
PERFECT !

thank you very much marko.

Now I can see the media files!
Not only I did not had the codecs, but I also had to...

"
Video Output Issues: If you are unable to see any video try the following:
Run gmplayer, Right-Click, goto Preferences > Video and change your driver. This may be dependent on your video hardware/driver.
"
I also did it to the other applications and all the media programs are now available.