PDA

View Full Version : Flash Installation Issues - Already visited FedoraFaq/etc.



Izek
27th July 2008, 06:02 PM
The following occured when I tried to install using fedora-faq's method (http://www.fedorafaq.org/#flash)... (I don't have an x86_64 machine btw)


[Ian@localhost ~]$ su -
Password:
[root@localhost ~]# yum install flash-plugin nspluginwrapper.{i386,x86_64} pulseaudio-libs.i386 libflashsupport.i386
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
No package flash-plugin available.
Package nspluginwrapper-1.1.0-4.fc9.i386 already installed and latest version
No package nspluginwrapper.x86_64 available.
Package pulseaudio-libs-0.9.10-1.fc9.i386 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package libflashsupport.i386 0:000-0.5.svn20070904 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
libflashsupport i386 000-0.5.svn20070904 fedora 8.6 k

Transaction Summary
================================================== ===========================
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 8.6 k
Is this ok [y/N]: y
Downloading Packages:
(1/1): libflashsupport-000-0.5.svn20070904.i386.rpm | 8.6 kB 00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : libflashsupport [1/1]

Installed: libflashsupport.i386 0:000-0.5.svn20070904
Complete!

After doing that, I did the "configure your browser" and this is what I got from that...


[root@localhost ~]# mozilla-plugin-config -i -g -v
INFO: /usr/lib/nspluginwrapper/npviewer looks ok.
INFO: /usr/lib64/nspluginwrapper/npviewer isn't accessible.
INFO: Processing /usr/lib/mozilla/plugins -> /usr/lib/mozilla/plugins-wrapped
INFO: Linking /usr/lib/mozilla/plugins/libtotem-gmp-plugin.xpt to /usr/lib/mozilla/plugins-wrapped/libtotem-gmp-plugin.xpt...
WARNING: Failed.
INFO: Linking /usr/lib/mozilla/plugins/libtotem-gmp-plugin.so to /usr/lib/mozilla/plugins-wrapped/libtotem-gmp-plugin.so...
WARNING: Failed.
INFO: Linking /usr/lib/mozilla/plugins/libjavaplugin.so to /usr/lib/mozilla/plugins-wrapped/libjavaplugin.so...
WARNING: Failed.
INFO: Linking /usr/lib/mozilla/plugins/libtotem-cone-plugin.xpt to /usr/lib/mozilla/plugins-wrapped/libtotem-cone-plugin.xpt...
WARNING: Failed.
INFO: Linking /usr/lib/mozilla/plugins/libtotem-cone-plugin.so to /usr/lib/mozilla/plugins-wrapped/libtotem-cone-plugin.so...
WARNING: Failed.
INFO: Linking /usr/lib/mozilla/plugins/libtotem-mully-plugin.so to /usr/lib/mozilla/plugins-wrapped/libtotem-mully-plugin.so...
WARNING: Failed.
INFO: Linking /usr/lib/mozilla/plugins/libtotem-complex-plugin.so to /usr/lib/mozilla/plugins-wrapped/libtotem-complex-plugin.so...
WARNING: Failed.
INFO: Linking /usr/lib/mozilla/plugins/libtotem-complex-plugin.xpt to /usr/lib/mozilla/plugins-wrapped/libtotem-complex-plugin.xpt...
WARNING: Failed.
INFO: Linking /usr/lib/mozilla/plugins/libtotem-basic-plugin.so to /usr/lib/mozilla/plugins-wrapped/libtotem-basic-plugin.so...
WARNING: Failed.
INFO: Linking /usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.xpt to /usr/lib/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.xpt...
WARNING: Failed.
INFO: Linking /usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so to /usr/lib/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.so...
WARNING: Failed.
INFO: Linking /usr/lib/mozilla/plugins/libtotem-mully-plugin.xpt to /usr/lib/mozilla/plugins-wrapped/libtotem-mully-plugin.xpt...
WARNING: Failed.
INFO: Linking /usr/lib/mozilla/plugins/libtotem-basic-plugin.xpt to /usr/lib/mozilla/plugins-wrapped/libtotem-basic-plugin.xpt...
WARNING: Failed.
INFO: Processing /usr/lib64/mozilla/plugins -> /usr/lib64/mozilla/plugins-wrapped
WARNING: I can't open dir /usr/lib64/mozilla/plugins-wrapped
INFO: Processing /usr/lib/mozilla/plugins -> /usr/lib64/mozilla/plugins-wrapped
INFO: Processing /usr/lib/mozilla/plugins <- /usr/lib/mozilla/plugins-wrapped
INFO: Checking plugin installation /usr/lib/mozilla/plugins-wrapped/libtotem-gmp-plugin.xpt...
INFO: Checking plugin installation /usr/lib/mozilla/plugins-wrapped/libtotem-gmp-plugin.so...
INFO: Checking plugin installation /usr/lib/mozilla/plugins-wrapped/libjavaplugin.so...
INFO: Checking plugin installation /usr/lib/mozilla/plugins-wrapped/libtotem-cone-plugin.xpt...
INFO: Checking plugin installation /usr/lib/mozilla/plugins-wrapped/libtotem-cone-plugin.so...
INFO: Checking plugin installation /usr/lib/mozilla/plugins-wrapped/libtotem-mully-plugin.so...
INFO: Checking plugin installation /usr/lib/mozilla/plugins-wrapped/libtotem-complex-plugin.so...
INFO: Checking plugin installation /usr/lib/mozilla/plugins-wrapped/libtotem-complex-plugin.xpt...
INFO: Checking plugin installation /usr/lib/mozilla/plugins-wrapped/libtotem-basic-plugin.so...
INFO: Checking plugin installation /usr/lib/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.xpt...
INFO: Checking plugin installation /usr/lib/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.so...
INFO: Checking plugin installation /usr/lib/mozilla/plugins-wrapped/libtotem-mully-plugin.xpt...
INFO: Checking plugin installation /usr/lib/mozilla/plugins-wrapped/libtotem-basic-plugin.xpt...
INFO: Processing /usr/lib64/mozilla/plugins <- /usr/lib64/mozilla/plugins-wrapped
WARNING: I can't open dir /usr/lib64/mozilla/plugins-wrapped
INFO: Processing /usr/lib/mozilla/plugins <- /usr/lib64/mozilla/plugins-wrapped
WARNING: I can't open dir /usr/lib64/mozilla/plugins-wrapped

Also, when installing via the adobe.com site, I get an error message after the package downloads, it simply says "cannot install tmp/flash-plugin-9.0.124.0-release.i386.rpm"

marko
27th July 2008, 07:35 PM
The following occured when I tried to install using fedora-faq's method... (I don't have an x86_64 machine btw)

You don't need nspluginwrapper for i386

these instructions are better:

http://www.mjmwired.net/resources/mjm-fedora-f9.html#flash


su -
<root password>
rpm -ivh http://linuxdownload.adobe.com/adobe-release/adobe-release-i386-1.0-1.noarch.rpm
rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-adobe-linux
yum install flash-plugin libflashsupport

Refer to the upper section and not the 2nd half that's for 64 bit

Izek
27th July 2008, 10:38 PM
Thanks for telling me not to do "sudo" like it said on the instructions there, it told me my username didn't exist in the sudo or whatever.

marko
28th July 2008, 01:18 AM
Thanks for telling me not to do "sudo" like it said on the instructions there, it told me my username didn't exist in the sudo or whatever.

It would be if you do all the instructions on that whole page, higher up is
a section where you setup sudo

http://www.mjmwired.net/resources/mjm-fedora-f9.html#sudo

but since I was pointing to just the relevant flash section I figured you might not have that setup