View Full Version : "Add/Remove Software" Gone

27th July 2008, 08:10 AM
The "Add/Remove Software" link is gone from my KDE4 menu. I'm running Fedora 9 and I think the problem happened when gnome-packagekit had an update with a broken dependency sometime ago. I chose not to install the update and somehow it didn't appear again. I tried running PackageKit and gnome-packagekit from the terminal but neither was identified as a valid command. The weird thing is that when I run Yumex it shows that PackageKit, gnome-packagekit, and all their dependencies are installed properly. I even tried removing and reinstalling them but that didn't work. Any ideas on how I can fix this problem?

27th July 2008, 08:15 AM
What is the output of typing from a terminal



27th July 2008, 02:44 PM
"pirut" is not included in F9 anylonger:

yum search pirut
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* fedora: mirror.lib.ucdavis.edu
* freshrpms: ayo.freshrpms.net
* updates: mirror.lib.ucdavis.edu
fedora | 2.4 kB 00:00
freshrpms | 2.4 kB 00:00
updates | 2.3 kB 00:00
Warning: No matches found for: pirut
No Matches found

and here in my F9, when double click a .rpm, it can never be installed as it was in F8.

27th July 2008, 03:11 PM
Typing "gpk-application" opens the "Add/Remove Software" GUI, but how can I get it back on the KDE4 menu, and how can I access the PackageKit settings to set the autoupdate intervals?

28th July 2008, 05:18 AM
I figured out that I can type "gpk-update-viewer" and "gpk-prefs" in the terminal to open the update viewer and the settings. But I still can't figure out why they're gone from the menu. Many websites I looked at say that they can be found under (System->Administration), but I don't seem to have the whole "Administration" submenu. I tried the "Restore system menu" option from the menu editor but that didn't work either. Any ideas on how to get it back?

9th September 2008, 03:29 PM
If you're running rawhide you might want to try installing kpackagekit which is a KDE4 native frontend to PackageKit.