PDA

View Full Version : X server failed to start after Kernel update



llb
27th July 2008, 04:37 AM
Hi, there was a kernel update, I think it was 6.25....11 or something.
After the update and reboot using the new kernel version, the x server won't start, no GUI .
Then it asked me to reconfigure my x server, but when I chose my older kernel version at boot, everything worked fine.
I am using the Nvidia 177 driver with CUDA support, I think the officially supported is version 173, but somehow I got version 177 to work.
I don't know what the problem is.
Can somebody help me? Thanks.

Skunk Worx
27th July 2008, 04:52 AM
It sounds like you downloaded NVIDIA 177.13 and built/installed it yourself. Is this true?

If so, be aware that you need to rebuild/reinstall the NVIDIA driver every time the kernel is updated.

Just execute the "NVIDIA....run" file again (as root) and follow the prompts.

---
John

JohnVV
27th July 2008, 05:22 AM
and i would also add that a rebuild of the nvidia.run installer will be needed for almost all xorg updates too
also some programs may not run using only the nvidia.run driver
for example my celestia build did not run unless i also built and installed mesa from source

llb
27th July 2008, 05:27 AM
Ye, I fear that if I reinstall the Nvidia driver my CUDA SDK would break, so for now I will stick to my older kernel which worked fine, had no problem with it.
These kernel updates are really annoying, this happened to me once before.
So can I just not update the kernel at all from now on?

Skunk Worx
27th July 2008, 05:52 AM
yes you can block kernel updates via the command line or permanently in /etc/yum.conf

# yum --exclude=kernel* update

or edit /etc/yum.conf and add :

exclude=kernel*

...in the list near the top.

also in your case you might want to remove the newer kernel via rpm or permanently configure /etc/grub.conf to boot the last 'good' kernel.

You might miss something good in a newer kernel though :D

---
John

Brook
27th July 2008, 06:09 AM
New kernel is more powerful and efficient.But if the old kernel can fill you need,it's useless to update the kernel unless you like to try new things in risk.

Hlingler
27th July 2008, 06:17 AM
Also be aware that kernel updates usually fall into the "security" update category....

V

llb
27th July 2008, 08:36 AM
I am tempted to reinstall the Nvidia driver, but I fear something else may break, such as the VirtualBox, last time I had to recompile VirtualBox Kernel, and thank god it worked, but I don't know about this time. Any ideas?

Skunk Worx
27th July 2008, 06:04 PM
I haven't used it but scanning Sun's VirtualBox manual, page 17 states you can update the kernel module when the kernel changes by running :

# /etc/init.d/vboxdrv setup

Given the comments in the thread I'd consider booting into the new kernel and running this, and also running the NVIDIA .run file. It's sounding like you should bite the bullet and deal with this whenever the kernel changes, rather than ban things in yum.

Kernel modules are installed into the /lib/modules/(kernel version) area. Since the build/install is based on the kernel version, it should not affect your ability to boot and run other kernels...they are in a different directory and should not be affected.

Consider booting into the new kernel, building/installing both kernel modules (NVIDIA and VirtualBox) and booting into both...your earlier kernel and the newest. I am guessing it will be fine either way.