PDA

View Full Version : I have the answer, but



hattrickinc
27th July 2008, 03:27 AM
I searched! lol

Problem:
Make: *** [Modules] Error 2

Solution:
devel headers.

I did yum install kernel kernel-headers

Still no go.

I cant find the devel for this kernel:

2.6.25.11-97.fc9.i686


any advice please?

GallComp
27th July 2008, 03:31 AM
Can you be a bit more specific of what are you trying to acomplish and what steps are following...

Your post is kinda confussing...

leigh123linux
27th July 2008, 03:38 AM
Try



su
yum install kernel-devel

hattrickinc
27th July 2008, 03:38 AM
I just set up my laptop with fedora core 9..

When I try to 'make' a program, i get this error:

Make: *** [Modules] Error 2

Wayne
27th July 2008, 03:40 AM
What program are you trying to make?

See my sig for guides

Wayne

hattrickinc
27th July 2008, 03:45 AM
uname -a
Linux localhost.localdomain 2.6.25.11-97.fc9.i686 #1 SMP Mon Jul 21 01:31:09 EDT 2008 i686 i686 i386 GNU/Linux


make[2]: *** [/root/Download/ipwraw-ng/ipwraw.o] Error 1
make[1]: *** [_module_/root/Download/ipwraw-ng] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.25.11-97.fc9.i686'
make: *** [modules] Error 2

hattrickinc
27th July 2008, 03:47 AM
ps- I read the sigs ;-)


I know this error, I got it a couple months ago, and researched and found the devel headers SOMEWHERE

But I cannot find it tonight,..
ps- Its not just this compile, it's everything I try to manually compile..

[root@localhost ~]# yum install kernel-devel
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
Package kernel-devel-2.6.25.11-97.fc9.i686 already installed and latest version
Nothing to do

Skunk Worx
27th July 2008, 03:59 AM
Can you show a few more lines above this one? Like from at least the first error down.

make[2]: *** [/root/Download/ipwraw-ng/ipwraw.o] Error 1

hattrickinc
27th July 2008, 04:02 AM
[root@localhost Download]# rpm -ivh kernel-headers-2.6.25.11-97.fc9.i386.rpm
Preparing... ########################################### [100%]
package kernel-headers-2.6.25.11-97.fc9.i386 is already installed

hattrickinc
27th July 2008, 04:02 AM
[root@localhost ipwraw-ng]# make
make -C /lib/modules/2.6.25.11-97.fc9.i686/build M=/root/Download/ipwraw-ng modules
make[1]: Entering directory `/usr/src/kernels/2.6.25.11-97.fc9.i686'
CC [M] /root/Download/ipwraw-ng/ipwraw.o
/root/Download/ipwraw-ng/ipwraw.c: In function ‘store_bssid’:
/root/Download/ipwraw-ng/ipwraw.c:1500: error: implicit declaration of function ‘MAC_ARG’
/root/Download/ipwraw-ng/ipwraw.c:1500: warning: too few arguments for format
/root/Download/ipwraw-ng/ipwraw.c:1506: warning: too few arguments for format
/root/Download/ipwraw-ng/ipwraw.c: In function ‘show_bssid’:
/root/Download/ipwraw-ng/ipwraw.c:1516: warning: too few arguments for format
/root/Download/ipwraw-ng/ipwraw.c: In function ‘ipw_print_rx_config’:
/root/Download/ipwraw-ng/ipwraw.c:2565: warning: too few arguments for format
/root/Download/ipwraw-ng/ipwraw.c:2567: warning: too few arguments for format
/root/Download/ipwraw-ng/ipwraw.c: In function ‘tx_skb’:
/root/Download/ipwraw-ng/ipwraw.c:7421: warning: too few arguments for format
/root/Download/ipwraw-ng/ipwraw.c: In function ‘ipw_net_set_mac_address’:
/root/Download/ipwraw-ng/ipwraw.c:7610: warning: too few arguments for format
/root/Download/ipwraw-ng/ipwraw.c: In function ‘ipw_up’:
/root/Download/ipwraw-ng/ipwraw.c:8081: warning: too few arguments for format
/root/Download/ipwraw-ng/ipwraw.c: In function ‘ipw_pci_probe’:
/root/Download/ipwraw-ng/ipwraw.c:8737: error: ‘SA_SHIRQ’ undeclared (first use in this function)
/root/Download/ipwraw-ng/ipwraw.c:8737: error: (Each undeclared identifier is reported only once
/root/Download/ipwraw-ng/ipwraw.c:8737: error: for each function it appears in.)
/root/Download/ipwraw-ng/ipwraw.c:8743: error: implicit declaration of function ‘SET_MODULE_OWNER’
make[2]: *** [/root/Download/ipwraw-ng/ipwraw.o] Error 1
make[1]: *** [_module_/root/Download/ipwraw-ng] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.25.11-97.fc9.i686'
make: *** [modules] Error 2

Wayne
27th July 2008, 04:08 AM
Are you trying to install AirCrack?

Wayne

hattrickinc
27th July 2008, 04:11 AM
No, I am trying to compile programs.
no matter what I compile, I get these errors.

No one else had this problem when they first installed?
Something I should have enabled setting up the install?
lol I'm pulling my hair out here!

GallComp
27th July 2008, 04:37 AM
I am sorry but the software you mention you want to compile is quite questionable, and for other information found by the staff I will proceed to close this thread.

Seve
27th July 2008, 04:38 AM
No, I am trying to compile programs.
no matter what I compile, I get these errors.Why would you say something like this in response to Wayne's question when you already have posted evidence to the contrary?

root@localhost ipwraw-ng
What is Aircrack-ng ?
http://www.aircrack-ng.org/doku.php

Aircrack-ng is an 802.11 WEP and WPA-PSK keys cracking program that can recover keys once enough data packets have been captured.

Seve

GallComp
27th July 2008, 04:46 AM
Also You are now warned not to pursue this matter any further or you will be banned from the forums.