PDA

View Full Version : F9_x64: gdm huge font size with livna nvidia



stefan1975
26th July 2008, 05:24 PM
Hi all,

i have a strange issue that is not very serious but the fact that I have not been able to solve it bugs me still.

I am running F9_x64 fully updated on my laptop with a nvidia quadro 350 video card and a 1900x1200 resolution.

After the default install I had of course the default 'nv' driver which worked perfectly apart from compositing. GDM was also looking fine in the same resolution as my desktop.

Now I have installed the latest kmod nvidia drivers from livna and after logging in hey work great, i have compiz working perfectly although I did have to manually lower the dpi to 96 in the font config section o get the fonts look small again.

However tuning down the dpi did not help at all for the GDM login screen, this is HUGE. it seems like it is either a larger font, larger dpi (160 or so) or 1400x900 resolution.

I would like to have a "tiny" GDM login screen again, same as my 1900x1200 96dpi desktop with the nvidia driver and compiz enabled but for the life of me I cannot find any place I can influence this. (like a -X 96 in gdm.conf in the older versions of GDM).

does anyone have an idea as how to solve this but keeping the binary driver and settings?

The strange thing is that on my desktop with a geforce 6200 at 1280x1024 this issue does not seem to appear when running the same nvidia driver, or it must be because the resolution is lower in the first place.

thanks.
stefan

null_pointer_us
26th July 2008, 07:42 PM
If you have a laptop with 1900x1200, then your DPI is probably a lot higher than 96. DPI is the number of dots (i.e. pixels) per inch. My 1680x1050 desktop monitor has average DPI of 89, so installing the livna nvidia drivers (?) actually made my Fedora fonts a little smaller.

Adjusting font size for the monitor's DPI is actually a good thing. One problem is that we don't have apps that universally let us adjust their font sizes and image scaling to match how we use them (i.e. maximized, tiled, etc.). Another problem is that AA'd low-dpi fonts don't look very good.

Maybe you could check the login script, the one that starts GDM. IIRC, there was some kind of font DPI setting or parameter, but that was a long, long time ago. xorg's config file might be another good place to look, if that affects GDM.

Seve
26th July 2008, 07:51 PM
Hello:
Try adding the following to the Section "Device" in your /etc/X11/xorg.conf

Option "DPI" "96 x 96"

Seve

stefan1975
26th July 2008, 08:17 PM
If you have a laptop with 1900x1200, then your DPI is probably a lot higher than 96. DPI is the number of dots (i.e. pixels) per inch. My 1680x1050 desktop monitor has average DPI of 89, so installing the livna nvidia drivers (?) actually made my Fedora fonts a little smaller.

Adjusting font size for the monitor's DPI is actually a good thing. One problem is that we don't have apps that universally let us adjust their font sizes and image scaling to match how we use them (i.e. maximized, tiled, etc.). Another problem is that AA'd low-dpi fonts don't look very good.

Maybe you could check the login script, the one that starts GDM. IIRC, there was some kind of font DPI setting or parameter, but that was a long, long time ago. xorg's config file might be another good place to look, if that affects GDM.

well i do not know what the default DPI for my resolution would be, I just know that I always prefer a big resolution of 1900x1200 with a small DPI of 96 which gives me a large desktop with small windows and small fonts allowing a maximum of information on the screen. 96DPI with medium AA, lcd screen selected always gives me the best result.

stefan

stefan1975
26th July 2008, 08:20 PM
Hello:
Try adding the following to the Section "Device" in your /etc/X11/xorg.conf

Option "DPI" "96 x 96"

Seve

hi! that actually worked! thank a lot for that tip, and here I was thinking I knew everything about xorg. I still think it is odd that you have to set DPI in two places for it to work everywhere. In the gnome configuration panel did the trick for all (GTK and QT) apps and the xorg.conf DPI setting just worked for the new GDM (which I love by the way but find hugely under documented and not very configurable).

It would be great if this bit improved for linux in general. 4 places to set my display configuration (livna-config-display, system-config-somewhat, gnome, nvidia-settings) all influencing eachother and overwriting settings.

anyway for now all is good again.

thanks a lot,
stefan

mcmackin
8th August 2008, 04:28 AM
Adding that setting in my xorg.conf did not change the gdm font size. Is there no gdm config tool like I find in Ubuntu?