PDA

View Full Version : Firefox in Gnome is so slow!



Brook
26th July 2008, 03:28 PM
Normally,I surf the internet with firefox in X server.I input the command "startx" and enter the Gnome.But I find that Gnome is so slower than windows,especially surfing the internet with firefox.The firefox is very slow just like the other applications.For example,when I switch different tabs in FF,I have to wait for 1 second.And the scrolling is slow too.What's wrong?Is it my system's problems or others'?Do you have the same problems?

stefan1975
26th July 2008, 05:31 PM
for me FF3 is also slow in Fedora(9). but gnome is actually rather fast.
I have filed a bug for the slowness of firefox that imho is mainly due to 11mb addons by default:

https://bugzilla.redhat.com/show_bug.cgi?id=456045

But it is closed as WONTFIX, so i switched to opera9.51 instead ..... which is *fast* (really!) but won't let me browse the fedora forums (some bug i believe in opera). so now I use opera for all sites apart from the forum for which I use my slow firefox.

but then i do not know your install, your architecture or hardware so your problem might be totally different and related to video drivers or something.

stefan

sidebrnz
27th July 2008, 01:02 AM
Have you considered installing Fasterfox? It might help.

Demz
27th July 2008, 01:24 AM
try disabling some Language Packs that you do not need,,that may speed it up

marko
27th July 2008, 01:39 AM
FF3 in general has some performance slowing things turned on by default.
I turn off smooth scroll:
(Edit->Preferences->Advanced->General-> "Use smooth scrolling" (uncheck)

and the "warn me if the site I'm visiting is a suspected {attack|forgery} site"
(Edit->Preferences->Security uncheck those two)

Although the latter was mostly a problem back in the FF3 beta when
there was some kind of bug and the sqlite file would balloon up.
Now that's fixed it might be ok to have that on.

Wayne
27th July 2008, 01:43 AM
There was a similar thread not too long ago linking to a site with some performance tips. Maybe search through the forum?

Wayne

JohnVV
27th July 2008, 04:31 AM
Hi Brook
Normally,I surf the internet with firefox in X server.I input the command "startx" and enter the Gnome.
if you are starting Gnome ( by hand with typing "startx") i take it you don't have a driver installed for the graphics card or a card .
Is this from the installer installing in "text only" ,run level3 or did you reset inittab to
"id:3:initdefault: "from "id:5:initdefault:" . With no driver or card then most things will be slow.

Wayne
27th July 2008, 04:34 AM
Found the link:

http://isaytech.blogspot.com/2008/06/how-to-optimize-firefox-3.html

Wayne

Brook
27th July 2008, 05:35 AM
Thank you ,guys.I will try those ways.
I love Fedora,and I won't be disappointed at it for ever,because she is improving.