PDA

View Full Version : yum update depsolving error



sanjay_ankur
26th July 2008, 03:20 PM
Hi all..

My yum update is giving this error..



Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package gnome-keyring-devel.x86_64 0:2.22.3-1.fc9 set to be updated
---> Package openoffice.org-writer.x86_64 1:2.4.1-17.4.fc9 set to be updated

...

....

.....


---> Package libidn.i386 0:0.6.14-7 set to be updated
---> Package setools-libs.x86_64 0:3.3.4-1.fc9 set to be updated
---> Package libpaper.x86_64 0:1.1.23-2.fc9 set to be updated
--> Running transaction check
---> Package kmod-nvidia-2.6.25.11-97.fc9.x86_64.x86_64 0:173.14.09-5.lvn9 set to be updated
--> Processing Dependency: kernel-uname-r = 2.6.25.11-97.fc9.x86_64 for package: kmod-nvidia-2.6.25.11-97.fc9.x86_64
---> Package cyrus-sasl-lib.i386 0:2.1.22-13.fc9 set to be updated
---> Package sqlite.i386 0:3.5.6-2.fc9 set to be updated
--> Processing Dependency: libreadline.so.5 for package: sqlite
--> Running transaction check
---> Package kmod-nvidia-2.6.25.11-97.fc9.x86_64.x86_64 0:173.14.09-5.lvn9 set to be updated
--> Processing Dependency: kernel-uname-r = 2.6.25.11-97.fc9.x86_64 for package: kmod-nvidia-2.6.25.11-97.fc9.x86_64
---> Package readline.i386 0:5.2-13.fc9 set to be updated
--> Finished Dependency Resolution
kmod-nvidia-2.6.25.11-97.fc9.x86_64-173.14.09-5.lvn9.x86_64 from livna has depsolving problems
--> Missing Dependency: kernel-uname-r = 2.6.25.11-97.fc9.x86_64 is needed by package kmod-nvidia-2.6.25.11-97.fc9.x86_64-173.14.09-5.lvn9.x86_64 (livna)


I used the akmod-nvidia.. I havent got kmod-nvidia installed.



[root@Ankur ~]# rpm -q kmod-nvidia
package kmod-nvidia is not installed


I updated the kernel kernel-devel and kernel-headers along with akmod-nvidia.
Can someone please help me out here?? I want to update my system :(

Thank you ,

Regards,

Ankur

sanjay_ankur
26th July 2008, 04:11 PM
hi,

I managed to solve it.. I am not sure , however, if this is the correct method.
I excluded the kmod-nvidia packages in the livna.repo file by adding the line
exclude=kmod-nvidia

The dep solving error isn't turning up now..

regards,

Ankur

albiii
7th August 2008, 01:08 PM
Well, you made the "error" go away, but didn't fix the problem.
I suspect that your updates repository is not enabled or you would have the new kernel.

sudo vi /etc/yum.repos.d/fedora-updates.repo

<find the line that says "enabled', change the "0" to a "1">
<it should read>

[updates]
name=Fedora Core $releasever - $basearch - Updates
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/$releasever/$basearch/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-fc$releasever&arch=$basearch
enabled=1
gpgcheck=1

<The do a yum update. You may have dependency issues due to not having ben getting updates for a while, so you may have to update peicemeal....>

sanjay_ankur
8th August 2008, 06:52 AM
I have updates enabled.. Its something to do with the kmod that akmods makes.