PDA

View Full Version : audacity plays 'silently'



Ian.Davidson
26th July 2008, 02:01 PM
I am running F9.

When I attempt to play WAV files using audacity, no sound comes out - although the 'meter' moves to show that it recognises it should be playing. Other things (such as Movie Player) are able to play the files.

Why can audacity not speak?

Ian

bee
26th July 2008, 02:04 PM
Hi. I don't know, i've never used that software nor got that problem, but maybe the audio device is busy by some other application? or maybe the output device in "audacity" is wrong?(check the options)

:)

JEO
26th July 2008, 02:09 PM
According to this site:
http://www.pulseaudio.org/wiki/PerfectSetup#Audacity

Audacity does not support pulseaudio. You can use pasuspender to run it without pulseaudio though.

Ian.Davidson
26th July 2008, 02:53 PM
Thanks Jeo, That works now.

I now have an 'ease of use' question.

If I right click a file in a folder, I can 'Open with Audacity' - but that does not have the pasuspender prepended to it. I have found that I can run pasuspender -- audacity from the command line, and then drag and drop the audio file into audacity.

My 'users' will not enjoy having to run like that. I tried putting the command into a launcher on my desktop - but the result was that I got audacity without the pasuspend being in effect. Is there a way I can get audacity to start 'easily'?

Ian

mwhidby
22nd August 2008, 04:02 PM
Ian,
You could try this - I think it will work.
Rename /usr/bin/audacity to something like /usr/bin/audacity-wrapped
Create a one-line shell script called /usr/bin/audacity:-


#!/bin/sh
pasuspender -- audacity-wrapped $*

Make it executable with chmod 755 /usr/bin/audacity, and then try 'Open with'.
Judging from the output of 'ps' it looks as though it's doing the right thing but
curiously for me I never needed to use pasuspender. (In my case the silent playback
was caused by an old .audacity-data directory.)