PDA

View Full Version : openemm and error after first execution



ls-l
26th July 2008, 12:56 PM
I've installed OpenEMM on Fedora Core 5 using this tutorial:
http://www.openemm.org/wiki/Installation:InstallGuideRHEL

But after first run I get an error:

An error occurred
Cause: javax.servlet.ServletException: org.springframework.jdbc.UncategorizedSQLException : Hibernate operation: Cannot open connection; uncategorized SQLException for SQL [???]; SQL state [null]; error code [0]; Cannot create PoolableConnectionFactory (Access denied for user 'agnitas'@'MY_IP' (using password: YES)); nested exception is org.apache.commons.dbcp.SQLNestedException: Cannot create PoolableConnectionFactory (Access denied for user 'agnitas'@'MY_IP' (using password: YES))

in the places signed as 'My_IP' is my correct IP

I've created in the database user 'agnitas' and It seems that it's the user using which the application is working with MySQL. That error is maybe because agnitas ma zle haslo, but the system gives it automatically and during the previous installation it worked. The previous installation worked but I'm afraid I'm doing all the thigs the same. I've no idea how to fix that software

Maybe it's because it's trying to enter by the static IP 'agnitas@staticIP', and I'm supposed to ener by 'agnitas@127.0.0.1'. All in all in MySQL Privlidges it was written that agnitas can enter from outside.. MySQL port is not blocked by iptables because the firewall is disables (only for test reasons).

I realise that it's not the appropriate forum for my problem but I'd like you to give me as many ideas as possible
thanks in advance