PDA

View Full Version : STRANGE PROBLEM - FAT32 not detecting



sharathkumaru
26th July 2008, 10:37 AM
Hi,
I have some strange problem.
I installed fedora 8 in sata 160 gb hard disk, and windows xp on another hard disk(pata).
The problem is one of the drive in my pata hard disk is not detecting. Its a FAT32 drive. There is also another FAT32 drive in pata hard disk which was detecting.

its my music drive which contains 20 gb of songs. So please anybody help me fix the error.

:confused:

Brook
26th July 2008, 12:13 PM
Could you mount it manually?I came across the similiar problem when I used the PartionMagic tool.The partion of windows could't be mounted automatically and manually.Then I check and fix the filesystem's error and bad sectors with the tool of Windows(For example,hit on the property of partion "C",and select "TOOL",then "Begin Check").Restart the system and enter the linux,it works well.

sharathkumaru
26th July 2008, 01:29 PM
Ok thank you. I'll try and then reply the result.

sharathkumaru
26th July 2008, 03:06 PM
I tried it ,but its not working.

alphaindia
26th July 2008, 05:46 PM
have you ensure that the windows was properly shutdown? I have come across similar problem and it was mainly due to improper shutdown of windows. Another thing, have you update your system?

sharathkumaru
26th July 2008, 06:06 PM
It properly shut down no problem in that.
that drive was not detecting from the beggining.
I turned off automatic updates in windows.

Brook
27th July 2008, 05:17 AM
alphaindia's meaning is whether you have updated the Fedora,right?

another thing,Do you select the two options?below
http://hiphotos.baidu.com/%B5%E3%B5%E3%D0%C7%B9%E2/pic/item/d78fdf163d7b8b0f962b433b.jpg
http://hiphotos.baidu.com/%B5%E3%B5%E3%D0%C7%B9%E2/pic/item/54aaa24b924c53e783025c3b.jpg

JohnVV
27th July 2008, 06:00 AM
can you run

su -
fdisk -l
the 2 fat32 partitions should be listed
then edit fstab

su -
mkdir /usr/Fat32_1
gedit /etc/fstab
-- and add to it the fat32 partition
example:

/dev/sdb1 /usr/Fat32_1 vfat defaults 0 0

dev/sdb1 would be changed to yours , like sdb2 ,sda3 ,...
-----------------------------------
i would also back up all of the music on the 2 ( 1996)windows fat32 ) and reformat them to ntfs

alphaindia
27th July 2008, 06:11 AM
Exactly Brook. That's what I meant. Normally, once I have updated my FC, either in FC8 and FC9, it works superbly in detecting and accessing Windows HDD.

sharathkumaru
29th July 2008, 10:37 AM
No I didn't updated fedora. I freshly installed Fedora 8.

This is what I get after the fdisk -l command:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x9a6d6a2a

Device Boot Start End Blocks Id System
/dev/sda1 1 9257 74356821 c W95 FAT32 (LBA)
/dev/sda2 9258 18247 72212175 f W95 Ext'd (LBA)
/dev/sda3 18248 19457 9719325 83 Linux
/dev/sda5 9258 16903 61416463+ b W95 FAT32
/dev/sda6 16904 17920 8169021 b W95 FAT32
/dev/sda7 * 17921 17986 530113+ b W95 FAT32
/dev/sda8 17987 18181 1566306 82 Linux swap / Solaris
/dev/sda9 18182 18247 530113+ 83 Linux

Disk /dev/sdb: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x16531652

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 2432 19535008+ 7 HPFS/NTFS
/dev/sdb2 2433 9729 58613152+ f W95 Ext'd (LBA)
/dev/sdb5 2433 4864 19535008+ 7 HPFS/NTFS
/dev/sdb6 4865 7296 19535008+ b W95 FAT32
/dev/sdb7 7297 9729 19543041 b W95 FAT32


I follwed JohnVV's instructions but here is no change, still not able to detect.

JohnVV
29th July 2008, 09:59 PM
did you reboot
and is there any particular reason you have win xp running on a combination of ntfs and the old fat32
also adding to fstab
/dev/sda1 /mnt/Fat32_1 vfat defaults 0 0
/dev/sda5 /mnt/Fat32_2 vfat defaults 0 0
/dev/sda6 /mnt/Fat32_3 vfat defaults 0 0
/dev/sdb6 /mnt/Fat32_4 vfat defaults 0 0
/dev/sdb7 /mnt/Fat32_5 vfat defaults 0 0
then running


su -
mkdir /mnt/Fat32_1
mkdir /mnt/Fat32_2
mkdir /mnt/Fat32_3
mkdir /mnt/Fat32_4
mkdir /mnt/Fat32_5

use /mnt or /usr that is up to you
then reboot

sharathkumaru
30th July 2008, 11:33 AM
No, not any perticular reason.

After i rebooted, mounting file system failed.

then i added all the five FAT32 partition, and again rebooted.
This time, no failure.
But the drive still missing.
FAT32_4 is missing.
But in the desktop, there was two mounted volumes of the same drive.

sharathkumaru
30th July 2008, 02:43 PM
Thank you its working now.
And one more thing that am not able to copy the files to the drives and gives error message as
<b>"you do not have permission to write to this folder"</b>

I copy some files from desktop and want to paste it to desired folder. But am not able to paste.

sharathkumaru
3rd August 2008, 07:33 PM
The drives that i have mounted are not able to write that is not able to copy anything in to it.
So how can we overcome the problem??

alphaindia
4th August 2008, 11:11 AM
have you tried updating your fc?
su -
yum update

sharathkumaru
4th August 2008, 12:05 PM
Yes, i tried but its not properly working.
Every time I booted and try to update using software updater or add/remove tools or update using yum there was error that another application is running and not able to update.

And one more problem it takes too much time in retrieving software information.
I waited more than an hour to get the update screen..
And some time the system hangs. I have to press reset button again to boot.
:confused:
My system configuration is
AMD Athlon 64bit 2800+,
Asrock k8upgrade vm 800,
512 mb ram,
160 gb sata hard disk and 80 gb pata.

alphaindia
4th August 2008, 02:49 PM
Bro, just kill the software update.
command : kill <ID>

Btw, it will take long. U are talking about more than 1GB or software update. Btw, y r u using fc8 and not fc9?

sharathkumaru
9th August 2008, 04:44 PM
I update some parts of fedora8 using software updates.
I selected only some updates only because it will take more time to update all components.
There are around 260 update packages.
Then it took some time to update and asks for reboot. So i just rebooted. Then there was another fedora appears in grub boot loader. I selected new one. It booted normally. thereafter there is no logon screen. There is only a blank screen with the cursor processing.
I kept quite for about 30 minutes still no change.

Is there any solution??

alphaindia
10th August 2008, 01:42 PM
First of all, the new fedora you mentioned in the grub boot loader is your new kernel. Its normally advisable to keep a minimum of 2-3 kernel at any one time. However, u r ok with the latest one, you may delete the rest.

Secondly, why you choose partial update?

Thirdly, You have to open new threat for new problem/post.

Finally, you can try login to the previous kernel, and reupdate everything.

sharathkumaru
12th August 2008, 01:51 PM
I chose partial update because it will take a lot time i mean to say more than half a day to update all.
It will took around 1 hour to get 25 % of resolving dependencies..
And more over my system hangs too much..

JohnVV
13th August 2008, 06:42 PM
try adding to the end of each fat32 line in fstab
" umask 0 0 0 "
without the ""
but with the missing "FAT32_4" you do have a slightly messed up table . its no biggie and you can live with it , but consider reformatting them all to ntfs and ext3