PDA

View Full Version : FlashPlayer 10 + FF2



AltairJr
26th July 2008, 07:58 AM
after some searching, and randomly trying different solutions I've gotten FP 9 to work - got both video and audio playback of flash content - but I've become aware of the problem that all those wonderful flash content/ads have a tendency(more like compulsive behavior) of liking to be on top of drop down menus.

After cruising google and finding out that as a linux user i'm pretty much up a river until adobe fixes it - Lucky for me, my timing let me know about the FP 10 prerelease that at least appears to have dealt with that... only I have no idea how to get it to install and then work in firefox 2 (ff3 lags bad on my machine)

Note: I am currently in the middle of getting ready for travel and may not have reliable internet where I'm at (last time the network manager didn't want to play nice with their WEPenabled access point - or it might have been WPA - can't recall at the moment) and so I may not be able to immediately reply to helpful solutions after Sunday night/Monday morning

notoriousdb
26th July 2008, 10:26 AM
I have flash 10 installed. Downloaded the tarball from http://labs.adobe.com/downloads/flashplayer10.html uninstalled flash 9, extracted the tarball and then as root went in to the extracted directory and did a
./flashplayer-installer

There is an RPM available too but I dopn't know how reliable this is

mnisay
26th July 2008, 10:27 AM
are you referring for flash player for browser?

if so, try http://www.ilovetux.com/index.php?s=flash+player

dckrinke
20th August 2008, 05:47 AM
mnisay had a link to a website with a simple one line command that setup adobe flashplayer 10, but now that website (ilovetux.com) is down. Did anyone capture that one line command? Could you please repost it here?

TIA

Hlingler
20th August 2008, 05:54 AM
No, but you can get FlashPlayer10 in a couple short steps here: http://labs.adobe.com/technologies/flashplayer10/

RPM available. Note that you must un-install your existing FlashPlayer package first.

V

P.S. FP10 works well here, although I fail to see any advantage over FP9.X at this point.

dckrinke
20th August 2008, 06:05 AM
I tried installing flashplayer that way, but I could not get it installed:
The install script asks the question:
Please enter the installation path of the Mozilla, Netscape,
or Opera browser (i.e., /usr/lib/mozilla):
and I type in
/usr/lib/firefox-3.0.1
but it responds with:
WARNING: Please enter a valid installation path.
and I cannot get it to install.


Do you know how to do this?

Hlingler
20th August 2008, 06:12 AM
Yes. As I said: don't use the install script, get the RPM package instead: http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_install_linux_081108.i386.rpm

V

dckrinke
20th August 2008, 06:35 AM
OK, i tried
rpm -ivh flashplayer10_install_linux_081108.i386.rpm
but it said that I need
libcurl.so.3

I downloaded curl-7.18.2.tar.gz and tried ./configure make make install, but it didn't seem to work, there is still no /lib/libcurl...

Is there another way to get libcurl?

Hlingler
20th August 2008, 06:45 AM
Yes. Go to City-Fan.org repo: http://www.city-fan.org/ftp/contrib/yum-repo/, and fetch the RPM-release package for your flavor of Fedora. Install the city-fan.org release RPM. Enable the city-fan.org repo. Then:
yum install libcurl7155
~]$ locate libcurl.so.3
/usr/lib/libcurl.so.3
/usr/lib/libcurl.so.3.0.0
~]$ rpm -qf /usr/lib/libcurl.so.3
libcurl7155-7.15.5-5.cf.fc8.i386
~]$V

P.S. Package libcurl7155 may drag other packages in with it as dependencies (curl, etc.), just let it install whatever it wants.
P.P.S. Install both the x86 and x86_64 packages just to cover all possibilities.

dckrinke
20th August 2008, 07:09 AM
I tried, but it still doesn't work.

[root@localhost flashplayer]# yum install libcurl7155
Loaded plugins: refresh-packagekit
city-fan.org | 1.9 kB 00:00
primary.sqlite.bz2 | 89 kB 00:01
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package libcurl7155.i386 0:7.15.5-5.cf.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
libcurl7155 i386 7.15.5-5.cf.fc9 city-fan.org 184 k

Transaction Summary
================================================== ===========================
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 184 k
Is this ok [y/N]: y
Downloading Packages:
(1/1): libcurl7155-7.15.5-5.cf.fc9.i386.rpm | 184 kB 00:03
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID b56a8bac
Importing GPG key 0xB56A8BAC "city-fan.org software librarian <software@city-fan.org>" from /etc/pki/rpm-gpg/RPM-GPG-KEY-city-fan.org
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : libcurl7155 [1/1]

Installed: libcurl7155.i386 0:7.15.5-5.cf.fc9
Complete!

[root@localhost flashplayer]# rpm -qf /usr/lib/libcurl.so.3
libcurl7155-7.15.5-5.cf.fc9.i386
[root@localhost flashplayer]# rpm -e flash-plugin-[root@localhost flashplayer]# rpm -ivh flashplayer10_install_linux_081108.i386.rpm
Preparing... ########################################### [100%]
1:flash-plugin ########################################### [100%]



So the plugin seemed to install, but still no working flashplayer.

Thanks for the help, but I have to quit for tonight

Would it be OK to post the one line install script that ilovetux had on this thread? At least that worked easily.

Hlingler
20th August 2008, 07:15 AM
Sorry that didn't work out for you.

If I had that one-line script, I would have gladly posted it first thing, but I simply do not have it.

Perhaps later, someone who does have it will see this thread, and post it. Or, perhaps ilovetux will pay his ISP bill and get that web site back up. :)

V

mnisay
20th August 2008, 09:04 AM
Sorry that my site is down, an having technical issues with my hosting provider due to excessive amount of bots crawling the site :( so the site was suspended

To install flash 10 with your firefox, simply follow these steps

1. uninstall existing flash-plugin rpm package like so

# rpm -qa | grep flash-plugin | xargs rpm -e

2. uninstall any gnash and swfdec rpm package like so

# rpm -qa | grep swfdec | xargs rpm -e
# rpm -qa | grep gnash | xargs rpm -e

uninstalling mozplugger rpm is not required but optional

3. for i386 machines, download and install every rpm that you can find from below link

http://kojipkgs.fedoraproject.org/packages/curl/7.18.2/3.fc9/i386/

if you dont have i386 machines, find your machine here and get the rpms under your labeled machine folder

http://kojipkgs.fedoraproject.org/packages/curl/7.18.2/3.fc9/

EDITED:
If F9 is not your working OS, choose libcurl from your OS here

http://kojipkgs.fedoraproject.org/packages/curl/7.18.2/

Ensure that curl library is within the search path

# updatedb ; locate libcurl.so.3
/usr/lib/libcurl.so.3

Make sure that your current OS is F9 . the above link source is update for curl and its library. Ensure also that firefox binary can be found from default path

# which firefox
/usr/bin/firefox

4. now, download adobe flash plugin rpm below link and install it via rpm

# wget -c http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_install_linux_081108.i386.rpm

# rpm -ivh flashplayer10_install_linux_081108.i386.rpm

the above rpm is for fedora 9 i386 , machines, no other rpms are available for other archs.

5. Go to /usr/lib/mozilla/plugins/ folder

# cd /usr/lib/mozilla/plugins/
# ls -la /usr/lib/mozilla/plugins/

and make sure you have the following lines

lrwxrwxrwx 1 root root 39 2008-08-20 08:40 libflashplayer.so -> /usr/lib/flash-plugin/libflashplayer.so

6. Restart your firefox and head on to www.youtube.com to test your flash player. This should work out right and this is how I remember my installation yesterday with FF3 under F9.

Optionally, launch firefox, enter about:config as its URL and check for adobe flash plugin for browser there

Hope this helps.

Hlingler
20th August 2008, 09:10 AM
He may have to remove the libcurl package from city-fan.org repo first, since it may conflict with the curl package(s) from Fedora repos.

I suspect it was the missing sym-links that were the problem, and either libcurl from city-fan.org, or the standard fedora curl packages, will both work equally fine.

V

leigh123linux
20th August 2008, 10:53 AM
You can also use AdobeReader to satisfy the deps ! , just link the required libs to /usr/lib

i.e


ln -sf /opt/Adobe/Reader8/Reader/intellinux/lib/libcurl.so.3 /usr/lib



[root@localhost leigh05]# rpm -qa |grep dobe
AdobeReader_enu-8.1.2_SU1-1.i486
adobe-release-i386-1.0-1.noarch
[root@localhost leigh05]# locate libcurl.so.3
/opt/Adobe/Reader8/Reader/intellinux/lib/libcurl.so.3
/opt/Adobe/Reader8/Reader/intellinux/lib/libcurl.so.3.0.0
[root@localhost leigh05]# locate libssl.so.0.9.7
/opt/Adobe/Reader8/Reader/intellinux/lib/libssl.so.0.9.7
[root@localhost leigh05]# locate libcrypto.so.0.9.7
/opt/Adobe/Reader8/Reader/intellinux/lib/libcrypto.so.0.9.7
[root@localhost leigh05]#



[root@localhost leigh05]# mozilla-plugin-config -i
*** NSPlugin Viewer *** ERROR: libcurl.so.3: cannot open shared object file: No such file or directory
*** NSPlugin Viewer *** ERROR: libcurl.so.3: cannot open shared object file: No such file or directory
[root@localhost leigh05]# locate libcurl.so
/opt/Adobe/Reader8/Reader/intellinux/lib/libcurl.so
/opt/Adobe/Reader8/Reader/intellinux/lib/libcurl.so.3
/opt/Adobe/Reader8/Reader/intellinux/lib/libcurl.so.3.0.0
/usr/lib/libcurl.so.4
/usr/lib/libcurl.so.4.1.0
/usr/lib/googleearth/libcurl.so.4
/usr/lib64/libcurl.so
/usr/lib64/libcurl.so.4
/usr/lib64/libcurl.so.4.1.0
[root@localhost leigh05]# ln -sf /opt/Adobe/Reader8/Reader/intellinux/lib/libcurl.so.3 /usr/lib
[root@localhost leigh05]# mozilla-plugin-config -i
*** NSPlugin Viewer *** ERROR: libssl.so.0.9.7: cannot open shared object file: No such file or directory
*** NSPlugin Viewer *** ERROR: libssl.so.0.9.7: cannot open shared object file: No such file or directory
[root@localhost leigh05]# locate libssl.so.0.9
/lib/libssl.so.0.9.8g
/lib64/libssl.so.0.9.8g
/opt/Adobe/Reader8/Reader/intellinux/lib/libssl.so.0.9.7
/var/lib/mock/fedora-9-i386/root/lib/libssl.so.0.9.8g
/var/lib/mock/fedora-9-x86_64/root/lib64/libssl.so.0.9.8g
[root@localhost leigh05]# ln -sf /opt/Adobe/Reader8/Reader/intellinux/lib/libssl.so.0.9.7 /usr/lib
[root@localhost leigh05]# mozilla-plugin-config -i
*** NSPlugin Viewer *** ERROR: libcrypto.so.0.9.7: cannot open shared object file: No such file or directory
*** NSPlugin Viewer *** ERROR: libcrypto.so.0.9.7: cannot open shared object file: No such file or directory
[root@localhost leigh05]# locate libcrypto.so.0.9
/lib/libcrypto.so.0.9.8g
/lib64/libcrypto.so.0.9.8g
/opt/Adobe/Reader8/Reader/intellinux/lib/libcrypto.so.0.9.7
/usr/lib/googleearth/libcrypto.so.0.9.8
/var/lib/mock/fedora-9-i386/root/lib/libcrypto.so.0.9.8g
/var/lib/mock/fedora-9-x86_64/root/lib64/libcrypto.so.0.9.8g
[root@localhost leigh05]# ln -sf /opt/Adobe/Reader8/Reader/intellinux/lib/libcrypto.so.0.9.7 /usr/lib
[root@localhost leigh05]# mozilla-plugin-config -i
[root@localhost leigh05]#

s0d
21st August 2008, 06:32 AM
hi there guys,
I too am trying to install FP10 and when i download and install the RPMs from the site linked in on Mnisay's post i get the following install error:

libcurl = 7.18.2-1.fc9 is needed by package libcurl-devel-7.18.2-1.fc9.x86_64
libcurl.so.4 is needed by package nspluginwrapper-1.1.0-5.fc9.i386

i run an x86_64 edition of Fedora 9 and am downloading the correct packages. I wonder whether i have the wrong nspluginwrapper?

Hlingler
21st August 2008, 06:41 AM
You do not need libcurl-devel, unless you plan to compile programs from source code. You may safely remove that package, which will eliminate at least one road-block, perhaps it will allow the whole transaction to complete cleanly.

V