PDA

View Full Version : Several odd issues in Fedora 9



PreacherBill3
25th July 2008, 10:27 PM
I've raised these issues elsewhere, and it seems that no one has any ideas. So I'm raising them here to see if anyone here can help.

I seem to have several odd issues with Fedora 9, some perhaps related, some not.

1) The network manager icon on the panel tells me the network is not connected, even when it is. I can ping all other systems on our local network, and I have no trouble browsing to internet sites.

2) Perhaps related to this, Firefox always comes up in "work offline" mode. Simply unchecking it makes everything work fine. UPDATE - this only seems to be happening when I'm logged in as root. Since this is a server, that's most of the time.

3) If a folder on the desktop is selected, and then double-clicked to try and open it, nothing happens. Selecting another icon on the desktop and then going back to the folder seems to take care of this. This is also happened with other folders not on the desktop, but it doesn't seem to be consistent with them.

4) When I run the Update System utility and click the update button, nothing happens. The same is true when I run Add/Remove Software and click the install button. No error messages, nothing. Running yum directly from the command line works fine.

None of these are critical issues. But I would like to get them fixed. System is an AMD Sempron 2600 processor, 512 mb memory, ATI Radeon 9200 video card.

Any clues as to where to look are appreciated.

Thanks

Bill

scotty38
25th July 2008, 11:55 PM
1. I've seen this before, if you open up thy applet is the adapter designation blank, with Lo as an option in the dropdown? type in eth0 and see if it starts responding.
Failing that turn off NetworkManager and use network instead.

2. You shouldn't be logged in as root really.....

3. don't know

4. Is this as root again? It should work ok logged in as a normal user, juts give root's credentials when required.

gianugo64
2nd August 2008, 05:01 AM
I have network problems. To let network run, I had to disable NetworkManager, as suggested by some forums. Now I can navigate Internet properly, but still the software install / remove feature thinks I'm always offline, refuses to install anything, and there's no way to convince it of the contrary. Strangely enough, yum installer, called from the command line, works perfectly. Any ideas?

Gianugo

Da_Pipe
23rd August 2008, 09:21 PM
I am having the same issues with a fresh install of core 9 updated. Any suggestions of than disable network manager?

marcrblevins
24th August 2008, 12:28 AM
Try:


su -
yum update NetworkManager

Ssl
24th August 2008, 12:54 AM
PreacherBill3: Avoid disabling networkmanager as many desktop applications (epiphany web browser, liferea feed reader etc.) nowadays depend on networkmanager for net state - connected or not and go into offline.

For solving your problem - hm, probably you did upgrade of earlier fedora relese? - try to disable System --> Administration --> Network device control and let nm-applet do the job. Keep your software updated as suggested.