PDA

View Full Version : cannot install mplayer on fedora 9



zakhmi
25th July 2008, 09:55 PM
while installing (doing make)mplayer in fedora 9 i got the following eror message:

dct64_sse.c:73: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
dct64_sse.c:102: error: can't find a register in class 'GENERAL_REGS' while reloading 'asm'
dct64_sse.c:48: error: 'asm' operand has impossible constraints
dct64_sse.c:48: error: 'asm' operand has impossible constraints

i am not having any internet connection.so,i can not do yum install mplayer.It worked fine with fedora 7 & 8..plz help..

Seve
25th July 2008, 10:22 PM
Hello:
Does ./configure provide any clues ?

I just downloaded mplayer and ran ./configure and make without a problem on F8 x86_64

Seve

brebs
25th July 2008, 10:24 PM
Mplayer svn compiles fine for me in Fedora 9. It's in my repo (ftp://ftp.brebs.me.uk/fedora/9/).

zakhmi
26th July 2008, 10:06 AM
i notice that i have installed fedora i686 on my i386 system..is that a problem for mplayer ??

mnisay
26th July 2008, 11:33 AM
if you can see red lights, that is a problem i guess.

basically, my choice of players is VLC (http://www.ilovetux.com/2007/07/vlc-media-player-install-howto.html) , suits for me though

zakhmi
26th July 2008, 07:39 PM
there isn't anything like that..any other suggestion

mnisay
26th July 2008, 10:32 PM
am not sure how you are posting here since you do not have any internet connection.

if you do have, simply

# yum update mplayer*

scottro
26th July 2008, 11:32 PM
The i386 and i686 shouldn't be an issue. The i386 is the basic generic version.

Has anyone suggested that you add the livna repo and install it via yum? (I don't see that specifically mentioned, only a mention that you do yum install mplayer.)

It is in the livna repos and has worked for me on a 32 bit and 64 bit machine.

zakhmi
27th July 2008, 12:01 AM
hey!!i'm posting here from my friend's windows system...what i want to say is that right now i haven't configured my internet connection since its a broadcom chip that sure is a headache to connect in a wpa
internet connection..so i cannot do yum or get help from net directly by updating mplayer

brebs
27th July 2008, 11:36 PM
Transfer the RPM files using a recordable CD or USB stick. Then use e.g.:

yum --nogpgcheck localinstall mplayer-blahblah.rpm