PDA

View Full Version : Problem compiling Gnome-Do



KeefTM
25th July 2008, 06:29 PM
Hey, I'm trying to compile the latest version of Gnome-Do and I'm running into some problems. I'm a linux n00b so please bear with me. I am missing some dependencies, and I can't seem to find the proper ones to install from yum. I am running Fedora release 8 (Werewolf).


checking for LIBDO... configure: error: Package requirements (glib-2.0 gdk-2.0 gdk-x11-2.0 gtk+-2.0) were not met:

No package 'gdk-2.0' found
No package 'gdk-x11-2.0' found
No package 'gtk+-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBDO_CFLAGS
and LIBDO_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Thanks for the help.

Seve
25th July 2008, 06:36 PM
Hello:
Why not just use yum to install it ?

yum install gnome-do

Seve

KeefTM
25th July 2008, 06:38 PM
Hello:
Why not just use yum to install it ?

yum install gnome-do

Seve

Because yum still has an older 0.4 version, and not the new 0.5 with the new features. I've also ran into some bugs with the version from yum, so I wanted to try the newest version to see if they were fixed.

Seve
25th July 2008, 07:32 PM
Hello:
Try
yum install gtk2-devel

Seve

KeefTM
25th July 2008, 07:46 PM
Hello:
Try
yum install gtk2-devel

Seve

Awesome, that worked. Thanks for the help. Now I went through a bunch of requirements and I was making progress, but I seem to be stuck on the following:


checking for GNOME_DESKTOP_SHARP_20... configure: error: Package requirements (gnome-desktop-sharp-2.0) were not met:

No package 'gnome-desktop-sharp-2.0' found

I tried installing gnome-desktop-devel, but that didn't work.

drewlander
25th July 2008, 08:00 PM
If you install yum-utils, you can just do a yum-builddep gnome-do and it will install all dependencies.

KeefTM
25th July 2008, 08:00 PM
Ok, so I found an rpm for the gnome-desktop-sharp-2.0 source, but running configure spits out the following error:



checking for GTKSHARP... configure: error: Package requirements (gtk-sharp-2.0 >= 2.12.0) were not met:

Requested 'gtk-sharp-2.0 >= 2.12.0' but version of Gtk is 2.10.3

Since 2.10.3 is the version on yum, I guess I have to install the update from source as well, right?

KeefTM
25th July 2008, 08:02 PM
If you install yum-utils, you can just do a yum-builddep gnome-do and it will install all dependencies.

I think that checks the dependencies for the old version of gnome-do that yum has.

drewlander
25th July 2008, 08:51 PM
I think that checks the dependencies for the old version of gnome-do that yum has.
Yes it does.
I do find it does help out though.
Like now for instance, you need to compile a newer version of gtk-sharp (http://www.mono-project.com/GtkSharp)
yum-builddep gtk-sharp2 should install all the needed components for when you compile a newer version of gtk-sharp from source.
In a situation like this when you are trying to compile a package that is newer than what the repositories of your distribution provide, what you are experiencing is common. You either continue to build newer libs, or use "unstable" packages.