PDA

View Full Version : Yum update (many dependency errors)



cc3283@att.com
24th July 2008, 06:20 PM
Hello All,

I upgraded a system from fc6 to f9 using the CDs. I now have many dependency issues when trying to do an update via yum. here is the output. I have run yum clean and some other commands following other post i have found.

Any help would be greatly appriciated, Thanks



Exiting on user cancel
[root@esacdev ~]# yum install python
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: ftp.is.co.za
* livna: mirrors.tummy.com
* updates: ftp.is.co.za
livna | 2.1 kB 00:00
updates | 2.3 kB 00:00
Setting up Install Process
Parsing package install arguments
No package python available.
Nothing to do
[root@esacdev ~]# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
Missing dependencies:
Package opal requires libcrypto.so.6
Package opal requires liblber-2.3.so.0
Package opal requires libldap-2.3.so.0
Package opal requires libldap_r-2.3.so.0
Package opal requires libssl.so.6
Package mysql-devel requires mysql = 5.0.27-1.fc6
Package perl-libxml-perl requires perl(:MODULE_COMPAT_5.8.8)
Package fwbuilder-ipt requires libcrypto.so.6
Package fwbuilder-ipt requires libssl.so.6
Package quagga requires libtermcap.so.2
Package ImageMagick-devel requires ImageMagick = 6.2.8.0-4.fc6
Package perl-Crypt-SSLeay requires libcrypto.so.6
Package perl-Crypt-SSLeay requires libssl.so.6
Package perl-Crypt-SSLeay requires perl(:MODULE_COMPAT_5.8.8)
Package xchat requires libcrypto.so.6
Package xchat requires libssl.so.6
Package xchat requires perl(:MODULE_COMPAT_5.8.8)
Package gimp-print-plugin requires libgimpprint.so.1
Package net-snmp-devel requires libnetsnmp.so.10
Package net-snmp-devel requires libnetsnmpagent.so.10
Package net-snmp-devel requires libnetsnmphelpers.so.10
Package net-snmp-devel requires libnetsnmpmibs.so.10
Package net-snmp-devel requires libnetsnmptrapd.so.10
Package net-snmp-devel requires libsnmp.so.10
Package net-snmp-devel requires net-snmp = 1:5.3.1
Package ckermit requires libcrypto.so.5
Package ckermit requires libssl.so.5
Package ckermit requires libtermcap.so.2
Package java-1.4.2-gcj-compat-devel requires java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp.110
Package java-1.4.2-gcj-compat-devel requires python(abi) = 2.4
Package perl-XML-Dumper requires perl(:MODULE_COMPAT_5.8.8)
Package neon-devel requires libneon.so.25
Package neon-devel requires neon = 0.25.5-5.1
Package db4-utils requires db4 = 4.3.29-9.fc6
Package db4-utils requires libdb-4.3.so
Package perl-XML-Encoding requires perl(:MODULE_COMPAT_5.8.6)
Package openmotif requires /usr/X11R6/lib/X11/XKeysymDB
Package ImageMagick-perl requires /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi
Package ImageMagick-perl requires ImageMagick = 6.2.8.0-4.fc6
Package libfwbuilder requires libcrypto.so.6
Package libfwbuilder requires libssl.so.6
Package struts11 requires libgcj.so.6
Package elfutils-libelf-devel-static requires elfutils-libelf-devel-i386 = 0.131-1.fc6
Package gnome-python2-gtksourceview requires gnome-python2-desktop = 2.16.0-1.fc6
Package gnome-python2-gtksourceview requires python(abi) = 2.4
Package 4Suite requires python(abi) = 2.4
Package 4Suite requires python-abi = 2.4
Package elfutils-devel requires elfutils-libelf-devel-i386 = 0.131-1.fc6
Package elfutils-devel requires elfutils-libs-i386 = 0.131-1.fc6
Package java-1.4.2-gcj-compat-javadoc requires java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp.110
Package perl-XML-LibXML requires perl(:MODULE_COMPAT_5.8.8)
Package gmpc requires libcrypto.so.6
Package gmpc requires libcurl.so.3
Package gmpc requires libssl.so.6
Package scim-devel requires scim-libs = 1.4.4-37.fc6
Package libnetfilter_conntrack-devel requires libnetfilter_conntrack = 0.0.50-2.fc6
Package perl-Net-IP requires perl(:MODULE_COMPAT_5.8.8)
Package fwbuilder requires libcrypto.so.6
Package fwbuilder requires libssl.so.6
Package net-snmp-perl requires libcrypto.so.6
Package net-snmp-perl requires libnetsnmp.so.10
Package net-snmp-perl requires libnetsnmpagent.so.10
Package net-snmp-perl requires libnetsnmphelpers.so.10
Package net-snmp-perl requires libnetsnmpmibs.so.10
Package net-snmp-perl requires libsensors.so.3
Package net-snmp-perl requires net-snmp = 1:5.3.1
Package pyOpenSSL requires libcrypto.so.6
Package pyOpenSSL requires libssl.so.6
Package pyOpenSSL requires python(abi) = 2.4
Package perl-LDAP requires perl(:MODULE_COMPAT_5.8.8)
Package java-1.4.2-gcj-compat-src requires java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp.110
Package PyXML requires python(abi) = 2.4
Package perl-XML-Grove requires perl(:MODULE_COMPAT_5.8.8)
Package ghostscript-devel requires ghostscript = 8.15.4-1.fc6
Package perl-XML-LibXML-Common requires perl(:MODULE_COMPAT_5.8.8)
Package ekiga requires libedataserver-1.2.so.7
Package perl-Parse-Yapp requires perl(:MODULE_COMPAT_5.8.8)
Package lcms-devel requires lcms = 1.15-1.2.2
Package freeradius requires libcrypto.so.6
Package freeradius requires libldap_r-2.3.so.0
Package freeradius requires libsnmp.so.10
Package freeradius requires libssl.so.6
Package autofs requires liblber-2.3.so.0
Package autofs requires libldap_r-2.3.so.0
Package libgcj-src requires libgcj = 4.1.2-13.fc6
Package net-snmp-utils requires libcrypto.so.6
Package net-snmp-utils requires libnetsnmp.so.10
Package net-snmp-utils requires net-snmp = 1:5.3.1
Package gftp requires libcrypto.so.6
Package gftp requires libssl.so.6
Package perl-XML-SAX requires perl(:MODULE_COMPAT_5.8.8)
Package rhnlib requires python(abi) = 2.4
Package up2date requires python(abi) = 2.4
Package up2date requires python-optik
Package gnuplot requires libtermcap.so.2
Package perl-XML-NamespaceSupport requires perl(:MODULE_COMPAT_5.8.8)
Package libsane-hpaio requires libcrypto.so.6
Package libsane-hpaio requires libnetsnmp.so.10
Package perl-XML-Twig requires perl(:MODULE_COMPAT_5.8.8)

[root@esacdev ~]# package-cleanup -d
Setting up yum
[root@esacdev ~]#

cc3283@att.com
24th July 2008, 06:25 PM
more info
see attached file


[root@esacdev ~]# yum update
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: ftp.is.co.za
* livna: mirrors.tummy.com
* updates: ftp.is.co.za
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: libfwbuilder.so.6 for package: fwbuilder
--> Processing Dependency: libfwbuilder.so.6 for package: fwbuilder-ipt

leigh123linux
24th July 2008, 06:40 PM
Check for problems and orphans ( you may need to remove some orphans to enable your system to update )


su
package-cleanup --problems
package-cleanup --orphans

cc3283@att.com
28th July 2008, 03:09 PM
Thanks leigh123,

Attached is the full output, here is a truncated version:

[root@esacdev ~]# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
Missing dependencies:
Package opal requires libcrypto.so.6
Package opal requires liblber-2.3.so.0
Package opal requires libldap-2.3.so.0
Package opal requires libldap_r-2.3.so.0
Package opal requires libssl.so.6
Package mysql-devel requires mysql = 5.0.27-1.fc6
Package perl-libxml-perl requires perl(:MODULE_COMPAT_5.8.8)
Package fwbuilder-ipt requires libcrypto.so.6
Package fwbuilder-ipt requires libssl.so.6
Package quagga requires libtermcap.so.2
Package ImageMagick-devel requires ImageMagick = 6.2.8.0-4.fc6
Package perl-Crypt-SSLeay requires libcrypto.so.6
Package perl-Crypt-SSLeay requires libssl.so.6


[root@esacdev ~]# package-cleanup --orphans
Setting up yum
mcstrans-0.1.8-3.i386
kernel-devel-2.6.18-1.2798.fc6.i686
jakarta-commons-fileupload-javadoc-1.0-6jpp.1.i386
puretls-javadoc-0.9-0.b5.4jpp.1.i386
gnu-getopt-javadoc-1.0.12-3jpp.1.i386
perl-Parse-Yapp-1.05-36.fc6.noarch
tetex-afm-3.0-36.fc6.i386
net-snmp-devel-5.3.1-15.fc6.i386
ImageMagick-perl-6.2.8.0-4.fc6.i386
radeontool-1.5-3.fc9.i386
diffutils-2.8.1-21.fc9.i386
iptables-ipv6-1.4.0-4.fc9.i386
gnupg-1.4.9-1.fc9.i386

leigh123linux
28th July 2008, 04:34 PM
Post the output for



su
yum clean all
yum update

cc3283@att.com
28th July 2008, 04:54 PM
[root@esacdev ~]# yum clean all
Loaded plugins: fastestmirror, refresh-packagekit
Cleaning up Everything
Cleaning up list of fastest mirrors

[root@esacdev ~]# yum update

attached to post

leigh123linux
28th July 2008, 05:22 PM
Post



rpm -qa |grep python

and


su
yum list python

cc3283@att.com
28th July 2008, 05:33 PM
[root@esacdev cdr]# rpm -qa |grep python
at-spi-python-1.22.1-1.fc9.i386
libxslt-python-1.1.23-3.fc9.i386
gnome-python2-bonobo-2.22.0-2.fc9.i386
python-numeric-24.2-10.fc9.i386
notify-python-0.1.1-3.fc9.i386
gnome-python2-desktop-2.22.0-2.fc9.i386
MySQL-python-1.2.2-6.fc9.i386
python-2.5.1-25.fc9.i386
gnome-python2-canvas-2.22.0-2.fc9.i386
dbus-python-0.82.4-2.fc9.i386
newt-python-0.52.9-1.fc9.i386
python-urlgrabber-3.0.0-6.fc9.noarch
gamin-python-0.1.9-5.fc9.i386
python-reportlab-2.1-2.fc9.noarch
gnome-python2-applet-2.22.0-2.fc9.i386
gnome-python2-libegg-2.19.1-15.fc9.i386
gnome-python2-gnomeprint-2.22.0-2.fc9.i386
rpm-python-4.4.2.3-2.fc9.i386
libselinux-python-2.0.61-1.fc9.i386
libxml2-python-2.6.32-1.fc9.i386
python-devel-2.5.1-25.fc9.i386
gnome-python2-gconf-2.22.0-2.fc9.i386
gnome-python2-gtkhtml2-2.19.1-15.fc9.i386
gnome-python2-gtksourceview-2.16.0-1.fc6.i386
libuser-python-0.56.9-1.i386
gnome-python2-extras-2.19.1-15.fc9.i386
python-ldap-2.3.1-3.fc9.i386
audit-libs-python-1.7.2-6.fc9.i386
python-libs-2.5.1-25.fc9.i386
python-iniparse-0.2.3-3.fc9.noarch
gnome-python2-2.22.0-2.fc9.i386
mod_python-3.3.1-7.i386
gnome-python2-gnomevfs-2.22.0-2.fc9.i386
gstreamer-python-0.10.11-2.fc9.i386
[root@esacdev cdr]# yum list python
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: ftp.is.co.za
* livna: mirrors.tummy.com
* updates: ftp.is.co.za
fedora | 2.4 kB 00:00
livna | 2.1 kB 00:00
updates | 2.3 kB 00:00
Installed Packages
python.i386 2.5.1-25.fc9 installed

leigh123linux
28th July 2008, 05:52 PM
Try



mkdir rpm
cd rpm
wget ftp://ftp.is.co.za/linux/distributions/fedora/linux/updates/9/i386/python-2.5.1-26.fc9.i386.rpm ftp://ftp.is.co.za/linux/distributions/fedora/linux/updates/9/i386/python-devel-2.5.1-26.fc9.i386.rpm ftp://ftp.is.co.za/linux/distributions/fedora/linux/updates/9/i386/python-libs-2.5.1-26.fc9.i386.rpm
rpm -Uvh python*rpm
yum --noplugins update

cc3283@att.com
29th July 2008, 05:59 PM
Thanks again for your help with this


[root@esacdev rpm]# rpm -Uvh python*rpm
error: Failed dependencies:
python(abi) = 2.4 is needed by (installed) rhnlib-1.8-6.p24.1.noarch
python(abi) = 2.4 is needed by (installed) up2date-4.4.23-4.i386
python(abi) = 2.4 is needed by (installed) 4Suite-1.0-8.b1.i386
python(abi) = 2.4 is needed by (installed) PyXML-0.8.4-4.i386
python(abi) = 2.4 is needed by (installed) java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.110.i386
python(abi) = 2.4 is needed by (installed) gnome-python2-gtksourceview-2.16.0-1.fc6.i386
python(abi) = 2.4 is needed by (installed) pyOpenSSL-0.6-1.p24.7.2.2.i386
python-abi = 2.4 is needed by (installed) 4Suite-1.0-8.b1.i386
[root@esacdev rpm]#

leigh123linux
29th July 2008, 06:15 PM
Try


su
yum erase rhnlib up2date 4Suite
yum update

cc3283@att.com
29th July 2008, 06:30 PM
attached full output


[root@esacdev ~]# yum erase rhnlib up2date 4Suite
Loaded plugins: fastestmirror, refresh-packagekit
Setting up Remove Process
Loading mirror speeds from cached hostfile
* fedora: ftp.is.co.za
* livna: mirrors.tummy.com
* updates: ftp.is.co.za
fedora | 2.4 kB 00:00
livna | 2.1 kB 00:00
updates | 2.3 kB 00:00
Resolving Dependencies
--> Running transaction check
---> Package up2date.i386 0:4.4.23-4 set to be erased
---> Package 4Suite.i386 0:1.0-8.b1 set to be erased
---> Package rhnlib.noarch 0:1.8-6.p24.1 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Removing:
4Suite i386 1.0-8.b1 installed 17 M
rhnlib noarch 1.8-6.p24.1 installed 281 k
up2date i386 4.4.23-4 installed 5.5 M

Transaction Summary
================================================== ===========================
Install 0 Package(s)
Update 0 Package(s)
Remove 3 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing : up2date ######################### [1/3]
warning: /etc/sysconfig/rhn/up2date-uuid saved as /etc/sysconfig/rhn/up2date-uui d.rpmsave
warning: /etc/sysconfig/rhn/up2date saved as /etc/sysconfig/rhn/up2date.rpmsave
Erasing : rhnlib ######################### [2/3]
Erasing : 4Suite ######################### [3/3]

Removed: 4Suite.i386 0:1.0-8.b1 rhnlib.noarch 0:1.8-6.p24.1 up2date.i386 0:4.4.2 3-4
Complete!
[root@esacdev ~]# yum update
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: ftp.is.co.za
* livna: mirrors.tummy.com
* updates: ftp.is.co.za
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package gtkmm24.i386 0:2.12.7-1.fc9 set to be updated
---> Package gtksourceview2.i386 0:2.2.2-1.fc9 set to be updated
---> Package ncurses-libs.i386 0:5.6-18.20080628.fc9 set to be updated
--> Processing Dependency: ncurses-base = 5.6-18.20080628.fc9 for package: ncurs es-libs
---> Package libpurple.i386 0:2.4.3-1.fc9 set to be updated
---> Package ghostscript.i386 0:8.62-4.fc9 set to be updated
---> Package dmraid.i386 0:1.0.0.rc14-8.fc9 set to be updated
---> Package libusb-devel.i386 0:0.1.12-15.fc9 set to be updated
---> Package libxslt-devel.i386 0:1.1.24-1.fc9 set to be updated
---> Package libpciaccess.i386 0:0.10.3-2.fc9 set to be updated
--> Processing Dependency: libtdb.so.0 for package: samba
--> Processing Dependency: libtdb.so.0 for package: samba-client
---> Package libpng10-devel.i386 0:1.0.37-1.fc9 set to be updated
---> Package ImageMagick-devel.i386 0:6.3.8.1-4.fc9 set to be updated
--> Processing Dependency: jasper for package: ImageMagick-devel
---> Package scim-devel.i386 0:1.4.7-23.fc9 set to be updated
---> Package nautilus-extensions.i386 0:2.22.5.1-1.fc9 set to be updated
...
--> Finished Dependency Resolution
1:perl-Pod-Escapes-1.04-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 1:perl-Pod -Escapes-1.04-30.fc9.i386 (installed)
1:NetworkManager-gnome-0.7.0-0.9.3.svn3623.fc9.i386 from installed has depsolvin g problems
--> Missing Dependency: NetworkManager-glib = 1:0.7.0-0.9.3.svn3623.fc9 is nee ded by package 1:NetworkManager-gnome-0.7.0-0.9.3.svn3623.fc9.i386 (installed)
mesa-libGL-7.1-0.37.fc9.i386 from updates has depsolving problems
--> Missing Dependency: mesa-dri-drivers = 7.1-0.37.fc9 is needed by package m esa-libGL-7.1-0.37.fc9.i386 (updates)
samba-client-3.2.0-1.pre3.9.fc9.i386 from installed has depsolving problems
...

leigh123linux
29th July 2008, 07:30 PM
Ok post



yum update perl


and



rpm -qa |grep perl

cc3283@att.com
29th July 2008, 07:34 PM
[root@esacdev rpm]# yum update perl
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: ftp.is.co.za
* livna: mirrors.tummy.com
* updates: ftp.is.co.za
fedora | 2.4 kB 00:00
livna | 2.1 kB 00:00
updates | 2.3 kB 00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package perl.i386 4:5.10.0-31.fc9 set to be updated
--> Processing Dependency: perl-libs = 4:5.10.0-31.fc9 for package: perl
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Test-Harness
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Module-Pluggable
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-version
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-CPAN
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-IO-Zlib
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Module-Build
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Compress-Zlib
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-ExtUtils-ParseXS
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-ExtUtils-MakeMaker
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Archive-Tar
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-IO-Compress-Base
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Module-CoreList
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-devel
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Compress-Raw-Zlib
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Pod-Simple
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Pod-Escapes
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-ExtUtils-CBuilder
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Test-Simple
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-IO-Compress-Zlib
--> Running transaction check
---> Package perl-libs.i386 4:5.10.0-31.fc9 set to be updated
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Test-Harness
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Module-Pluggable
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-version
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-CPAN
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-IO-Zlib
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Module-Build
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Compress-Zlib
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-ExtUtils-ParseXS
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-ExtUtils-MakeMaker
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Archive-Tar
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-IO-Compress-Base
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Module-CoreList
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Compress-Raw-Zlib
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Pod-Simple
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Pod-Escapes
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-ExtUtils-CBuilder
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Test-Simple
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-IO-Compress-Zlib
---> Package perl-devel.i386 4:5.10.0-31.fc9 set to be updated
--> Finished Dependency Resolution
1:perl-ExtUtils-ParseXS-2.18-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 1:perl-ExtUtils-ParseXS-2.18-30.fc9.i386 (installed)
perl-Compress-Zlib-2.008-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-Compress-Zlib-2.008-30.fc9.i386 (installed)
perl-IO-Compress-Zlib-2.008-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-IO-Compress-Zlib-2.008-30.fc9.i386 (installed)
1:perl-Module-Build-0.2808-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 1:perl-Module-Build-0.2808-30.fc9.i386 (installed)
1:perl-Pod-Escapes-1.04-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 1:perl-Pod-Escapes-1.04-30.fc9.i386 (installed)
perl-ExtUtils-MakeMaker-6.36-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-ExtUtils-MakeMaker-6.36-30.fc9.i386 (installed)
1:perl-Pod-Simple-3.05-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 1:perl-Pod-Simple-3.05-30.fc9.i386 (installed)
perl-Archive-Tar-1.37-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-Archive-Tar-1.37-30.fc9.i386 (installed)
1:perl-IO-Zlib-1.07-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 1:perl-IO-Zlib-1.07-30.fc9.i386 (installed)
perl-Test-Simple-0.72-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-Test-Simple-0.72-30.fc9.i386 (installed)
perl-CPAN-1.9205-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-CPAN-1.9205-30.fc9.i386 (installed)
1:perl-ExtUtils-CBuilder-0.21-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 1:perl-ExtUtils-CBuilder-0.21-30.fc9.i386 (installed)
perl-Compress-Raw-Zlib-2.008-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-Compress-Raw-Zlib-2.008-30.fc9.i386 (installed)
perl-IO-Compress-Base-2.008-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-IO-Compress-Base-2.008-30.fc9.i386 (installed)
3:perl-version-0.74-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 3:perl-version-0.74-30.fc9.i386 (installed)
perl-Module-CoreList-2.14-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-Module-CoreList-2.14-30.fc9.i386 (installed)
perl-Test-Harness-2.64-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-Test-Harness-2.64-30.fc9.i386 (installed)
1:perl-Module-Pluggable-3.60-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 1:perl-Module-Pluggable-3.60-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-Test-Harness-2.64-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-Compress-Zlib-2.008-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 1:perl-Module-Build-0.2808-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 1:perl-Pod-Escapes-1.04-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-ExtUtils-MakeMaker-6.36-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-Compress-Raw-Zlib-2.008-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 1:perl-ExtUtils-CBuilder-0.21-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 1:perl-ExtUtils-ParseXS-2.18-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-Archive-Tar-1.37-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-IO-Compress-Zlib-2.008-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 1:perl-Module-Pluggable-3.60-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-IO-Compress-Base-2.008-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 1:perl-Pod-Simple-3.05-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-Test-Simple-0.72-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 1:perl-IO-Zlib-1.07-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 3:perl-version-0.74-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-CPAN-1.9205-30.fc9.i386 (installed)
Error: Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-Module-CoreList-2.14-30.fc9.i386 (installed)
[root@esacdev rpm]#

cc3283@att.com
29th July 2008, 07:36 PM
[root@esacdev rpm]# rpm -qa |grep perl
perl-Parse-Yapp-1.05-36.fc6.noarch
ImageMagick-perl-6.2.8.0-4.fc6.i386
mod_perl-2.0.3-21.i386
perl-XML-DOM-1.44-4.fc9.noarch
perl-Math-Pari-2.010709-7.fc9.i386
perl-Convert-ASCII-Armour-1.4-6.fc9.noarch
perl-IPC-Run-0.80-5.fc9.noarch
perl-UNIVERSAL-require-0.11-4.fc9.noarch
perl-CGI-Untaint-email-0.03-5.fc9.noarch
perl-Module-Build-0.2808-30.fc9.i386
perl-XML-SAX-0.14-2.noarch
perl-IO-Compress-Base-2.008-30.fc9.i386
perl-Crypt-Random-1.25-5.fc9.noarch
perl-Net-SSH2-0.18-5.fc9.i386
perl-Pod-POM-0.17-9.fc9.noarch
perl-WWW-Mechanize-1.34-1.fc9.noarch
perl-Module-CoreList-2.14-30.fc9.i386
perl-GD-2.35-7.fc9.i386
perl-XML-Dumper-0.81-2.fc6.noarch
perl-Convert-ASN1-0.21-3.fc9.noarch
perl-Module-Pluggable-3.60-30.fc9.i386
perl-Crypt-CBC-2.22-3.fc9.noarch
perl-Convert-PEM-0.07-6.fc9.noarch
perl-HTML-Template-2.9-2.fc9.noarch
perl-Class-Prototyped-1.11-1.fc9.noarch
perl-Carp-Assert-0.20-2.fc9.noarch
perl-Text-Diff-0.35-6.fc9.noarch
perl-Event-1.11-1.fc9.i386
perl-XML-LibXML-Common-0.13-8.2.2.i386
groff-perl-1.18.1.4-14.fc9.i386
perl-DBI-1.601-4.fc9.i386
perl-IO-Socket-INET6-2.54-1.fc9.noarch
perl-version-0.74-30.fc9.i386
perl-IO-Zlib-1.07-30.fc9.i386
perl-Email-Valid-0.179-4.fc9.noarch
perl-Template-Toolkit-2.19-4.fc9.i386
perl-Spiffy-0.30-9.fc9.noarch
perl-Params-Validate-0.91-1.fc9.i386
perl-POE-0.9999-1.fc9.noarch
perl-XML-NamespaceSupport-1.09-1.2.1.noarch
perl-HTML-Parser-3.56-5.fc9.i386
perl-Test-Harness-2.64-30.fc9.i386
perl-Crypt-DES-2.05-7.fc9.i386
perl-FreezeThaw-0.43-6.fc9.noarch
perl-CGI-FormBuilder-3.0501-5.fc9.noarch
perl-PAR-Dist-0.29-2.fc9.noarch
perl-Log-Log4perl-1.13-2.fc9.noarch
perl-Expect-Simple-0.04-1.fc9.noarch
perl-XML-Twig-3.29-1.fc6.noarch
perl-Date-Manip-5.48-3.fc9.noarch
perl-DBD-MySQL-4.005-8.fc9.i386
perl-BSD-Resource-1.28-6.fc9.i386
perl-libs-5.10.0-30.fc9.i386
perl-ExtUtils-MakeMaker-6.36-30.fc9.i386
perl-CPAN-1.9205-30.fc9.i386
perl-Sort-Versions-1.5-8.fc9.noarch
perl-Crypt-DES_EDE3-0.01-6.fc9.noarch
perl-TeX-Hyphen-0.140-7.fc9.noarch
perl-CGI-FastTemplate-1.09-4.fc9.noarch
perl-Class-Accessor-0.31-4.fc9.noarch
perl-CGI-Ex-2.21-2.fc9.noarch
perl-Carp-Assert-More-1.12-4.fc9.noarch
perl-ExtUtils-CBuilder-0.21-30.fc9.i386
perl-Config-Record-1.1.1-4.fc9.noarch
perl-Test-use-ok-0.02-4.fc9.noarch
perl-Curses-1.20-3.fc9.i386
perl-Newt-1.08-21.fc9.i386
perl-Digest-HMAC-1.01-19.fc9.noarch
perl-libwww-perl-5.808-7.fc9.noarch
rrdtool-perl-1.3.0-1.fc9.i386
perl-Compress-Raw-Zlib-2.008-30.fc9.i386
perl-Pod-Simple-3.05-30.fc9.i386
perl-Crypt-Primes-0.50-5.fc9.noarch
perl-Digest-MD2-2.03-7.fc9.i386
perl-Net-SSH-0.08-6.fc9.noarch
perl-MailTools-2.03-1.fc9.noarch
perl-Template-Alloy-1.008-2.fc9.noarch
perl-DBD-Pg-1.49-9.fc9.i386
perl-CGI-Untaint-date-1.00-5.fc9.noarch
perl-Test-LongString-0.11-3.fc9.noarch
perl-Log-Dispatch-2.21-1.fc9.noarch
perl-Test-AutoBuild-1.2.2-3.fc9.noarch
perl-Expect-1.21-1.fc9.noarch
perl-XML-LibXML-1.58-2.2.2.1.i386
perl-XML-Grove-0.46alpha-29.1.1.noarch
perl-Net-IP-1.25-2.fc6.noarch
perl-Crypt-SSLeay-0.51-12.fc6.i386
perl-Net-SSLeay-1.32-5.fc9.i386
perl-URI-1.35-8.fc9.noarch
perl-5.10.0-30.fc9.i386
perl-Compress-Zlib-2.008-30.fc9.i386
perl-Data-Buffer-0.04-6.fc9.noarch
perl-Class-ErrorHandler-0.01-5.fc9.noarch
perl-Crypt-DSA-0.14-6.fc9.noarch
perl-Text-Autoformat-1.14.0-3.fc9.noarch
perl-GraphViz-2.02-3.fc9.noarch
perl-CGI-Session-4.20-4.fc9.noarch
perl-Mail-Sender-0.8.13-3.fc9.noarch
perl-YAML-Tiny-1.25-2.fc9.noarch
perl-Algorithm-Diff-1.1902-6.fc9.noarch
perl-Test-Base-0.54-3.fc9.noarch
perl-IO-Tty-1.07-5.fc9.i386
perl-POE-Component-Logger-1.00-3.fc9.noarch
perl-LDAP-0.33-3.fc6.noarch
perl-String-CRC32-1.4-6.fc9.i386
perl-IO-Socket-SSL-1.12-4.fc9.noarch
perl-Pod-Escapes-1.04-30.fc9.i386
perl-Archive-Tar-1.37-30.fc9.i386
perl-Crypt-RSA-1.58-4.fc9.noarch
perl-AppConfig-1.66-3.fc9.noarch
perl-Test-Simple-0.72-30.fc9.i386
perl-IPC-Shareable-0.60-6.fc9.noarch
perl-MIME-Lite-3.01-6.fc9.noarch
perl-TermReadKey-2.30-6.fc9.i386
perl-libxml-perl-0.08-1.2.1.noarch
perl-Net-DNS-0.63-3.fc9.i386
perl-ExtUtils-ParseXS-2.18-30.fc9.i386
perl-Crypt-Blowfish-2.10-6.fc9.i386
perl-TimeDate-1.16-8.fc9.noarch
perl-Date-Simple-3.02-9.fc9.i386
perl-Log-Dispatch-FileRotate-1.18-1.fc9.noarch
perl-Log-Dispatch-Config-1.01-3.fc9.noarch
net-snmp-perl-5.3.1-15.fc6.i386
perl-SGMLSpm-1.03ii-18.fc9.noarch
perl-Digest-SHA1-2.11-7.fc9.i386
perl-IO-Compress-Zlib-2.008-30.fc9.i386
perl-Crypt-DH-0.06-8.fc9.noarch
perl-Text-Reform-1.12.2-4.fc9.noarch
perl-CGI-Ajax-0.701-4.fc9.noarch
perl-IO-stringy-2.110-8.fc9.noarch
perl-Test-WWW-Mechanize-1.20-1.fc9.noarch
perl-Socket6-0.20-1.fc9.i386
perl-XML-Parser-2.36-3.fc9.i386
perl-Math-GMP-2.04-9.fc9.i386
perl-Tie-EncryptedHash-1.21-4.fc9.noarch
perl-Text-Template-1.45-1.fc9.noarch
perl-CGI-Untaint-1.26-5.fc9.noarch
perl-CGI-Prototype-0.9053-5.fc9.noarch
perl-Module-ScanDeps-0.82-2.fc9.noarch
perl-XML-Encoding-1.01-27.noarch
perl-HTML-Tagset-3.10-8.fc9.noarch
perl-XML-RegExp-0.03-4.fc9.noarch
perl-devel-5.10.0-30.fc9.i386
perl-Class-Loader-2.03-6.fc9.noarch
perl-Net-SSH-Perl-1.30-6.fc9.noarch
perl-Parse-RecDescent-1.95.1-5.fc9.noarch
perl-Mail-Sendmail-0.79-10.fc9.noarch
perl-Module-Install-0.68-3.fc9.noarch
perl-GD-Barcode-1.15-3.fc9.noarch
[root@esacdev rpm]#

leigh123linux
29th July 2008, 08:28 PM
Ok try



su
yumdownloader perl
rpm -Uvh perl*rpm

and post the error

cc3283@att.com
29th July 2008, 08:37 PM
[root@esacdev rpm]# yumdownloader perl
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: ftp.is.co.za
* livna: mirrors.tummy.com
* updates: ftp.is.co.za
fedora | 2.4 kB 00:00
livna | 2.1 kB 00:00
updates | 2.3 kB 00:00
perl-5.10.0-31.fc9.i386.rpm | 14 MB 01:58
[root@esacdev rpm]# rpm -Uvh perl*rpm
error: Failed dependencies:
perl-libs = 4:5.10.0-31.fc9 is needed by perl-5.10.0-31.fc9.i386
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-version-0.74-30.fc9.i3 86
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-Pod-Escapes-1.04-30.fc 9.i386
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-libs-5.10.0-30.fc9.i38 6
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-Module-Pluggable-3.60- 30.fc9.i386
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-devel-5.10.0-30.fc9.i3 86
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-IO-Compress-Base-2.008 -30.fc9.i386
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-Compress-Raw-Zlib-2.00 8-30.fc9.i386
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-ExtUtils-MakeMaker-6.3 6-30.fc9.i386
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-IO-Compress-Zlib-2.008 -30.fc9.i386
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-Compress-Zlib-2.008-30 .fc9.i386
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-Test-Harness-2.64-30.f c9.i386
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-ExtUtils-ParseXS-2.18- 30.fc9.i386
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-Pod-Simple-3.05-30.fc9 .i386
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-IO-Zlib-1.07-30.fc9.i3 86
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-Archive-Tar-1.37-30.fc 9.i386
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-CPAN-1.9205-30.fc9.i38 6
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-Test-Simple-0.72-30.fc 9.i386
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-ExtUtils-CBuilder-0.21 -30.fc9.i386
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-Module-Build-0.2808-30 .fc9.i386
perl = 4:5.10.0-30.fc9 is needed by (installed) perl-Module-CoreList-2.14-3 0.fc9.i386
[root@esacdev rpm]#

leigh123linux
29th July 2008, 09:26 PM
Try


su
yum erase java-1.4.2*
yum update

cc3283@att.com
30th July 2008, 04:34 PM
I can attach the full output if needed. The erase completed fine with no errors.

Is this looking like a lost cause? I appreciate your time and help/advice with this problem.


[root@esacdev ~]# yum update
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: ftp.is.co.za
* livna: mirrors.tummy.com
* updates: ftp.is.co.za
fedora | 2.4 kB 00:00
livna | 2.1 kB 00:00
updates | 2.3 kB 00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package gtk2-devel.i386 0:2.12.11-1.fc9 set to be updated
---> Package gnome-keyring-pam.i386 0:2.22.3-1.fc9 set to be updated
---> Package python-libs.i386 0:2.5.1-26.fc9 set to be updated
--> Processing Dependency: python = 2.5.1-26.fc9 for package: python-libs
---> Package paps-libs.i386 0:0.6.8-6.fc9 set to be updated
---> Package xorg-x11-drv-i810.i386 0:2.3.2-2.fc9 set to be updated
---> Package perl-XML-Twig.noarch 0:3.32-1.fc9 set to be updated
---> Package e2fsprogs-devel.i386 0:1.40.8-3.fc9 set to be updated
---> Package libsepol-devel.i386 0:2.0.32-1.fc9 set to be updated
---> Package python-urlgrabber.noarch 0:3.0.0-9.fc9 set to be updated
---> Package xml-common.noarch 0:0.6.3-24.fc9 set to be updated
---> Package glibc-devel.i386 0:2.8-8 set to be updated
--> Processing Dependency: glibc-headers = 2.8-8 for package: glibc-devel
---> Package mesa-libGLU-devel.i386 0:7.1-0.37.fc9 set to be updated
--> Processing Dependency: libpt_linux_x86_r.so.1.10.4 for package: ekiga
---> Package libvolume_id.i386 0:124-1.fc9.2 set to be updated
---> Package liberation-fonts.noarch 0:1.04-1.fc9 set to be updated
---> Package pwlib.i386 0:1.10.10-6.fc9 set to be updated
---> Package elfutils-devel.i386 0:0.133-3.fc9 set to be updated
---> Package postgresql-libs.i386 0:8.3.3-2.fc9 set to be updated
---> Package switchdesk.noarch 0:4.0.9-2 set to be updated
---> Package evince.i386 0:2.22.2-1.fc9 set to be updated
---> Package pango-devel.i386 0:1.20.4-1.fc9 set to be updated
---> Package popt.i386 0:1.13-4.fc9 set to be updated
---> Package libgweather.i386 0:2.22.3-1.fc9 set to be updated
---> Package libxml2-devel.i386 0:2.6.32-2.fc9 set to be updated
---> Package agg.i386 0:2.5-6.fc9 set to be updated
---> Package cyrus-sasl-devel.i386 0:2.1.22-15.fc9 set to be updated
--> Processing Dependency: cyrus-sasl = 2.1.22-15.fc9 for package: cyrus-sasl-devel
---> Package libao.i386 0:0.8.8-5.fc9 set to be updated
---> Package audit-libs.i386 0:1.7.4-1.fc9 set to be updated
---> Package libpciaccess.i386 0:0.10.3-2.fc9 set to be updated
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Module-Build
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Compress-Raw-Zlib
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-version
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Compress-Zlib
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-ExtUtils-ParseXS
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-IO-Compress-Base
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Test-Harness
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-IO-Compress-Zlib
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Module-Pluggable
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Archive-Tar
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Module-CoreList
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-ExtUtils-MakeMaker
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-CPAN
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Pod-Simple
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Pod-Escapes
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-IO-Zlib
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-ExtUtils-CBuilder
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Test-Simple
---> Package cups-libs.i386 1:1.3.7-8.fc9 set to be updated
---> Package openldap-devel.i386 0:2.4.8-6.fc9 set to be updated
---> Package lcms-devel.i386 0:1.17-5.fc9 set to be updated
---> Package libgtop2.i386 0:2.22.3-1.fc9 set to be updated
---> Package nss.i386 0:3.12.0.3-0.9.1.fc9 set to be updated
---> Package cyrus-sasl-lib.i386 0:2.1.22-15.fc9 set to be updated
---> Package control-center.i386 1:2.22.2.1-1.fc9 set to be updated
--> Processing Dependency: control-center-filesystem = 1:2.22.2.1-1.fc9 for package: control-center
---> Package libXp-devel.i386 0:1.0.0-11.fc9 set to be updated
---> Package enchant.i386 1:1.4.2-1.fc9 set to be updated
---> Package db4-cxx.i386 0:4.6.21-6.fc9 set to be updated
---> Package ghostscript-devel.i386 0:8.62-4.fc9 set to be updated
---> Package libpng10-devel.i386 0:1.0.37-1.fc9 set to be updated
---> Package nss_compat_ossl.i386 0:0.9.2-5.fc9 set to be updated
--> Processing Dependency: libxml2 = 2.6.32-1.fc9 for package: libxml2-python
---> Package gail.i386 0:1.22.3-1.fc9 set to be updated
---> Package bzip2-devel.i386 0:1.0.5-2.fc9 set to be updated
---> Package gtkhtml3.i386 0:3.18.3-1.fc9 set to be updated
---> Package mesa-libGL-devel.i386 0:7.1-0.37.fc9 set to be updated
---> Package kde-settings.noarch 0:4.0-24.fc9 set to be updated
---> Package libcurl.i386 0:7.18.2-1.fc9 set to be updated
---> Package eel2.i386 0:2.22.2-1.fc9 set to be updated
--> Processing Dependency: libdns.so.41 for package: bind-utils
...

cc3283@att.com
30th July 2008, 04:39 PM
--> Finished Dependency Resolution
1:perl-Pod-Escapes-1.04-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 1:perl-Pod-Escapes-1.04-30.fc9.i386 (installed)
1:NetworkManager-gnome-0.7.0-0.9.3.svn3623.fc9.i386 from installed has depsolving problems
--> Missing Dependency: NetworkManager-glib = 1:0.7.0-0.9.3.svn3623.fc9 is needed by package 1:NetworkManager-gnome-0.7.0-0.9.3.svn3623.fc9.i386 (installed)
cyrus-sasl-devel-2.1.22-15.fc9.i386 from updates has depsolving problems
--> Missing Dependency: cyrus-sasl = 2.1.22-15.fc9 is needed by package cyrus-sasl-devel-2.1.22-15.fc9.i386 (updates)
mesa-libGL-7.1-0.37.fc9.i386 from updates has depsolving problems
--> Missing Dependency: mesa-dri-drivers = 7.1-0.37.fc9 is needed by package mesa-libGL-7.1-0.37.fc9.i386 (updates)
samba-client-3.2.0-1.pre3.9.fc9.i386 from installed has depsolving problems
--> Missing Dependency: libtdb.so.0 is needed by package samba-client-3.2.0-1.pre3.9.fc9.i386 (installed)
lcms-libs-1.17-5.fc9.i386 from updates has depsolving problems
--> Missing Dependency: lcms = 1.17-5.fc9 is needed by package lcms-libs-1.17-5.fc9.i386 (updates)
PackageKit-0.1.12-10.20080505.fc9.i386 from installed has depsolving problems
--> Missing Dependency: PackageKit-libs = 0.1.12-10.20080505.fc9 is needed by package PackageKit-0.1.12-10.20080505.fc9.i386 (installed)
perl-IO-Compress-Zlib-2.008-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-IO-Compress-Zlib-2.008-30.fc9.i386 (installed)
1:control-center-2.22.2.1-1.fc9.i386 from updates has depsolving problems
--> Missing Dependency: control-center-filesystem = 1:2.22.2.1-1.fc9 is needed by package 1:control-center-2.22.2.1-1.fc9.i386 (updates)
3:perl-version-0.74-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 3:perl-version-0.74-30.fc9.i386 (installed)
libselinux-python-2.0.61-1.fc9.i386 from installed has depsolving problems
--> Missing Dependency: libselinux = 2.0.61-1.fc9 is needed by package libselinux-python-2.0.61-1.fc9.i386 (installed)
fwbuilder-ipt-2.0.12-2.fc6.i386 from installed has depsolving problems
--> Missing Dependency: libfwcompiler.so.6 is needed by package fwbuilder-ipt-2.0.12-2.fc6.i386 (installed)
perl-ExtUtils-MakeMaker-6.36-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-ExtUtils-MakeMaker-6.36-30.fc9.i386 (installed)
ImageMagick-devel-6.3.8.1-4.fc9.i386 from fedora has depsolving problems
--> Missing Dependency: jasper is needed by package ImageMagick-devel-6.3.8.1-4.fc9.i386 (fedora)
perl-Archive-Tar-1.37-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package perl-Archive-Tar-1.37-30.fc9.i386 (installed)
pidgin-2.4.1-2.fc9.i386 from installed has depsolving problems
--> Missing Dependency: libpurple = 2.4.1-2.fc9 is needed by package pidgin-2.4.1-2.fc9.i386 (installed)
ncurses-libs-5.6-18.20080628.fc9.i386 from updates has depsolving problems
--> Missing Dependency: ncurses-base = 5.6-18.20080628.fc9 is needed by package ncurses-libs-5.6-18.20080628.fc9.i386 (updates)
1:perl-Module-Pluggable-3.60-30.fc9.i386 from installed has depsolving problems
--> Missing Dependency: perl = 4:5.10.0-30.fc9 is needed by package 1:perl-Module-Pluggable-3.60-30.fc9.i386 (installed)
cdparanoia-alpha9.8-30.i386 from installed has depsolving problems
--> Missing Dependency: cdparanoia-libs = alpha9.8-30 is needed by package cdparanoia-alpha9.8-30.i386 (installed)
audit-libs-python-1.7.2-6.fc9.i386 from installed has depsolving problems
--> Missing Dependency: audit-libs = 1.7.2-6.fc9 is needed by package audit-libs-python-1.7.2-6.fc9.i386 (installed)
fwbuilder-2.0.12-2.fc6.i386 from installed has depsolving problems
--> Missing Dependency: libfwbuilder = 2.0.12 is needed by package fwbuilder-2.0.12-2.fc6.i386 (installed)
python-devel-2.5.1-26.fc9.i386 from updates has depsolving problems
--> Missing Dependency: python = 2.5.1-26.fc9 is needed by package python-devel-2.5.1-26.fc9.i386 (updates)
openldap-clients-2.4.8-3.fc9.i386 from installed has depsolving problems

leigh123linux
30th July 2008, 04:40 PM
I can attach the full output if needed. The erase completed fine with no errors.

Is this looking like a lost cause? I appreciate your time and help/advice with this problem.


[root@esacdev ~]# yum update
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: ftp.is.co.za
* livna: mirrors.tummy.com
* updates: ftp.is.co.za
fedora | 2.4 kB 00:00
livna | 2.1 kB 00:00
updates | 2.3 kB 00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package gtk2-devel.i386 0:2.12.11-1.fc9 set to be updated
---> Package gnome-keyring-pam.i386 0:2.22.3-1.fc9 set to be updated
---> Package python-libs.i386 0:2.5.1-26.fc9 set to be updated
--> Processing Dependency: python = 2.5.1-26.fc9 for package: python-libs
---> Package paps-libs.i386 0:0.6.8-6.fc9 set to be updated
---> Package xorg-x11-drv-i810.i386 0:2.3.2-2.fc9 set to be updated
---> Package perl-XML-Twig.noarch 0:3.32-1.fc9 set to be updated
---> Package e2fsprogs-devel.i386 0:1.40.8-3.fc9 set to be updated
---> Package libsepol-devel.i386 0:2.0.32-1.fc9 set to be updated
---> Package python-urlgrabber.noarch 0:3.0.0-9.fc9 set to be updated
---> Package xml-common.noarch 0:0.6.3-24.fc9 set to be updated
---> Package glibc-devel.i386 0:2.8-8 set to be updated
--> Processing Dependency: glibc-headers = 2.8-8 for package: glibc-devel
---> Package mesa-libGLU-devel.i386 0:7.1-0.37.fc9 set to be updated
--> Processing Dependency: libpt_linux_x86_r.so.1.10.4 for package: ekiga
---> Package libvolume_id.i386 0:124-1.fc9.2 set to be updated
---> Package liberation-fonts.noarch 0:1.04-1.fc9 set to be updated
---> Package pwlib.i386 0:1.10.10-6.fc9 set to be updated
---> Package elfutils-devel.i386 0:0.133-3.fc9 set to be updated
---> Package postgresql-libs.i386 0:8.3.3-2.fc9 set to be updated
---> Package switchdesk.noarch 0:4.0.9-2 set to be updated
---> Package evince.i386 0:2.22.2-1.fc9 set to be updated
---> Package pango-devel.i386 0:1.20.4-1.fc9 set to be updated
---> Package popt.i386 0:1.13-4.fc9 set to be updated
---> Package libgweather.i386 0:2.22.3-1.fc9 set to be updated
---> Package libxml2-devel.i386 0:2.6.32-2.fc9 set to be updated
---> Package agg.i386 0:2.5-6.fc9 set to be updated
---> Package cyrus-sasl-devel.i386 0:2.1.22-15.fc9 set to be updated
--> Processing Dependency: cyrus-sasl = 2.1.22-15.fc9 for package: cyrus-sasl-devel
---> Package libao.i386 0:0.8.8-5.fc9 set to be updated
---> Package audit-libs.i386 0:1.7.4-1.fc9 set to be updated
---> Package libpciaccess.i386 0:0.10.3-2.fc9 set to be updated
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Module-Build
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Compress-Raw-Zlib
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-version
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Compress-Zlib
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-ExtUtils-ParseXS
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-IO-Compress-Base
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Test-Harness
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-IO-Compress-Zlib
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Module-Pluggable
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Archive-Tar
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Module-CoreList
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-ExtUtils-MakeMaker
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-CPAN
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Pod-Simple
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Pod-Escapes
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-IO-Zlib
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-ExtUtils-CBuilder
--> Processing Dependency: perl = 4:5.10.0-30.fc9 for package: perl-Test-Simple
---> Package cups-libs.i386 1:1.3.7-8.fc9 set to be updated
---> Package openldap-devel.i386 0:2.4.8-6.fc9 set to be updated
---> Package lcms-devel.i386 0:1.17-5.fc9 set to be updated
---> Package libgtop2.i386 0:2.22.3-1.fc9 set to be updated
---> Package nss.i386 0:3.12.0.3-0.9.1.fc9 set to be updated
---> Package cyrus-sasl-lib.i386 0:2.1.22-15.fc9 set to be updated
---> Package control-center.i386 1:2.22.2.1-1.fc9 set to be updated
--> Processing Dependency: control-center-filesystem = 1:2.22.2.1-1.fc9 for package: control-center
---> Package libXp-devel.i386 0:1.0.0-11.fc9 set to be updated
---> Package enchant.i386 1:1.4.2-1.fc9 set to be updated
---> Package db4-cxx.i386 0:4.6.21-6.fc9 set to be updated
---> Package ghostscript-devel.i386 0:8.62-4.fc9 set to be updated
---> Package libpng10-devel.i386 0:1.0.37-1.fc9 set to be updated
---> Package nss_compat_ossl.i386 0:0.9.2-5.fc9 set to be updated
--> Processing Dependency: libxml2 = 2.6.32-1.fc9 for package: libxml2-python
---> Package gail.i386 0:1.22.3-1.fc9 set to be updated
---> Package bzip2-devel.i386 0:1.0.5-2.fc9 set to be updated
---> Package gtkhtml3.i386 0:3.18.3-1.fc9 set to be updated
---> Package mesa-libGL-devel.i386 0:7.1-0.37.fc9 set to be updated
---> Package kde-settings.noarch 0:4.0-24.fc9 set to be updated
---> Package libcurl.i386 0:7.18.2-1.fc9 set to be updated
---> Package eel2.i386 0:2.22.2-1.fc9 set to be updated
--> Processing Dependency: libdns.so.41 for package: bind-utils
...


Post the output !




Is this looking like a lost cause?

upgrades can be problematic but they can normally be rectified .

cc3283@att.com
30th July 2008, 04:43 PM
attached the output 51.1bytes

leigh123linux
30th July 2008, 05:14 PM
post



rpm -qa |grep fwbuilder
rpm -qa |grep elfutils
rpm -qa |grep fc6

cc3283@att.com
30th July 2008, 05:22 PM
[root@esacdev ~]# rpm -qa |grep fwbuilder
fwbuilder-ipt-2.0.12-2.fc6.i386
libfwbuilder-devel-2.0.12-3.fc6.i386
fwbuilder-2.0.12-2.fc6.i386
libfwbuilder-2.0.12-3.fc6.i386
[root@esacdev ~]# rpm -qa |grep elfutils
elfutils-libs-0.133-3.fc9.i386
elfutils-libelf-devel-0.133-3.fc9.i386
elfutils-libelf-devel-static-0.131-1.fc6.i386
elfutils-libelf-0.133-3.fc9.i386
elfutils-devel-0.131-1.fc6.i386
elfutils-devel-static-0.131-1.fc6.i386
elfutils-0.133-3.fc9.i386
[root@esacdev ~]# rpm -qa |grep fc6
kernel-devel-2.6.18-1.2798.fc6.i686
perl-Parse-Yapp-1.05-36.fc6.noarch
tetex-afm-3.0-36.fc6.i386
net-snmp-devel-5.3.1-15.fc6.i386
ImageMagick-perl-6.2.8.0-4.fc6.i386
libmpd-0.12.0-3.fc6.i386
fwbuilder-ipt-2.0.12-2.fc6.i386
HelixPlayer-1.0.7-6.fc6.i386
libfwbuilder-devel-2.0.12-3.fc6.i386
xorg-x11-xfs-1.0.5-1.fc6.i386
perl-XML-Dumper-0.81-2.fc6.noarch
pwlib-1.10.4-1.fc6.i386
gdk-pixbuf-0.22.0-32.fc6.i386
commoncpp2-1.5.0-1.fc6.i386
libpng10-devel-1.0.29-1.fc6.i386
elfutils-libelf-devel-static-0.131-1.fc6.i386
glib-1.2.10-26.fc6.i386
libnetfilter_conntrack-devel-0.0.50-2.fc6.i386
xscreensaver-base-5.04-1.fc6.i386
mgetty-1.1.33-9.fc6.i386
fwbuilder-2.0.12-2.fc6.i386
xorg-x11-xsm-1.0.2-4.fc6.i386
dia-0.95-8.fc6.i386
perl-XML-Twig-3.29-1.fc6.noarch
libgcj-src-4.1.2-13.fc6.i386
ImageMagick-devel-6.2.8.0-4.fc6.i386
dhcp-3.0.5-5.fc6.i386
hwbrowser-0.29-1.fc6.noarch
xchat-2.6.6-4.fc6.i386
ccrtp-1.5.1-1.fc6.i386
conntrack-1.0-0.2.beta2.fc6.i386
tetex-xdvi-3.0-36.fc6.i386
freeradius-1.1.7-3.1.fc6.i386
hardlink-1.0-2.fc6.i386
setools-3.0-2.fc6.i386
tux-3.2.18-9.fc6.i386
db4-utils-4.3.29-9.fc6.i386
gnome-keyring-manager-2.16.0-2.fc6.i386
perl-Net-IP-1.25-2.fc6.noarch
xsri-2.1.0-10.fc6.i386
libfwbuilder-2.0.12-3.fc6.i386
perl-Crypt-SSLeay-0.51-12.fc6.i386
kexec-tools-1.101-56.fc6.i386
ekiga-2.0.5-3.fc6.i386
elfutils-devel-0.131-1.fc6.i386
jakarta-commons-modeler-javadoc-1.1-8jpp.2.fc6.i386
mysql-gui-common-5.0r12-2.fc6.i386
elfutils-devel-static-0.131-1.fc6.i386
gimp-print-plugin-4.2.7-23.fc6.i386
libsane-hpaio-1.7.4a-3.fc6.i386
xorg-x11-resutils-7.1-2.fc6.i386
perl-LDAP-0.33-3.fc6.noarch
gtk+-1.2.10-55.fc6.i386
opal-2.2.5-1.fc6.i386
sysklogd-1.4.1-41.fc6.i386
lesstif-0.95.0-20.fc6.i386
scim-devel-1.4.4-37.fc6.i386
xorg-x11-drv-s3-0.5.0-1.fc6.i386
gnome-python2-gtksourceview-2.16.0-1.fc6.i386
gconf-editor-2.16.0-2.fc6.i386
imlib-1.9.15-5.fc6.i386
xosd-2.2.14-9.fc6.i386
gmpc-0.13.0-1.fc6.i386
gnome-volume-manager-2.15.0-4.fc6.i386
net-snmp-utils-5.3.1-15.fc6.i386
brlapi-0.4.1-2.1.fc6.i386
quagga-0.99.7-1.fc6.i386
mysql-devel-5.0.27-1.fc6.i386
net-snmp-perl-5.3.1-15.fc6.i386
htmlview-4.0.0-3.fc6.noarch
lesstif-devel-0.95.0-20.fc6.i386
bluefish-1.0.7-1.fc6.i386
ghostscript-devel-8.15.4-1.fc6.i386
gtksourceview-1.8.0-1.fc6.i386
libpng10-1.0.29-1.fc6.i386
system-config-soundcard-2.0.6-6.fc6.noarch
kernel-devel-2.6.22.14-72.fc6.i686
[root@esacdev ~]#

leigh123linux
30th July 2008, 05:53 PM
Try



su
rpm -e kernel-devel-2.6.18-1.2798.fc6.i686 kernel-devel-2.6.22.14-72.fc6.i686 HelixPlayer
yumdownloader glib elfutils-libelf-devel-static elfutils-devel elfutils-devel-static
rpm -Uvh --nodeps glib*rpm elfutils*rpm


and post


yum update

cc3283@att.com
30th July 2008, 06:08 PM
will post yum update

[root@esacdev voip]# rpm -e kernel-devel-2.6.18-1.2798.fc6.i686 kernel-devel-2.6.22.14-72.fc6.i686 HelixPlayer
[root@esacdev voip]# yumdownloader glib elfutils-libelf-devel-static elfutils-devel elfutils-devel-static
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: ftp.is.co.za
* livna: mirrors.tummy.com
* updates: ftp.is.co.za
fedora | 2.4 kB 00:00
livna | 2.1 kB 00:00
updates | 2.3 kB 00:00
No Match for argument elfutils-libelf-devel-static
No Match for argument elfutils-devel-static
glib-1.2.10-29.fc9.i386.rpm | 139 kB 00:01
elfutils-devel-0.133-3.fc9.i386.rpm | 59 kB 00:01
[root@esacdev voip]# rpm -Uvh --nodeps glib*rpm elfutils*rpm
Preparing... ########################################### [100%]
1:glib ########################################### [ 50%]
2:elfutils-devel ########################################### [100%]
[root@esacdev voip]# yumdownloader glib elfutils-lib elf-devel-static elfutils-devel elfutils-devel-static
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: ftp.is.co.za
* livna: mirrors.tummy.com
* updates: ftp.is.co.za
No Match for argument elfutils-lib
No Match for argument elf-devel-static
No Match for argument elfutils-devel-static
./glib-1.2.10-29.fc9.i386.rpm already exists and appears to be complete
./elfutils-devel-0.133-3.fc9.i386.rpm already exists and appears to be complete
[root@esacdev voip]#

leigh123linux
30th July 2008, 06:27 PM
I think the mirror is incomplete !

try


su
yum erase yum-fastestmirror
yum clean headers metadata dbcache
yum update

if this fails try


yum --skip-broken update

and post the output

cc3283@att.com
30th July 2008, 06:55 PM
attached the full output

Loaded plugins: fastestmirror, refresh-packagekit
Setting up Remove Process
Loading mirror speeds from cached hostfile
* fedora: ftp.is.co.za
* livna: mirrors.tummy.com
* updates: ftp.is.co.za
Resolving Dependencies
--> Running transaction check
---> Package yum-fastestmirror.noarch 0:1.1.14-4.fc9 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Removing:
yum-fastestmirror noarch 1.1.14-4.fc9 installed 14 k

Transaction Summary
================================================== ===========================
Install 0 Package(s)
Update 0 Package(s)
Remove 1 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing : yum-fastestmirror ######################### [1/1]

Removed: yum-fastestmirror.noarch 0:1.1.14-4.fc9
Complete!
[root@esacdev ~]# yum clean headers metadata dbcache
Loaded plugins: refresh-packagekit
Existing lock /var/run/yum.pid: another copy is running as pid 7763.

Another app is currently holding the yum lock; waiting for it to exit...
0 header files removed
7 metadata files removed
6 sqlite files removed
0 metadata files removed
[root@esacdev ~]# yum update
Loaded plugins: refresh-packagekit
fedora | 2.4 kB 00:00
primary.sqlite.bz2 | 7.6 MB 01:10
livna | 2.1 kB 00:00
primary.sqlite.bz2 | 241 kB 00:01
updates | 2.3 kB 00:00
primary.sqlite.bz2 | 2.5 MB 00:22
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package system-config-network-tui.noarch 0:1.5.10-1.fc9 set to be updated
---> Package ghostscript.i386 0:8.62-4.fc9 set to be updated
---> Package bind-libs.i386 32:9.5.0-33.P1.fc9 set to be updated
---> Package evolution-data-server.i386 0:2.22.3-2.fc9 set to be updated
---> Package system-config-firewall.noarch 0:1.2.10-1.fc9 set to be updated
---> Package mesa-libGLU.i386 0:7.1-0.37.fc9 set to be updated
---> Package dmraid.i386 0:1.0.0.rc14-8.fc9 set to be updated
---> Package ccrtp.i386 0:1.6.0-1.fc9 set to be updated
---> Package gnome-panel-libs.i386 0:2.22.2-2.fc9 set to be updated
---> Package totem-pl-parser.i386 0:2.22.3-1.fc9 set to be updated
---> Package db4-cxx.i386 0:4.6.21-6.fc9 set to be updated
---> Package gstreamer-plugins-base.i386 0:0.10.19-2.fc9 set to be updated
---> Package gail.i386 0:1.22.3-1.fc9 set to be updated
---> Package xorg-x11-fonts-ISO8859-1-75dpi.noarch 0:7.2-6.fc9 set to be updated
---> Package kudzu-devel.i386 0:1.2.85-1 set to be updated
---> Package libvorbis.i386 1:1.2.0-4.fc9 set to be updated
---> Package perl.i386 4:5.10.0-31.fc9 set to be updated
---> Package selinux-policy-targeted.noarch 0:3.3.1-79.fc9 set to be updated
---> Package kde-settings.noarch 0:4.0-24.fc9 set to be updated
---> Package nss_compat_ossl.i386 0:0.9.2-5.fc9 set to be updated
---> Package cyrus-sasl-md5.i386 0:2.1.22-15.fc9 set to be updated
---> Package glibmm24.i386 0:2.16.2-1.fc9 set to be updated
---> Package glibc.i686 0:2.8-8 set to be updated
--> Processing Dependency: glibc-common = 2.8-8 for package: glibc
---> Package ImageMagick-devel.i386 0:6.3.8.1-4.fc9 set to be updated
--> Processing Dependency: jasper for package: ImageMagick-devel
---> Package libpng-devel.i386 2:1.2.29-1.fc9 set to be updated
---> Package compat-libstdc++-296.i386 0:2.96-140 set to be updated
---> Package libSM-devel.i386 0:1.1.0-1.fc9 set to be updated
---> Package e2fsprogs-devel.i386 0:1.40.8-3.fc9 set to be updated
---> Package libgweather.i386 0:2.22.3-1.fc9 set to be updated
---> Package pango-devel.i386 0:1.20.4-1.fc9 set to be updated
---> Package lm_sensors.i386 0:3.0.2-1.fc9 set to be updated
---> Package cyrus-sasl-plain.i386 0:2.1.22-15.fc9 set to be updated
---> Package beecrypt.i386 0:4.1.2-17.fc9 set to be updated
---> Package gnome-keyring.i386 0:2.22.3-1.fc9 set to be updated
---> Package nfs-utils-lib.i386 0:1.1.1-5.fc9 set to be updated
---> Package libdrm-devel.i386 0:2.4.0-0.13.fc9 set to be updated
---> Package libgtop2.i386 0:2.22.3-1.fc9 set to be updated
---> Package freetype-devel.i386 0:2.3.5-6.fc9 set to be updated
---> Package hwbrowser.noarch 0:0.42-1.fc9 set to be updated
-...

cc3283@att.com
30th July 2008, 07:02 PM
updated post

leigh123linux
30th July 2008, 07:07 PM
updated post


Can you post


yum --skip-broken update

cc3283@att.com
30th July 2008, 07:15 PM
Sorry I missed that, attached please find the output.

leigh123linux
30th July 2008, 07:36 PM
Try



yum erase opal ImageMagick-devel libfwbuilder fwbuilder-ipt fwbuilder-devel fwbuilder
yum --skip-broken update

cc3283@att.com
1st August 2008, 03:11 PM
see attached output

leigh123linux
1st August 2008, 03:18 PM
Try

su
yum erase lcms-devel lcms
yum --skip-broken update

cc3283@att.com
1st August 2008, 05:17 PM
Much better,, attached is the output

leigh123linux
1st August 2008, 05:46 PM
Post


rpm -qa |grep glibc
rpm -qa |grep db4


and



yum update db4

cc3283@att.com
1st August 2008, 06:10 PM
output attached

leigh123linux
1st August 2008, 06:14 PM
Try



rpm -e db4-utils
yum update

cc3283@att.com
4th August 2008, 02:30 PM
output attached,

Thanks again for all you time spent on this!

leigh123linux
4th August 2008, 02:42 PM
output attached,

Thanks again for all you time spent on this!


Ok try



su
yum --skip-broken update

cc3283@att.com
4th August 2008, 03:05 PM
output attached

leigh123linux
4th August 2008, 03:37 PM
Try this ( warning glibc is a critical file so the next command could damage you fedora install !! )



su
yumdownloader glibc.i686
rpm -Uvh --replacefiles --replacepkgs glibc*.i686*rpm
yum --skip-broken update
yum update

cc3283@att.com
4th August 2008, 03:52 PM
[root@esacdev ~]# yumdownloader glibc.i686
Loaded plugins: refresh-packagekit
fedora | 2.4 kB 00:00
livna | 2.1 kB 00:00
updates | 2.3 kB 00:00
glibc-2.8-8.i686.rpm | 5.5 MB 00:56
[root@esacdev ~]# rpm -Uvh --replacefiles --replacepkgs glibc*.i686*rpm
error: Failed dependencies:
glibc-common = 2.8-8 is needed by glibc-2.8-8.i686
glibc = 2.8-3 is needed by (installed) glibc-common-2.8-3.i386
glibc = 2.8-3 is needed by (installed) glibc-headers-2.8-3.i386
glibc = 2.8-3 is needed by (installed) glibc-devel-2.8-3.i386
[root@esacdev ~]#

leigh123linux
4th August 2008, 04:05 PM
Ok


su
yumdownloader glibc.i686 glibc-common glibc-headers glibc-devel
rpm -Uvh --replacefiles --replacepkgs glibc*.i686*rpm glibc-common*rpm glibc-headers*rpm glibc-devel*rpm
yum --skip-broken update
yum update

cc3283@att.com
4th August 2008, 04:11 PM
I did not run the yum update



[root@esacdev ~]# rpm -Uvh --replacefiles --replacepkgs glibc*.i686*rpm glibc-common*rpm glibc-headers*rpm glibc-devel*rpm
error: File not found by glob: glibc-common*rpm
error: File not found by glob: glibc-headers*rpm
error: Failed dependencies:
glibc-common = 2.8-8 is needed by glibc-2.8-8.i686
glibc-headers = 2.8-8 is needed by glibc-devel-2.8-8.i386
glibc = 2.8-3 is needed by (installed) glibc-common-2.8-3.i386
glibc = 2.8-3 is needed by (installed) glibc-headers-2.8-3.i386
[root@esacdev ~]#

leigh123linux
4th August 2008, 04:17 PM
Try



wget http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/updates/9/i386/glibc-common-2.8-8.i386.rpm
wget http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/updates/9/i386/glibc-headers-2.8-8.i386.rpm
rpm -Uvh --replacefiles --replacepkgs glibc*.i686*rpm glibc-common*rpm glibc-headers*rpm glibc-devel*rpm
yum --skip-broken update
yum update

cc3283@att.com
5th August 2008, 05:15 PM
all went fine, except the yum update, see attached

leigh123linux
5th August 2008, 09:39 PM
Try



yum erase python-devel
yum update python

cc3283@att.com
15th August 2008, 04:58 PM
Sorry it has taken so long to get back to you

[root@esacdev ~]# yum erase python-devel
Loaded plugins: refresh-packagekit
Setting up Remove Process
fedora | 2.4 kB 00:00
livna | 2.1 kB 00:00
updates | 2.3 kB 00:00
primary.sqlite.bz2 | 2.8 MB 02:52
Resolving Dependencies
--> Running transaction check
---> Package python-devel.i386 0:2.5.1-25.fc9 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Removing:
python-devel i386 2.5.1-25.fc9 installed 2.4 M

Transaction Summary
================================================== ===========================
Install 0 Package(s)
Update 0 Package(s)
Remove 1 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing : python-devel [1/1]

Removed: python-devel.i386 0:2.5.1-25.fc9
Complete!
[root@esacdev ~]# yum update python
Loaded plugins: refresh-packagekit
Existing lock /var/run/yum.pid: another copy is running as pid 8998.
Another app is currently holding the yum lock; waiting for it to exit...
Another app is currently holding the yum lock; waiting for it to exit...
Another app is currently holding the yum lock; waiting for it to exit...
Another app is currently holding the yum lock; waiting for it to exit...
Another app is currently holding the yum lock; waiting for it to exit...
Another app is currently holding the yum lock; waiting for it to exit...
Another app is currently holding the yum lock; waiting for it to exit...
Another app is currently holding the yum lock; waiting for it to exit...
Another app is currently holding the yum lock; waiting for it to exit...
Setting up Update Process
Could not find update match for python
No Packages marked for Update

leigh123linux
15th August 2008, 05:09 PM
Ok post



yum list |grep python |grep installed


yum list |grep perl |grep installed


package-cleanup --problems


package-cleanup --orphans

and


yum update

cc3283@att.com
15th August 2008, 05:27 PM
See attached

leigh123linux
15th August 2008, 07:20 PM
Post


cat /etc/yum.repos.d/fedora.repo


cat /etc/yum.repos.d/fedora-updates.repo


cat /etc/yum.repos.d/livna.repo


cat /etc/yum.conf

cc3283@att.com
18th August 2008, 02:50 PM
[root@esacdev ~]# cat /etc/yum.repos.d/fedora.repo
[fedora]
name=Fedora $releasever - $basearch
failovermethod=priority
baseurl=ftp://ftp.is.co.za/linux/distributions/fedora/linux/releases/9/Everything/x86_64/os
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$releasever&arch=$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY

[root@esacdev ~]# cat /etc/yum.repos.d/fedora-updates.repo
[updates]
name=Fedora $releasever - $basearch - Updates
failovermethod=priority
baseurl=ftp://ftp.is.co.za/linux/distributions/fedora/linux/updates/9/x86_64/
http://ftp.leg.uct.ac.za/pub/linux/fedora/updates/9/x86_64
http://download.fedora.redhat.com/pub/fedora/linux/updates/$releasever/$basearch/
#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f$releasever&arch=$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora

[root@esacdev ~]# cat /etc/yum.repos.d/livna.repo
[livna]
name=Livna for Fedora Core $releasever - $basearch - Base
baseurl=
http://rpm.livna.org/fedora/$releasever/$basearch/
http://livna.cat.pdx.edu/fedora/$releasever/$basearch/
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/$basearch/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/
http://mirror.atrpms.net/livna/fedora/$releasever/$basearch/
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/$basearch/
failovermethod=priority
#mirrorlist=http://rpm.livna.org/mirrorlist-7
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna

[livna-debuginfo]
name=Livna for Fedora Core $releasever - $basearch - Debug
baseurl=
http://rpm.livna.org/fedora/$releasever/$basearch/debug/
http://livna.cat.pdx.edu/fedora/$releasever/$basearch/debug/
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/$basearch/debug/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/debug/
http://mirror.atrpms.net/livna/fedora/$releasever/$basearch/debug/
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/$basearch/debug/
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
gpgcheck=1

[livna-source]
name=Livna for Fedora Core $releasever - $basearch - Source
baseurl=
http://rpm.livna.org/fedora/$releasever/SRPMS/
http://livna.cat.pdx.edu/fedora/$releasever/SRPMS/
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/SRPMS/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/SRPMS/
http://mirror.atrpms.net/livna/fedora/$releasever/SRPMS/
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/SRPMS/
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
gpgcheck=1
[root@esacdev ~]# cat /etc/yum.conf
[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
installonly_limit=2

# This is the default, if you make this bigger yum won't see if the metadata
# is newer on the remote and so you'll "gain" the bandwidth of not having to
# download the new metadata and "pay" for it by yum not having correct
# information.
# It is esp. important, to have correct metadata, for distributions like
# Fedora which don't keep old packages around. If you don't like this checking
# interupting your command line usage, it's much better to have something
# manually check the metadata once an hour (yum-updatesd will do this).
# metadata_expire=90m

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
[root@esacdev ~]#

leigh123linux
18th August 2008, 02:59 PM
[root@esacdev ~]# cat /etc/yum.repos.d/fedora.repo
[fedora]
name=Fedora $releasever - $basearch
failovermethod=priority
baseurl=ftp://ftp.is.co.za/linux/distributions/fedora/linux/releases/9/Everything/x86_64/os
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$releasever&arch=$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY

[root@esacdev ~]# cat /etc/yum.repos.d/fedora-updates.repo
[updates]
name=Fedora $releasever - $basearch - Updates
failovermethod=priority
baseurl=ftp://ftp.is.co.za/linux/distributions/fedora/linux/updates/9/x86_64/
http://ftp.leg.uct.ac.za/pub/linux/fedora/updates/9/x86_64
http://download.fedora.redhat.com/pub/fedora/linux/updates/$releasever/$basearch/
#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f$releasever&arch=$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora

[root@esacdev ~]# cat /etc/yum.repos.d/livna.repo
[livna]
name=Livna for Fedora Core $releasever - $basearch - Base
baseurl=
http://rpm.livna.org/fedora/$releasever/$basearch/
http://livna.cat.pdx.edu/fedora/$releasever/$basearch/
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/$basearch/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/
http://mirror.atrpms.net/livna/fedora/$releasever/$basearch/
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/$basearch/
failovermethod=priority
#mirrorlist=http://rpm.livna.org/mirrorlist-7
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna

[livna-debuginfo]
name=Livna for Fedora Core $releasever - $basearch - Debug
baseurl=
http://rpm.livna.org/fedora/$releasever/$basearch/debug/
http://livna.cat.pdx.edu/fedora/$releasever/$basearch/debug/
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/$basearch/debug/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/$basearch/debug/
http://mirror.atrpms.net/livna/fedora/$releasever/$basearch/debug/
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/$basearch/debug/
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
gpgcheck=1

[livna-source]
name=Livna for Fedora Core $releasever - $basearch - Source
baseurl=
http://rpm.livna.org/fedora/$releasever/SRPMS/
http://livna.cat.pdx.edu/fedora/$releasever/SRPMS/
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/$releasever/SRPMS/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/$releasever/SRPMS/
http://mirror.atrpms.net/livna/fedora/$releasever/SRPMS/
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/$releasever/SRPMS/
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-livna
gpgcheck=1
[root@esacdev ~]# cat /etc/yum.conf
[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
installonly_limit=2

# This is the default, if you make this bigger yum won't see if the metadata
# is newer on the remote and so you'll "gain" the bandwidth of not having to
# download the new metadata and "pay" for it by yum not having correct
# information.
# It is esp. important, to have correct metadata, for distributions like
# Fedora which don't keep old packages around. If you don't like this checking
# interupting your command line usage, it's much better to have something
# manually check the metadata once an hour (yum-updatesd will do this).
# metadata_expire=90m

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
[root@esacdev ~]#



OK your fedora.repo & fedora-updates.repo are incorrect !


try



su
rpm -Uvh --replacefiles --replacepkgs http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/releases/9/Everything/i386/os/Packages/fedora-release-9-2.noarch.rpm


Then post


yum update

cc3283@att.com
18th August 2008, 03:36 PM
See attached

leigh123linux
18th August 2008, 05:13 PM
Post



yum reinstall *libxslt* libselinux*

cc3283@att.com
18th August 2008, 05:39 PM
[root@esacdev ~]# yum reinstall *libxslt* libselinux*
Loaded plugins: refresh-packagekit
Setting up Reinstall Process
fedora | 2.4 kB 00:00
livna | 2.1 kB 00:00
primary.sqlite.bz2 | 253 kB 00:02
updates | 2.3 kB 00:00
Error: No package(s) available to install
[root@esacdev ~]#

leigh123linux
18th August 2008, 05:59 PM
Ok post


yum list |grep libxslt


yum reinstall *libxslt*

cc3283@att.com
18th August 2008, 06:17 PM
[root@esacdev ~]# yum list |grep libxslt
libxslt.i386 1.1.23-3.fc9 installed
libxslt-devel.i386 1.1.23-3.fc9 installed
libxslt-python.i386 1.1.23-3.fc9 installed
libxslt.i386 1.1.24-2.fc9 updates
libxslt-devel.i386 1.1.24-2.fc9 updates
[root@esacdev ~]# yum reinstall *libxslt*
Loaded plugins: refresh-packagekit
Setting up Reinstall Process
Error: No package(s) available to install
[root@esacdev ~]#

leigh123linux
18th August 2008, 06:37 PM
The mirror you are using seems to have some packages missing ! ( there's no libxslt-python-1.1.24-2.fc9 listed )


[root@esacdev ~]# yum list |grep libxslt
libxslt.i386 1.1.23-3.fc9 installed
libxslt-devel.i386 1.1.23-3.fc9 installed
libxslt-python.i386 1.1.23-3.fc9 installed
libxslt.i386 1.1.24-2.fc9 updates
libxslt-devel.i386 1.1.24-2.fc9 updates




Try these repo files



wget http://leigh123.homelinux.com/repos.d/fedora-updates.repo -O /etc/yum.repos.d/fedora-updates.repo
wget http://leigh123.homelinux.com/repos.d/fedora.repo -O /etc/yum.repos.d/fedora.repo
yum clean all
yum update

cc3283@att.com
2nd September 2008, 02:56 PM
Thanks for your expert advice, I was able to successfully run yum update.

Why are there so many "broken" repos?
And what was at the core of this trouble?

Thanks Again,

leigh123linux
2nd September 2008, 03:30 PM
Thanks for your expert advice, I was able to successfully run yum update.

Why are there so many "broken" repos?
And what was at the core of this trouble?

Thanks Again,


I glad it's sorted :cool:




Why are there so many "broken" repos?
And what was at the core of this trouble



It was due to these edits and a bad mirror .

ftp://ftp.is.co.za/linux/distributions/fedora/linux/releases/9









[root@esacdev ~]# cat /etc/yum.repos.d/fedora.repo
[fedora]
name=Fedora $releasever - $basearch
failovermethod=priority
baseurl=ftp://ftp.is.co.za/linux/distributions/fedora/linux/releases/9/Everything/x86_64/os
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$releasever&arch=$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY

[root@esacdev ~]# cat /etc/yum.repos.d/fedora-updates.repo
[updates]
name=Fedora $releasever - $basearch - Updates
failovermethod=priority
baseurl=ftp://ftp.is.co.za/linux/distributions/fedora/linux/updates/9/x86_64/
http://ftp.leg.uct.ac.za/pub/linux/...pdates/9/x86_64
http://download.fedora.redhat.com/pub/fedora/linux/updates/$releasever/$basearch/
#mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-released-f$releasever&arch=$basearch
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora