PDA

View Full Version : Is RPM lying to me?



BlueH2O
24th July 2008, 05:52 PM
RPM seems to be telling me there are no dependencies, and then it tells me there are. What gives?

[root@arturo html]# rpm -q --whatrequires glibc-2.8-3.i686
no package requires glibc-2.8-3.i686
[root@arturo html]# rpm -e glibc-2.8-3.i686
error: Failed dependencies:
libc.so.6 is needed by (installed) compat-libstdc++-33-3.2.3-63.i386
libc.so.6 is needed by (installed) x10ephem-0.50-1.i386
libc.so.6(GLIBC_2.0) is needed by (installed) compat-libstdc++-33-3.2.3-63.i386
libc.so.6(GLIBC_2.0) is needed by (installed) x10ephem-0.50-1.i386
libc.so.6(GLIBC_2.1) is needed by (installed) compat-libstdc++-33-3.2.3-63.i386
libc.so.6(GLIBC_2.1.3) is needed by (installed) compat-libstdc++-33-3.2.3-63.i386
libc.so.6(GLIBC_2.1.3) is needed by (installed) x10ephem-0.50-1.i386
libc.so.6(GLIBC_2.2) is needed by (installed) compat-libstdc++-33-3.2.3-63.i386
libc.so.6(GLIBC_2.3) is needed by (installed) compat-libstdc++-33-3.2.3-63.i386
libm.so.6 is needed by (installed) compat-libstdc++-33-3.2.3-63.i386
libm.so.6 is needed by (installed) x10ephem-0.50-1.i386
libm.so.6(GLIBC_2.0) is needed by (installed) x10ephem-0.50-1.i386

:confused:

markkuk
24th July 2008, 06:28 PM
It's telling you the exact truth, there's no dependency specifically for "glibc-2.8-3.i686", but there are various dependencies for the files and symbols provided by that package (see "rpm -q --provides glibc-2.8-3.i686").

BlueH2O
24th July 2008, 06:31 PM
It's telling you the exact truth, there's no dependency specifically for "glibc-2.8-3.i686", but there are various dependencies for the files and symbols provided by that package (see "rpm -q --provides glibc-2.8-3.i686").

Is there a way to get rpm to list the packages that are needed rather than the files? I tried to get yum to do it for this particular package, but..

[root@arturo ~]# yum deplist x10ephem
Finding dependencies:

..it gave me nothing.

Hlingler
24th July 2008, 07:38 PM
RPM seems to be telling me there are no dependencies, and then it tells me there are. What gives?

[root@arturo html]# rpm -q --whatrequires glibc-2.8-3.i686
no package requires glibc-2.8-3.i686
[root@arturo html]# rpm -e glibc-2.8-3.i686
error: Failed dependencies:
libc.so.6 is needed by (installed) compat-libstdc++-33-3.2.3-63.i386
libc.so.6 is needed by (installed) x10ephem-0.50-1.i386
libc.so.6(GLIBC_2.0) is needed by (installed) compat-libstdc++-33-3.2.3-63.i386
libc.so.6(GLIBC_2.0) is needed by (installed) x10ephem-0.50-1.i386
libc.so.6(GLIBC_2.1) is needed by (installed) compat-libstdc++-33-3.2.3-63.i386
libc.so.6(GLIBC_2.1.3) is needed by (installed) compat-libstdc++-33-3.2.3-63.i386
libc.so.6(GLIBC_2.1.3) is needed by (installed) x10ephem-0.50-1.i386
libc.so.6(GLIBC_2.2) is needed by (installed) compat-libstdc++-33-3.2.3-63.i386
libc.so.6(GLIBC_2.3) is needed by (installed) compat-libstdc++-33-3.2.3-63.i386
libm.so.6 is needed by (installed) compat-libstdc++-33-3.2.3-63.i386
libm.so.6 is needed by (installed) x10ephem-0.50-1.i386
libm.so.6(GLIBC_2.0) is needed by (installed) x10ephem-0.50-1.i386

:confused:You've asked the wrong question. You asked what requires the specific version of glibc: glibc-2.8-3.i686. Sounds like what you really want to know is: what requires glibc:
~]$ rpm -q --whatrequires glibc
avast4workstation-1.0.8-1.i586
ppp-2.4.4-2.i386
isapnptools-1.26-6.i686
pam-0.99.8.1-17.1.fc8.i386
glibc-headers-2.7-2.i386
glibc-devel-2.7-2.i386
lockdev-1.0.1-11.fc8.1.i386
nss_db-2.2-40.fc8.i386
dump-0.4b41-6.fc8.i386
prelink-0.4.0-1.i386
openldap-2.3.39-4.fc8.i386V

BlueH2O
24th July 2008, 07:45 PM
What I want to know is why rpm says it cant erase glibc-2.8-3.i686 because x10ephem requires it, but when I ask what requires glibc-2.8-3.i686 it tells me "no package requires" it. That doesn't make any sense.

Hlingler
24th July 2008, 07:59 PM
Asked and answered: you cannot erase glibc because x10ephem requires libm.so.6, and only package glibc-2.8-3.i686 provides libm.so.6, not because x10ephem requires glibc-2.8-3.i686 in particular.

No packages require the specific version of glibc: glibc-2.8-3.i686. But several other packages require that some version of glibc and/or it's contents libm.so.6 be available.

Be aware that in addition, rpm does not do dep-solving, so there could be a dependency chain that could escalate into an ugly cascade if you try to remove a critical package - like glibc.

V

Dies
24th July 2008, 08:09 PM
What I want to know is why rpm says it cant erase glibc-2.8-3.i686 because x10ephem requires it, but when I ask what requires glibc-2.8-3.i686 it tells me "no package requires" it. That doesn't make any sense.

To us it may not make any sense, but....

In any case, although there has to be a much, much easier way to get this type of result, until some rpm guru shows up try something like


rpm -q --whatrequires $( rpm -q --filesbypkg glibc ) | sort -u | sed '/^no\ pack*/d'

which gives you output like



a2ps-4.14-5.fc9.i386
a52dec-0.7.4-11.lvn8.i386
aalib-libs-1.4.0-0.15.rc5.fc9.i386
alsa-lib-1.0.16-3.fc9.i386
anjuta-2.4.1-1.fc9.i386
apr-1.2.12-2.fc9.i386
apr-util-1.2.12-5.fc9.i386
atk-1.22.0-1.fc9.i386
atlas-3.6.0-15.fc9.i386
at-spi-1.22.1-1.fc9.i386
audiofile-0.2.6-8.fc9.i386
audit-libs-1.7.4-1.fc9.i386
autogen-libopts-5.9.4-4.fc9.i386
avahi-compat-libdns_sd-0.6.22-10.fc9.i386
avahi-glib-0.6.22-10.fc9.i386
bind-libs-9.5.0-33.P1.fc9.i386
binutils-2.18.50.0.6-4.fc9.i386
bluez-libs-3.32-1.fc9.i386
bzip2-libs-1.0.5-2.fc9.i386
cairo-1.6.4-1.fc9.i386
cairo-java-1.0.5-9.fc9.i386
cairomm-1.5.0-1.fc9.i386
Canna-libs-3.7p3-23.fc9.i386
check-0.9.5-2.fc9.1.i386
compat-libstdc++-296-2.96-140.i386
compat-libstdc++-33-3.2.3-63.i386
compiz-0.7.7-10.fc9.i386
cracklib-2.8.12-2.i386
cryptsetup-luks-1.0.6-2.fc9.i386
cups-libs-1.3.7-8.fc9.i386
cyrus-sasl-lib-2.1.22-13.fc9.i386
db4-4.6.21-6.fc9.i386
dbus-glib-0.74-8.fc9.i386
dbus-libs-1.2.1-1.fc9.i386
device-mapper-libs-1.02.24-11.fc9.i386
dirac-libs-0.9.1-2.fc9.i386
directfb-1.0.0-4.fc9.i386
djvulibre-libs-3.5.20-2.fc9.i386
dmraid-1.0.0.rc14-8.fc9.i386
dump-0.4b41-7.1.fc9.i386
e2fsprogs-libs-1.40.8-3.fc9.i386
eel2-2.22.2-1.fc9.i386
elfutils-libelf-0.133-3.fc9.i386
elfutils-libs-0.133-3.fc9.i386
enca-1.9-4.fc9.i386
enchant-1.4.2-1.fc9.i386
esound-libs-0.2.38-7.fc9.i386
evolution-data-server-2.22.3-2.fc9.i386
exempi-2.0.1-1.fc9.i386
expat-2.0.1-5.i386
faac-1.25-4.lvn8.i386
faad2-libs-2.6.1-3.lvn9.i386
festival-lib-1.96-4.fc9.i386
festival-speechtools-libs-1.2.96-4.fc9.i386
ffmpeg-compat-0.4.9-0.47.20080225.lvn9.i386
ffmpeg-libs-0.4.9-0.46.20080225.lvn9.i386
file-libs-4.23-5.fc9.i386
flac-1.2.1-4.fc9.i386
fontconfig-2.5.0-2.fc9.i386
freealut-1.1.0-6.fc9.i386
freeglut-2.4.0-14.fc9.i386
freetype-2.3.5-6.fc9.i386
freetype-freeworld-2.3.5-6.lvn9.i386
fribidi-0.19.1-2.fc9.i386
frysk-0.4-0.fc9.i386
fuse-libs-2.7.3-2.fc9.i386
gail-1.22.3-1.fc9.i386
gc-7.0-7.fc9.i386
GConf2-2.22.0-1.fc9.i386
gd-2.0.35-5.fc9.i386
gdbm-1.8.0-28.fc9.i386
gettext-0.17-4.fc9.i386
ggz-client-libs-0.0.14.1-1.fc9.i386
ghostscript-8.62-4.fc9.i386
giflib-4.1.3-9.i386
gimp-libs-2.4.6-1.fc9.i386
glade3-libgladeui-3.4.4-1.fc9.i386
glib2-2.16.4-1.fc9.i386
glibc-2.8-8.i686
glibc-common-2.8-8.i386
glibc-devel-2.8-8.i386
glibc-headers-2.8-8.i386
glib-java-0.2.6-12.fc9.i386
glibmm24-2.16.2-1.fc9.i386
gmime-2.2.18-1.fc9.i386
gmp-4.2.2-7.fc9.i386
gmyth-0.7.1-1.fc9.i386
gnome-bluetooth-libs-0.11.0-3.fc9.i386
gnome-build-0.2.4-1.fc9.i386
gnome-desktop-2.22.3-1.fc9.i386
gnome-keyring-2.22.3-1.fc9.i386
gnome-mag-0.15.0-2.fc9.i386
gnome-menus-2.22.2-1.fc9.i386
gnome-sharp-2.16.1-1.fc9.i386
gnome-speech-0.4.18-3.fc9.i386
gnome-vfs2-2.22.0-1.fc9.i386
gnutls-2.0.4-3.fc9.i386
gpgme-1.1.6-3.fc9.i386
gpm-1.20.1-92.fc9.i386
graphviz-2.16.1-0.5.fc9.i386
gsm-1.0.12-6.fc9.i386
gstreamer-0.10.19-1.fc9.i386
gstreamer-plugins-bad-0.10.7-1.lvn9.i386
gstreamer-plugins-farsight-0.12.7-2.fc9.i386
gtkhtml2-2.11.1-3.fc9.i386
gtkhtml3-3.18.3-1.fc9.i386
gtkmm24-2.12.7-1.fc9.i386
gtk-sharp2-2.10.3-3.fc9.i386
gtksourceview2-2.2.2-1.fc9.i386
gtkspell-2.0.11-8.fc9.i386
guile-1.8.4-1.fc9.i386
gutenprint-5.0.2-2.fc9.i386
hal-0.5.11-2.fc9.i386
hesiod-3.1.0-10.i386
hunspell-1.2.1-7.fc9.i386
hyphen-2.3.1-2.fc9.i386
ilmbase-1.0.1-2.fc9.i386
ImageMagick-6.3.8.1-4.fc9.i386
ImageMagick-c++-6.3.8.1-4.fc9.i386
imlib2-1.4.0-7.fc9.i386
inotify-tools-3.13-1.fc9.i386
jack-audio-connection-kit-0.109.2-1.fc9.1.i386
jasper-libs-1.900.1-8.fc9.i386
keyutils-libs-1.2-3.fc9.i386
krb5-libs-1.6.3-10.fc9.i386
lame-libs-3.97-6.lvn8.i386
lcms-libs-1.17-5.fc9.i386
lftp-3.6.3-2.fc9.i386
libacl-2.2.47-1.fc9.i386
libao-0.8.8-5.fc9.i386
libarchive-2.4.17-1.fc9.i386
libart_lgpl-2.3.20-1.fc9.i386
libattr-2.4.41-1.fc9.i386
libavc1394-0.5.3-2.fc9.i386
libbeagle-0.3.5-1.fc9.i386
libbonobo-2.22.0-2.fc9.i386
libbonoboui-2.22.0-2.fc9.i386
libbtctl-0.10.0-2.fc9.i386
libburn-0.4.0-2.fc9.i386
libcaca-0.99-0.4.beta11.fc9.i386
libcap-2.06-4.fc9.i386
libcdaudio-0.99.12p2-9.fc9.i386
libcddb-1.3.0-4.fc9.i386
libcdio-0.79-3.fc9.i386
libcompizconfig-0.7.7-8.fc9.i386
libconfig-1.2.1-2.fc9.i386
libcurl-7.18.2-1.fc9.i386
libdaemon-0.12-3.fc9.i386
libdc1394-2.0.2-1.fc9.i386
libdca-0.0.5-2.lvn8.i386
libdhcp-1.99.8-1.fc9.i386
libdhcp4client-4.0.0-14.fc9.i386
libdhcp6client-1.0.14-1.fc9.i386
libdmx-1.0.2-5.fc9.i386
libdrm-2.4.0-0.13.fc9.i386
libdv-1.0.0-4.fc9.i386
libdvbpsi-0.1.6-2.lvn9.i386
libdvdcss-1.2.9-5.lvn9.i386
libdvdnav-4.1.2-1.fc9.i386
libdvdread-4.1.2-1.fc9.i386
libebml-0.7.8-1.fc9.i386
libedit-2.10-4.20070831cvs.fc9.i386
libEMF-1.0.3-7.fc9.i386
libevent-1.3e-2.fc9.i386
libexif-0.6.16-1.fc9.i386
libfontenc-1.0.4-5.fc9.i386
libfreebob-1.0.7-4.fc9.i386
libgail-gnome-1.20.0-2.fc9.i386
libgcj-4.3.0-8.i386
libgconf-java-2.12.4-10.fc9.i386
libgcrypt-1.4.0-3.i386
libgdiplus-1.9-4.fc9.i386
libgdl-0.7.11-1.fc9.i386
libgfortran-4.3.0-8.i386
libggz-0.0.14.1-1.fc9.i386
libglade2-2.6.2-5.fc9.i386
libglademm24-2.6.6-1.fc9.i386
libgnome-2.22.0-3.fc9.i386
libgnomecanvas-2.20.1.1-2.fc9.i386
libgnomecups-0.2.3-3.fc9.i386
libgnomeprint22-2.18.4-1.fc9.i386
libgnomeprintui22-2.18.2-1.fc9.i386
libgnomeui-2.22.1-2.fc9.i386
libgomp-4.3.0-8.i386
libgpg-error-1.6-2.i386
libgpod-0.6.0-4.fc9.i386
libgsf-1.14.8-1.fc9.i386
libgssglue-0.1-6.fc9.i386
libgtk-java-2.8.7-7.fc9.i386
libgtop2-2.22.3-1.fc9.i386
libgweather-2.22.3-1.fc9.i386
libICE-1.0.4-3.fc9.i386
libicu-3.8.1-7.fc9.i386
libid3tag-0.15.1b-6.fc9.i386
libIDL-0.8.10-2.fc9.i386
libidn-0.6.14-7.i386
libiec61883-1.1.0-4.fc9.i386
libieee1284-0.2.11-3.fc9.i386
libiptcdata-1.0.2-2.fc9.i386
libisofs-0.2.8-3.fc9.i386
libjingle-0.3.11-8.fc9.i386
libjpeg-6b-41.fc9.i386
libksba-1.0.3-2.fc9.i386
libmad-0.15.1b-6.lvn9.i386
libmatroska-0.8.1-3.fc9.i386
libmikmod-3.2.0-3.beta2.fc9.i386
libmms-0.4-1.lvn9.i386
libmng-1.0.9-6.1.i386
libmodplug-0.8.4-3.fc9.i386
libmp4v2-1.5.0.1-6.fc9.i386
libmpcdec-1.2.6-4.fc9.i386
libmtp-0.2.6.1-1.fc9.i386
libmusicbrainz-2.1.5-6.fc9.i386
libnetfilter_conntrack-0.0.89-0.1.svn7356.fc9.i386
libnfnetlink-0.0.33-0.1.svn7211.fc9.i386
libnl-1.1-3.fc9.i386
libogg-1.1.3-9.fc9.i386
liboil-0.3.14-1.fc9.i386
libopendaap-0.4.0-5.fc9.i386
libopenraw-0.0.5-1.fc9.i386
libopenraw-gnome-0.0.5-1.fc9.i386
libpaper-1.1.23-2.fc9.i386
libpcap-0.9.8-2.fc9.i386
libpciaccess-0.10.3-2.fc9.i386
libpng-1.2.29-1.fc9.i386
libpurple-2.4.3-1.fc9.i386
libquicktime-1.0.2-3.lvn9.i386
libraw1394-1.3.0-7.fc9.i386
libsamplerate-0.1.2-8.fc9.i386
libselinux-2.0.67-4.fc9.i386
libsemanage-2.0.25-1.fc9.i386
libsepol-2.0.32-1.fc9.i386
libsexy-0.1.11-7.fc9.i386
libshout-2.2.2-3.fc9.i386
libsidplay-1.36.57-17.i386
libsigc++20-2.2.2-1.fc9.i386
libsilc-1.1.7-1.fc9.i386
libSM-1.1.0-1.fc9.i386
libsmbios-2.0.1-2.fc9.1.i386
libsndfile-1.0.17-3.fc9.i386
libsoup-2.4.1-1.fc9.i386
libspectre-0.2.0-2.fc9.i386
libstdc++-4.3.0-8.i386
libsysfs-2.1.0-4.fc9.i386
libtar-1.2.11-11.fc9.i386
libtasn1-1.3-1.fc9.i386
libtextcat-2.2-5.fc9.i386
libthai-0.1.9-4.fc9.i386
libtheora-1.0beta2-4.fc9.i386
libtiff-3.8.2-10.fc9.i386
libtimidity-0.1.0-6.fc9.i386
libtirpc-0.1.7-18.fc9.i386
libtool-ltdl-1.5.24-6.fc9.i386
libupnp-1.6.6-1.fc9.i386
libusb-0.1.12-15.fc9.i386
libuser-0.56.9-1.i386
libutempter-1.1.5-2.fc9.i386
libvisual-0.4.0-6.fc9.i386
libvolume_id-124-1.fc9.2.i386
libvorbis-1.2.0-4.fc9.i386
libwiimote-0.4-6.fc9.i386
libwmf-lite-0.2.8.4-18.fc9.i386
libwnck-2.22.3-1.fc9.i386
libwpd-0.8.14-1.fc9.i386
libwvstreams-4.4.1-4.fc9.i386
libX11-1.1.4-1.fc9.i386
libXau-1.0.3-5.fc9.i386
libXaw-1.0.4-2.fc9.i386
libxcb-1.1-4.fc9.i386
libXcomposite-0.4.0-4.fc9.i386
libXcursor-1.1.9-2.fc9.i386
libXdamage-1.1.1-4.fc9.i386
libXdmcp-1.0.2-5.fc9.i386
libXevie-1.0.2-3.fc9.i386
libXext-1.0.4-1.fc9.i386
libXfixes-4.0.3-3.fc9.i386
libXfont-1.3.2-1.fc9.i386
libXfontcache-1.0.4-5.fc9.i386
libXft-2.1.12-5.fc9.i386
libXi-1.1.3-4.fc9.i386
libXinerama-1.0.3-1.fc9.i386
libxkbfile-1.0.4-5.fc9.i386
libxklavier-3.5-1.fc9.i386
libXmu-1.0.4-1.fc9.i386
libXpm-3.5.7-4.fc9.i386
libXrandr-1.2.2-3.fc9.i386
libXrender-0.9.4-3.fc9.i386
libXres-1.0.3-4.fc9.i386
.........


Yes it goes on and on and on - pretty much the whole system... :D

Hlingler
24th July 2008, 08:15 PM
This command will yield similar results:
rpm -q --whatrequires `rpm -q --provides glibc`

A rather long list....

V

BlueH2O
24th July 2008, 08:39 PM
Asked and answered: you cannot erase glibc because x10ephem requires libm.so.6, and only package glibc-2.8-3.i686 provides libm.so.6, not because x10ephem requires glibc-2.8-3.i686 in particular.

No packages require the specific version of glibc: glibc-2.8-3.i686. But several other packages require that some version of glibc and/or it's contents libm.so.6 be available.

Be aware that in addition, rpm does not do dep-solving, so there could be a dependency chain that could escalate into an ugly cascade if you try to remove a critical package - like glibc.

V

Thanks.. The real trouble is that x10ephem is the only package that requires glibc.i386 on my system, since i use 64 bit.. but for some reason the source package does not build one of the three binaries in the i386 rpm, so I'm stuck with it for now. I've sent an email off to the author but I don't know enough about rpm and/or gcc to resolve the problem.

Hlingler
24th July 2008, 09:29 PM
Yes, I see... you're stuck. The only other options that I see are: dump x10ephem so that you can then dump glibc.i686[.i386] (assuming of course that there are in fact no other packages that require glibc.i686[.i386] or it's contents), or re-compile the source code for x86_64 64-bit.

If I read you correctly, you've tried to re-compile, but something went wrong. Do you have the 64-bit 'devel' add-on to glibc installed? It's: glibc-devel[-2.8-3].x86_64, and you probably also need glibc-headers[-2.8-3].x86_64. Plus of course the base 64-bit packages: glibc[-2.8-3].x86_64 and glibc-common[-2.8-3].x86_64.

I see now that there are also both i386 and i686 flavors of glibc, but only i386 has a matching '-devel' add-on - very odd. Makes it even more complicated and difficult to understand. :)

V

BlueH2O
24th July 2008, 09:34 PM
Yes, I see... you're stuck. The only other options that I see are: dump x10ephem so that you can then dump glibc.i686[.i386] (assuming of course that there are in fact no other packages that require glibc.i686[.i386] or it's contents), or re-compile the source code for x86_64 64-bit.

If I read you correctly, you've tried to re-compile, but something went wrong. Do you have the 64-bit 'devel' add-on to glibc installed? It's: glibc-devel[-2.8-3].x86_64, and you probably also need glibc-headers[-2.8-3].x86_64. Plus of course the base 64-bit packages: glibc[-2.8-3].x86_64 and glibc-common[-2.8-3].x86_64.

I see now that there are also both i386 and i686 flavors of glibc, but only i386 has a matching '-devel' add-on - very odd. Makes it even more complicated and difficult to understand. :)

V

Yes, I have glibc-devel and -headers for x86_64 already, something is wrong with the source RPM I think.. Or the source *in* the source RPM.. ..and it won't compile. Guess I'm stuck with it for now. :(


# make
g++ -c -o x10events.o x10events.cc
x10events.cc: In function ‘double timeconv(char*)’:
x10events.cc:104: error: ‘strchr’ was not declared in this scope
x10events.cc:110: error: ‘strlen’ was not declared in this scope
x10events.cc:111: error: ‘strcpy’ was not declared in this scope
x10events.cc:113: error: ‘strtok’ was not declared in this scope
x10events.cc: In function ‘int main(int, char**)’:
x10events.cc:251: error: ‘strtok’ was not declared in this scope
x10events.cc:272: error: ‘strcmp’ was not declared in this scope
x10events.cc:274: warning: deprecated conversion from string constant to ‘char*’
x10events.cc:281: error: ‘strcmp’ was not declared in this scope
x10events.cc:283: warning: deprecated conversion from string constant to ‘char*’
x10events.cc:286: error: ‘strcmp’ was not declared in this scope
x10events.cc:288: warning: deprecated conversion from string constant to ‘char*’
make: *** [x10events.o] Error 1

Hlingler
25th July 2008, 09:33 PM
@BlueH2O:

I did not see the errors from 'make' that you posted (did you edit the post? I don't see an edit flag - oh well whatever).

It's possible (probable) that this source code was generated for an older version of gcc, and so is failing with the newest/latest. You could try installing the older gcc version available from standard Fedora repos - I think these are all of the relevant packages:
compat-gcc-34-3.4.6-9
compat-gcc-34-c++-3.4.6-9
compat-gcc-34-g77-3.4.6-9
compat-libgcc-296-2.96-140

To use the older compiler version when compiling: set the environment variables as described here: http://www.mjmwired.net/linux/2005/11/15/using-alternate-compilers/

Good Luck,
V

BlueH2O
25th July 2008, 09:50 PM
@BlueH2O:

I did not see the errors from 'make' that you posted (did you edit the post? I don't see an edit flag - oh well whatever).

It's possible (probable) that this source code was generated for an older version of gcc, and so is failing with the newest/latest. You could try installing the older gcc version available from standard Fedora repos - I think these are all of the relevant packages:
compat-gcc-34-3.4.6-9
compat-gcc-34-c++-3.4.6-9
compat-gcc-34-g77-3.4.6-9
compat-libgcc-296-2.96-140

To use the older compiler version when compiling: set the environment variables as described here: http://www.mjmwired.net/linux/2005/11/15/using-alternate-compilers/

Good Luck,
V

You are right, thanks! I have now built an x86_64 RPM for x10ephem.