PDA

View Full Version : Removing Sound drivers



Ned
20th July 2004, 10:44 PM
Hi,

I recently installed core 2 on a machine with no speakers. It has built in sound chipset but I disabled sound in the bios before install, yet fedora seems to be loading loads of sound modules. Here's my lsmod listing:


[root@Bart root]# lsmod
Module Size Used by
snd_pcm_oss 41000 0
snd_pcm 69256 1 snd_pcm_oss
snd_page_alloc 8072 1 snd_pcm
snd_timer 17284 1 snd_pcm
snd_mixer_oss 13824 1 snd_pcm_oss
snd 39396 4 snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
soundcore 6112 1 snd
binfmt_misc 7176 1
parport_pc 19392 1
lp 8236 0
parport 29640 2 parport_pc,lp
autofs4 12932 0
sis900 14596 0
ipt_mac 1664 3
ipt_state 1536 1
ip_conntrack 24968 1 ipt_state
iptable_filter 2176 1
ip_tables 13568 3 ipt_mac,ipt_state,iptable_filter
floppy 47440 0
sg 27680 0
scsi_mod 91984 1 sg
dm_mod 32800 0
ohci_hcd 16016 0
button 4632 0
battery 6924 0
asus_acpi 8984 0
ac 3340 0
ext3 103656 3
jbd 40728 1 ext3

I also get the following errors repeatedly appearing in my system logs


Jul 20 09:00:32 Bart modprobe: FATAL: Error running install command for sound_slot_0
Jul 20 09:01:32 Bart last message repeated 6 times
Jul 20 09:02:49 Bart last message repeated 9 times
Jul 20 09:04:40 Bart last message repeated 3 times
Jul 20 09:08:19 Bart last message repeated 6 times
Jul 20 09:08:19 Bart last message repeated 2 times

How do I remove these modules and stop the system trying to load sound related modules at boot? Do I need to specifically recompile the kernel without sound support?

Ned

foolish
20th July 2004, 10:51 PM
Comment, put a # in front of, the lines in containing snd- or sound in /etc/modprobe.conf.dist

Ned
20th July 2004, 11:16 PM
Comment, put a # in front of, the lines in containing snd- or sound in /etc/modprobe.conf.dist

Thanks - so it's OK to edit /etc/modprobe.conf.dist directly?

EDIT: OK, I did this and initially lsmod isn't showing them, but after a while they show up again with lsmod as listed above :confused:

Ned

Ned
21st July 2004, 02:32 PM
Bump :)

I've now installed on a second machine that has no sound hardware installed and I'm still getting all these sound modules loading :rolleyes:

Foolish's suggestion didn't work on that system either :(

Any other ideas? I really don't want to have to compile a custom kernel every time and update is released.

Ned

crackers
21st July 2004, 06:02 PM
Try commenting out any lines like "alias snd-card-..." in the /etc/modprobe.conf file, along with "install ... && /usr/sbin/alsactl restore" and "uninstall ... && /usr/sbin/alsactl store" lines. That should catch other pieces.

Ned
22nd July 2004, 01:05 PM
Try commenting out any lines like "alias snd-card-..." in the /etc/modprobe.conf file, along with "install ... && /usr/sbin/alsactl restore" and "uninstall ... && /usr/sbin/alsactl store" lines. That should catch other pieces.

There are no sound or alsa related entries in /etc/modprobe.conf and I've commented them out from /etc/modprobe.conf.dist and these modules are still loading.

Ned

crackers
22nd July 2004, 05:00 PM
but after a while they show up again with lsmod as listed above
I wonder - are you by chance running KDE? If so, disable ARTS (KDE Control Center -> Sound & Multimedia -> Sound System). I'll bet it's that or something similar, like Nautilus, that's expecting the sound system to be available.

I just verified that you cannot reasonably "remove" ALSA without totally hosing your system (rpm -e --test alsa-lib). Since it's not really causing issues (is it?), I'd suggest just ignoring the durn thing. It's not like the drivers are actually eating a huge chunk of memory. No harm, no foul... :D

Ned
22nd July 2004, 08:55 PM
Yes, I'm running KDE and the sound system is already disabled. I think you're right inasmuch as KDE is doing this. Was just trying to optimise out all the loaded stuff .

Thanks,

Ned