View Full Version : RPM Hangs

18th July 2008, 02:58 AM
I upgraded from Fedora 8 to 9 using Preupgrade, and everything seemed fine.

Of course KDE4 sucs, nothing is quite right, the clock is so big I can only see half of it, and the Kde button (Application launcher) has the same problem.. so I though a Yum update might fix some of these things with newer version of packages.

After a bit Yumex hung. Then I tried from the command line, YUm, hung.

After 15 or so hard-resets (the hang was always 100% CPU unkillable) I tried going to the yum cache and using RPM to install the packages there.

Now, when doing even just 1 package, RPM shows the installing, reaches 100% and then hangs, using all the CPU and refusing to be killed.

What can I do?

18th July 2008, 04:02 AM

Can you post the output of yum repolist ?


18th July 2008, 04:04 AM
Loaded plugins: protectbase
repo id repo name status
fedora Fedora 9 - i386 enabled
livna Livna for Fedora Core 9 - i386 - Base enabled
updates Fedora 9 - i386 - Updates enabled

Is it likely to be a Yum problem if even RPM by it's self hangs?

18th July 2008, 04:11 AM
I would disable the livna repo (for now) and disable or remove the protectbase plugin.
You can always set it up again if you wish.
My first guess is that the protectbase plugin may be causing you grief ?
If you have any other additional non-standard yum plugins (didn't see any) disable or remove them as well.

Then try a yum clean all and if that works fine, try a
yum check-update


18th July 2008, 04:17 AM
I decided to read the rpm help files a bit, as I first wanted to get RPM actually to update a package without crashing before moving on to yum (I think Yum calls RPM to do it's work?).. after some trial-and-error I found something that fixed the problem:

yum --initdb
yum --rebuilddb

Looks like the RPM Database might have been corrupt I guess.

I will disable the plugin, Livna repo and do a yum clean all now, then try updating everything again.

Thank for the help.