View Full Version : K3B missing writing permissions on /dev/sr0

6th July 2008, 12:23 PM
Hello, I've tryed to burn some movies onto DVD+R in my K3B. First, it didn't detected any errors. But after starting a burn proccess, it fails with an error. Then, after restart of K3B, I'll get an error message that I don't have permissions to write on /dev/sr0. The CD/DVD creator included with Nautilus doesn't work too, but I've burned two weeks ago some software and it worked. Why it's not working now? What should I have to do? Thanks in advance.

6th July 2008, 01:07 PM
chmod 777 /dev/sr0

6th July 2008, 02:40 PM
i have the same problem.
my user is in the disk group, but the devices are not writable by the group

[root@fedora ~]$ ls -lrt /dev/sr0
brw-r-----+ 1 root disk 11, 0 2008-07-05 16:11 /dev/sr0

they where rw before. the pc where i have this problem is new, and i dont know if it even worked at first
in other pcs, i never had troubles (with F9 completly up to date)

but i do remember having tried ejecting this sr device, and it was my CDRW, and now (one day later) that same device is the DVD-RW

so this is a udev update, or this particular hardware i have dosnt work as spected by the person that maked the udev rules for fedora

7th July 2008, 04:24 AM
New update of udev is out and fixes the problem.

9th July 2008, 07:26 PM
Installed Packages
Name : udev
Arch : x86_64
Version : 124
Release : 1.fc9.2

And no it certainly does not solve the problem. My drive was working fine before and not it has totally been broken. First it was the upgrade 124.1fc9.1 which broke my system now this update does not fix it. I have tried downgrading but still theres a problem. I can view, copy with k9copy but I can't burn disks.

And it's pretty annoying and inconvenient.