PDA

View Full Version : DVD playback Hardship



yr2alex
17th July 2004, 08:39 AM
I've seen screenshots of Xine and Mplayer in action but on my fc2 box- stalemate...

My machine is a 400 MHz P2 with 633MB of ram, running Fedora Core 2, dvd player is a SONY DVD-ROM DDU220E

I yum installed the following pkgs: libdvdcss, libdvdread, libdvdnav, libdvdplay, xine-ui, xine-lib, etc, mplayer-gui, etc...

Here are some of the steps I've taken so far. I probably overlooked some minute detail but just don't know what. Maybe you can help (at least I hope so). BTW the GUI loads fine for both Xine and Mplayer but opted to run it in the cli.

I tried to get Xine to go first, did the following:

[root@FC2-Lin yves]# xine dvd://VTS_01_1.VOB

This is xine (X11 gui) - a free video player v0.99.2.
(c) 2000-2004 The xine Team.
libdvdnav: Using dvdnav version 1-rc4a from http://xine.sf.net
libdvdread: Using libdvdcss version 1.2.8 for DVD access
libdvdread: Could not open /dev/dvd with libdvdcss.
libdvdread: Can't open /dev/dvd for reading
libdvdnav: vm: faild to open/read the DVD
[root@FC2-Lin yves]#


So now I'm thinking maybe I didn't create my symlink so to check I did the following:

[root@FC2-Lin yves]# ll /dev/cdrom
lrwxrwxrwx 1 root root 8 Jun 10 09:18 /dev/cdrom -> /dev/hdb
[root@FC2-Lin yves]# ll /dev/hdc
brw-rw---- 1 root disk 22, 0 Feb 23 16:02 /dev/hdc


I tried it again with the same results then I did some soul searching, according to the Xine how-to it turns out that dma mode needs to be enabled so I did the following:

[root@FC2-Lin sbin]# ./hdparm -d 1 /dev/hdb

/dev/hdb:
setting using_dma to 1 (on)
using_dma = 1 (on)
[root@FC2-Lin sbin]#


I tried Xine again still no playback, just to double check that dma mode was enabled I did the following:

[yves@FC2-Lin yves]$ dmesg | grep hdb
ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
hdb: DVD-ROM DDU220E, ATAPI CD/DVD-ROM drive
hdb: ATAPI DVD-ROM drive, 512kB Cache, DMA
[yves@FC2-Lin yves]$

So this time I thought I'd take a different avenue and did the following:

[yves@FC2-Lin yves]$ xine -V XShm
This is xine (X11 gui) - a free video player v0.99.2.
(c) 2000-2004 The xine Team.
libdvdnav: Using dvdnav version 1-rc4a from http://xine.sf.net
libdvdread: Using libdvdcss version 1.2.8 for DVD access
libdvdread: Could not open /dev/dvd with libdvdcss.
libdvdread: Can't open /dev/dvd for reading
libdvdnav: vm: faild to open/read the DVD
[yves@FC2-Lin yves]$


As you can see still no play back, did man hdparm for additional options and did the following:


[root@FC2-Lin sbin]# ./hdparm -tT /dev/cdrom

/dev/cdrom:
read() failed: Input/output error
Timing buffered disk reads: read() failed: Input/output error
[root@FC2-Lin sbin]#

Ok now I'm a little concerned so I tried to mount to the dvd, no go. I pop out the dvd and pop in a cd played the cd using xmms, no problems there. One can never be too sure so to ensure that the right drive is being detected and that dma mode was set properly I did the following:

[root@FC2-Lin sin]# ./hdparm -i /dev/cdrom

/dev/cdrom:

Model=DVD-ROM DDU220E, FwRev=5.0g, SerialNo=
Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=unknown, BuffSize=0kB, MaxMultSect=0
(maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
IORDY=on/off, tPIO={min:180,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: sdma0 sdma1 sdma2 mdma0 mdma1 *mdma2
AdvancedPM=no

* signifies the current active mode

[root@FC2-Lin sbin]#

Stalemate once again, no Xine playback. I heard a lot of good things about Mplayer and assumed that the problem that I was experiencing may have been isolated to Xine so I thought to myself I'll give Mplayer a shot and as user did the following:


[yves@FC2-Lin yves]$ mplayer dvd://VTS_01_1.VOB
MPlayer 1.0pre4-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Intel Celeron Covington/Pentium II Deschutes,Tonga/Pentium II Xeon 401.6 MHz (Family: 6, Stepping: 2)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/yves/.mplayer/config
Reading /home/yves/.mplayer/codecs.conf: Can't open '/home/yves/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: Can't open '/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
font: can't open file: /home/yves/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/yves/.mplayer/input.conf: No such file or directory
Input config file /etc/mplayer/input.conf parsed: 53 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such device
Can't init input joystick

Playing dvd://VTS_01_1.VOB.
libdvdread: Using libdvdcss version 1.2.8 for DVD access
libdvdread: Could not open /dev/dvd with libdvdcss.
libdvdread: Can't open /dev/dvd for reading
Couldn't open DVD device: /dev/dvd


Exiting... (End of file)
[yves@FC2-Lin yves]$

Thought to myself maybe I should try it as root I'm feeling lucky, well needless to say my luck ran out and rather quickly:


[root@FC2-Lin sbin]# mplayer dvd://VTS_01_1.VOB
MPlayer 1.0pre4-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Intel Celeron Covington/Pentium II Deschutes,Tonga/Pentium II Xeon 401.1 MHz (Family: 6, Stepping: 2)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Reading config file /etc/mplayer/mplayer.conf
Reading config file /root/.mplayer/config
Reading /root/.mplayer/codecs.conf: Can't open '/root/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: Can't open '/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
font: can't open file: /root/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using Linux hardware RTC timing (1024Hz).
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Input config file /etc/mplayer/input.conf parsed: 53 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such device
Can't init input joystick

Playing dvd://VTS_01_1.VOB.
libdvdread: Using libdvdcss version 1.2.8 for DVD access
libdvdread: Could not open /dev/dvd with libdvdcss.
libdvdread: Can't open /dev/dvd for reading
Couldn't open DVD device: /dev/dvd


Exiting... (End of file)

As a last resort I swapped out hdd's popped in one that has windoze xp on it and watched Bad Boys 2 with incident so what do I do to get Xine or Mplayer to do in Linux what it is able to do in windoze?????

Please Help

Bana
17th July 2004, 09:26 AM
[root@FC2-Lin yves]# ll /dev/cdrom
lrwxrwxrwx 1 root root 8 Jun 10 09:18 /dev/cdrom -> /dev/hdb
[root@FC2-Lin yves]# ll /dev/hdc
brw-rw---- 1 root disk 22, 0 Feb 23 16:02 /dev/hdcShouldn't the symlink in question be going from /dev/dvd to /dev/hdb? That is what both xine and mplayer seem to be having problems with.

Viro
17th July 2004, 10:53 PM
Also, what are the permissions on /dev/hdb? You've only shown us the permissions to /dev/hdc (?!?) which should be 666 (i.e. a+rw) if you want everyone to be able to read and write to that drive.

triplehead
19th July 2004, 09:05 AM
you can also change drive setting for example on mplayer from /dev/dvd to /dev/cdrom. You can do this from gui or change config file.

yr2alex
20th July 2004, 10:30 PM
I apologize for taking such a long time to reply to your responses, additionally I thank you and appreciate your timely responses. Now then in response to your replies I made some quick adjustments but to no avail. Per "Bana's" advise I removed the original symlink that I created from /dev/cdrom and re-created the symlink by doing the following:

[root@FC2-Lin yves]# ln -s /dev/hdb /dev/dvd

then checked the permissions on it by doing the following:

[root@FC2-Lin yves]# ll /dev/dvd
lrwxrwxrwx 1 root root 8 Jul 18 19:10 /dev/dvd -> /dev/hdb
[root@FC2-Lin yves]#

but just then I remembered that "Viro" advised to change the permissions on /dev/hdb to a+rw to make it accessable to all users so I did the following:

[yves@FC2-Lin yves]$ ll /dev/hdb
brw------- 1 yves disk 3, 64 Feb 23 16:02 /dev/hdb
[yves@FC2-Lin yves]$ su
Password:
[root@FC2-Lin yves]# chmod 666 /dev/hdb
[root@FC2-Lin yves]# ll /dev/hdb
brw-rw-rw- 1 yves disk 3, 64 Feb 23 16:02 /dev/hdb

additionally checked the permissions for /dev/cdrom just as a precationary measure

[root@FC2-Lin yves]# ll /dev/cdrom
lrwxrwxrwx 1 root root 8 Jun 10 09:18 /dev/cdrom -> /dev/hdb

Still no play back, so I did some more soul searching and found that a certain someone had gained a bit of success by concatenating, well I thought to my self wouldn't hurt to try, besides I've got nothing to to lose but time... I did the following:

[root@FC2-Lin yves]# cat /dev/dvd
cat: /dev/dvd: No medium found
[root@FC2-Lin yves]# mount /dev/dvd
mount: can't find /dev/hdb in /etc/fstab or /etc/mtab
[root@FC2-Lin yves]# cat /dev/cdrom
cat: /dev/cdrom: No medium found
[root@FC2-Lin yves]# mount /dev/cdrom
mount: No medium found
[root@FC2-Lin yves]#

Ouch!!! considering that I was able to mount to a freshly burned cd using "k3b" in the same drive..

Somebody help me stop the bleeding.

triplehead
20th July 2004, 10:55 PM
see my previous post, works at least with mplayer

yr2alex
21st July 2004, 06:00 AM
Incidentally I'm glad that you mentioned

"you can also change drive setting for example on Mplayer from /dev/dvd to /dev/cdrom. You can do this from gui or change config file." -excerpt from "tripleheads" post

because for some odd reason Mplayer does not launch as user dunno why it did after it was initially installed, however, I can launch it as the root. If you would be so kind as to examine the text output of both user and root below maybe you can give me a clue as to why because I don't have one...

user output

[yves@FC2-Lin yves]$ gmplayer
MPlayer 1.0pre4-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Intel Celeron Covington/Pentium II Deschutes,Tonga/Pentium II Xeon 407.5 MHz (Family: 6, Stepping: 2)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/yves/.mplayer/config
[cfg] read config file: /home/yves/.mplayer/gui.conf
Reading config file /home/yves/.mplayer/gui.conf
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Reading /home/yves/.mplayer/codecs.conf: Can't open '/home/yves/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: Can't open '/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
font: can't open file: /home/yves/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/yves/.mplayer/input.conf: No such file or directory
Input config file /etc/mplayer/input.conf parsed: 53 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such device
Can't init input joystick
SKIN dir 1: '/home/yves/.mplayer/Skin'
SKIN dir 2: '/usr/share/mplayer/Skin'
[skin] file ( /usr/share/mplayer/Skin/default/skin ) not found.
Skin not found (default).
[yves@FC2-Lin yves]$

root output

[yves@FC2-Lin yves]$ su
Password:
[root@FC2-Lin yves]# gmplayer
MPlayer 1.0pre4-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Intel Celeron Covington/Pentium II Deschutes,Tonga/Pentium II Xeon 401.6 MHz (Family: 6, Stepping: 2)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Reading config file /etc/mplayer/mplayer.conf
Reading config file /root/.mplayer/config
[cfg] read config file: /root/.mplayer/gui.conf
Reading config file /root/.mplayer/gui.conf

vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Reading /root/.mplayer/codecs.conf: Can't open '/root/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: Can't open '/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
font: can't open file: /root/.mplayer/font/font.desc


Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using Linux hardware RTC timing (1024Hz).
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Input config file /etc/mplayer/input.conf parsed: 53 binds

Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such device
Can't init input joystick

SKIN dir 1: '/root/.mplayer/Skin'
SKIN dir 2: '/usr/share/mplayer/Skin'
cmd: 5
cmd: 5
cmd: 5
cmd: 5
cmd: 5
cmd: 2

Exiting... (Exit)

NOTE: as root mplayer gui loads successfully I exited it explicitly

let me know what you think...

triplehead
23rd July 2004, 07:17 AM
Incidentally I'm glad that you mentioned

"you can also change drive setting for example on Mplayer from /dev/dvd to /dev/cdrom. You can do this from gui or change config file." -excerpt from "tripleheads" post

because for some odd reason Mplayer does not launch as user dunno why it did after it was initially installed, however, I can launch it as the root. If you would be so kind as to examine the text output of both user and root below maybe you can give me a clue as to why because I don't have one...

user output

[yves@FC2-Lin yves]$ gmplayer
MPlayer 1.0pre4-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Intel Celeron Covington/Pentium II Deschutes,Tonga/Pentium II Xeon 407.5 MHz (Family: 6, Stepping: 2)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Reading config file /etc/mplayer/mplayer.conf
Reading config file /home/yves/.mplayer/config
[cfg] read config file: /home/yves/.mplayer/gui.conf
Reading config file /home/yves/.mplayer/gui.conf
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Reading /home/yves/.mplayer/codecs.conf: Can't open '/home/yves/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: Can't open '/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
font: can't open file: /home/yves/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/yves/.mplayer/input.conf: No such file or directory
Input config file /etc/mplayer/input.conf parsed: 53 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such device
Can't init input joystick
SKIN dir 1: '/home/yves/.mplayer/Skin'
SKIN dir 2: '/usr/share/mplayer/Skin'
[skin] file ( /usr/share/mplayer/Skin/default/skin ) not found.
Skin not found (default).
[yves@FC2-Lin yves]$

root output

[yves@FC2-Lin yves]$ su
Password:
[root@FC2-Lin yves]# gmplayer
MPlayer 1.0pre4-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Intel Celeron Covington/Pentium II Deschutes,Tonga/Pentium II Xeon 401.6 MHz (Family: 6, Stepping: 2)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Reading config file /etc/mplayer/mplayer.conf
Reading config file /root/.mplayer/config
[cfg] read config file: /root/.mplayer/gui.conf
Reading config file /root/.mplayer/gui.conf

vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Reading /root/.mplayer/codecs.conf: Can't open '/root/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: Can't open '/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
font: can't open file: /root/.mplayer/font/font.desc


Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using Linux hardware RTC timing (1024Hz).
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Input config file /etc/mplayer/input.conf parsed: 53 binds

Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such device
Can't init input joystick

SKIN dir 1: '/root/.mplayer/Skin'
SKIN dir 2: '/usr/share/mplayer/Skin'
cmd: 5
cmd: 5
cmd: 5
cmd: 5
cmd: 5
cmd: 2

Exiting... (Exit)

NOTE: as root mplayer gui loads successfully I exited it explicitly

let me know what you think...

i bolded the problem i think you have

did you install it from rpm or did you compile it from sources.

yr2alex
28th July 2004, 10:18 PM
Thanks Triplehead sorry I took so long to respond. I installed it using yum basically from rpms, it looks like all i need to do is change the permissions and I should be all set. A chmod a+ rw should do the trick huh? or do you suggest something else?
Thanks again I appreciate you help.

yr2alex