View Full Version : setup lan with 2 feodra1

17th July 2004, 06:17 AM
I have 2 computers which are connected through lan. the first one has fedora1 and the other one had winXP. by using IP tables I managed to share my internet connection from my fedora box to my winXP box. then I decided to install fc1 on the same box which had winXP but then both computers could not ping to the other one.

does iptables configurations that worked fot fc1 and winXP will work with two fc1?

thanks in advance,

17th July 2004, 12:16 PM
Your new Fedora machine couldn't ping the internet sharing one?

Is the Internet box firewalled?

17th July 2004, 06:07 PM
but when the new fedora machine runs xp it is able to ping...

17th July 2004, 09:18 PM
I think my ethernet card is not supported with linux ... I downloaded a driver but its an *.o file what should I do with it? I am new and I am not familiar with this file type...


17th July 2004, 09:41 PM
.o files are modules.
Here are two howtos: http://www.ibiblio.org/pub/Linux/docs/HOWTO/other-formats/html_single/Module-HOWTO.html and http://www.ibiblio.org/pub/Linux/docs/HOWTO/other-formats/html_single/Modules.html that are about modules. There might be a little difficult, but are from a very good source. If you need a kernel-recompiling then you could look at my article: http://www.fedoraforum.org/forum/article.php?a=4

17th July 2004, 10:08 PM
my card is an RTL8029
I downloaded the driver from the Realtek website
it has a setup file but it does not work. here is its content:

echo "Install RTL8029 ethernet driver..."

echo 'Please input source path ? ( ex: a:/sco/4.x) \c'

read d_path

echo "Please wait ........."

if [ ! -x /usr/lib/lli/r1e ]


mkdir /usr/lib/lli/r1e


doscp $d_path/Space.c /usr/lib/lli/r1e/Space.c

doscp $d_path/Driver.o /usr/lib/lli/r1e/Driver.o

doscp $d_path/Master /usr/lib/lli/r1e/Master

doscp $d_path/System /usr/lib/lli/r1e/System

doscp $d_path/Node /usr/lib/lli/r1e/Node

doscp $d_path/Init /usr/lib/lli/init/r1e0

chmod +x /usr/lib/lli/init/r1e0

doscp $d_path/Reconf /usr/lib/lli/reconf/r1e0

chmod +x /usr/lib/lli/reconf/r1e0

doscp $d_path/Remove /usr/lib/lli/remove/r1e0

chmod +x /usr/lib/lli/remove/r1e0

doscp $d_path/Info /usr/lib/lli/info/r1e0

chmod +x /usr/lib/lli/info/r1e0

doscp $d_path/Init /usr/lib/netconfig/init/r1e0

chmod +x /usr/lib/netconfig/init/r1e0

doscp $d_path/Reconf /usr/lib/netconfig/reconf/r1e0

chmod +x /usr/lib/netconfig/reconf/r1e0

doscp $d_path/Remove /usr/lib/netconfig/remove/r1e0

chmod +x /usr/lib/netconfig/remove/r1e0

doscp $d_path/info /usr/lib/netconfig/info/r1e0

chmod +x /usr/lib/netconfig/info/r1e0

echo "Transfer End ..."

I tried manually doing what it says but sill no ping.

17th July 2004, 10:12 PM
have you tried to make it executable?
chmod +x <filename>
and then ./<filename>

17th July 2004, 11:06 PM
it runs but then brings some errors:

[shlomi@localhost 5.X]$ chmod +x SETUP
[shlomi@localhost 5.X]$ ./SETUP
Install RTL 8029 Ethernet Adapter Driver (MDI)
Please input source path ? ( ex: a:/sco/5.x) \c
': not a valid identifier_path
: command not found
Please wait to transfer files ................
./SETUP: line 15: syntax error: unexpected end of file

here are the instructions:
(I have a problem with doscp - it says "command not found")

SCO UNIX RTL 8029 MDI Driver

The following files will be used in this installation:

Files Contents
----------- -----------------------------------------
Driver.o RTL 8029 MDI Driver Program
setup Transfer dos format to unix format setup program
Master Used by netconfig
System Used by netconfig
Node Used by netconfig
Space.c Used by netconfig
space.h Used by netconfig
lkcfg Used by netconfig
AOF/r3e Used by netconfig

1. Installation Diskette in DOS format.
Put RTL SCO UNIX Driver diskette to floppy A: and use doscp
command to copy RTL SCO UNIX PCI Driver into UNIX's directories.

# cd /
# doscp A:/sco5/setup /setup
# chmod +x /setup
# ./setup
(put the VOL.000.000 to the /tmp directory)

1.1 Run custom to enter software manager procedure.
1.2 Select menu "Software"
1.3 Push the "Install new"
1.4 What host(machine) do you want to install from ? "from host machine"
1.5 Insert Media, and select media device -> "Media Images"
1.6 Enter the full path to the directory containing media Images.-> "/tmp"

2. Use netconfig utility

Avaiable options:

# netconfig

3. To add adapters, select "Add New Lan Adapter" from "Hardware".

4. Add Protocol to select SCO TCP/IP.

5. Enter the internet Address of this interface n.n.n.n

6. Enter the netmask for this interface (default

7. Enter the boardcast address for this interface default: n.n.n.n

8. Do you want to relink to kernel now ? y

9. Do you want this kernel to boot by default (y/n) y

10. Do you want the kernel environment rebuilt (y/n) y

11. Reboot unix

# shutdown -y -g0

17th July 2004, 11:25 PM
SCO UNIX RTL 8029 MDI Driver

You use a Linux, not a SCO-Unix (even if some companies say it is the same ;) )
And I don't understand why they use the doscp (http://notabug.com/2002/coherent/man/doscp.html) command. So you need another driver.

17th July 2004, 11:51 PM
do you know where I can get one?
I search everywhere

18th July 2004, 12:03 AM
the attachment was wrong. Are you sure you card is not supported?
See also here : http://www.linux.org/docs/ldp/howto/Ethernet-HOWTO-2.html (search for 8029 in you browser)

18th July 2004, 12:19 AM
How can I download the attachments? I am new to this forum...

18th July 2004, 12:20 AM
the attachment was wrong. It was the same sco driver

18th July 2004, 02:14 AM
Ok I guess I will search some more or just buy another ethernet card that supports linux.