PDA

View Full Version : Problem with mounted NTFS and Latin2 letters



Aralas
25th June 2008, 01:20 PM
Since this is my first post to this forum I'd like to say hi to everybody! :)

I'm using Fedora 9 and I'm having some problems with my mounted NTFS partiotions. I have several NTFS partitions on my computer and all of them have been auto mounted in my /media directory without any intervention. Everything look fine at first, but then I realized that I can't see any of files/directories that has any Croatian letters in it (like č, ć, , which can be seen using UTf 8 or ISO 8859-2character set).
Does anybody know what could be the problem? :confused:

PabloTwo
25th June 2008, 04:07 PM
Hello Aralas, and welcome to the Fedora Forum

I am not sure how much I can help you on this issue, but I will offer a suggestion or two to try. I do not use F9. I run FC6 and play with F8 from a Live CD. On my FC6 install I have two ntfs partitions that are mounted from entries in the /etc/fstab file. Those entries were generated by a program I installed via yum called "ntfs-config". The entries look like this, and give some clues to language selection.

/dev/sda1 /media/DSK1_VOL1 ntfs-3g defaults,locale=en_US.UTF-8 0 0
/dev/sda5 /media/DSK1_VOL2 ntfs-3g defaults,locale=en_US.UTF-8 0 0
The option "locale" is specific to ntfs-3g, which I don't know whether or not is included by default in F9 (it is in F8), but if not, can easily be installed with yum. My suggestion is to create entries in your /etc/fstab file for all of the ntfs partitions you would like mounted using the ntfs-3g fs type and use the "locale' option to set a charachter set that might work, hopefully, for both Croation (Serbian-Latin) and English.

You can see which character sets are available on your system by typing, in a command terminal,

locale -a | less
and pick the one you think might be most appropiate "less" is a command line file reader that will let you scroll through the output of the 'locate -a' command a line or a screen full at a time. Type the letter q to exit less. Here is hoping this will be of some help to you. Good luck.

edited: to correct brain dead instruction to use "less locale -a"

Paul