PDA

View Full Version : Panel Always Launches 'gedit'



charactermatter
25th June 2008, 04:34 AM
When in gnome and I click places in the panel, and select a folder to open, it launches gedit, instead of nautilus. What did I do? I can't find anyone that's had this problem, and I can't find a preference anywhere to select nautilus as the preferred program to launch with this action. When I browse from the desktop icons for home or any folder I should put there it properly launches nautilus.Can anyone tell me how to fix this please? It would also be interesting to understand what I did that caused it.

Wayne
25th June 2008, 04:43 AM
Are these folders you've added to Nautilus Places pane yourself? Have you tried opening Nautilus and removing them then adding them back? Last resort could be to delete or rename the hidden .gconf directory.

Wayne

charactermatter
25th June 2008, 04:51 AM
I've changed the panel using the panel > properties, and then added things and taken them off. I "Use Nautilus to Draw the Desktop" with the nautilus tweak admin gui. If I uninstall gedit, then it launches nautilus as you would expect. I then reinstall gedit, and it starts launching if I try to open any folder from the Panel > Places menu.

charactermatter
26th June 2008, 05:09 AM
gedit seems to have taken it upon itself to launch itself when, in my panel, I select Places > home and try to open my home folder. It also launches if I try to browse any folders from the panel 'Places' menu. When I open any folder from the desktop or any other location it correctly launches nautilus. If I remove gedit from my computer then nautilus launches as I expect it to when I select a folder from the 'Places' list in the panel. If I reinstall gedit then it starts again. Am I dealing with a gedit problem? A Panel problem? or a gnome preferences problem? I can't find a way to associate the panel menu list for 'Places' with launching nautilus rather than gedit. Could anyone help me please?

Wayne
26th June 2008, 05:15 AM
What interests me is this:


I "Use Nautilus to Draw the Desktop" with the nautilus tweak admin gui

and don't fully understand what you're saying. Perhaps this is the cause of your problem?

Edit: If you're talking about gtweakui the last update I can see is 4 years old. I'd hardly think it would be reliable or useful on a modern Gnome system.

Wayne

charactermatter
26th June 2008, 05:27 AM
I have a "tweak ui" installed ( I downloaded it from fedora, livna or, or updates using yum) which gives me a couple buttons to set some nautilus and desktop options. One option is "use nautilus to draw the desktop." A function that I take as a literal description of what it does, although I don't know of any advantage it offers. I had changed nothing with this program or any other that toggled it from not working to what I am experiencing now. I did a large system 'bug and fix' update between the last time that things were normal and now. Is there a conf file somwhere that has been corrupted? I can't find any GUI toggles or preferences that tell those panel shortcuts to "launch nautilus when I click here."

charactermatter
26th June 2008, 05:32 AM
addendum: I have toggled all of the options offeredd by the tweak ui and it made not one iota of difference...

Wayne
26th June 2008, 05:34 AM
I can see no value in "use nautilus to draw the desktop." and it would be the first thing I'd turn off to see if it fixes things. Then I'd look for gtweakui config files in my /home and obliterate them and remove the whole thing. I mean, who needs tweaks for Galeon? Who even uses it these days?

Wayne

Dan
26th June 2008, 05:35 AM
Hi CHaracter.

I think Wayne has pointed you in the right direction. You're going to end up losing your current configuration files. Delete .gconf and .gconfd, then press ctrl+alt+backspace. That will hammer down Gnome. Then log back in normally. The system should replace those with clean copies.

Then re-configure normally.

Also a good idea to leave the option to have nautuilus draw the desktop intact. Just leave it turned on, then leave it alone. If you shut it down, you're desktop icons go away.

charactermatter
26th June 2008, 05:39 AM
I'll try that when I get home from work. Thanks for the help guys...