PDA

View Full Version : F9 - console letters dissapear one by one - looks like virus



dann
24th June 2008, 10:06 PM
My fedora 9 installation has a strange problem with the console. The letters on the screen with change to black (the screen is white on black in the console) one by one - all the a's..then the b's..c..d..e... until the entire screen is black. It almost looks like those Matrix screen savers

If this was windows, I'd swear it was a virus. Anyone seen this before?

soltanis
24th June 2008, 10:24 PM
Could just be a problem with the console.

Try looking at other TTYs (type Ctrl+Alt+F1) and see if the same problem repeats itself.
Try running xterm, aterm or other graphical terminal emulators other than (what I assume is) gnome-terminal to see if the problem repeats itself.

As for if it's a virus -- did you install any third-party packages or execute a program you downloaded as root? Are you running any Internet services? Is this a server, or a home computer? Are you behind a firewall or a router? Do you have SELinux and Firestarter running?

Oh and...if you change the colors, does the problem disappear (try black on white, or green on black)?

dann
24th June 2008, 10:53 PM
I tried the other TTYs - they look the same. All the letters are now black on black.


As for the virus - it's a pretty basic home computer. It's running SELinux, no firestarter, but it's behind a firewall/router and it's running the default iptables startup.

This is off topic, but explains why I was messing with console- but I just "yum updated" the computer and the system hangs for all users after the gdm logon.

I tried to reboot it (although that almost never does anything), and it has the same problem(s) - gdm hangs after logon, and the console(s) slowly disappears, alphabetically, letter by letter.

soltanis
24th June 2008, 11:04 PM
Wow.

The paranoid would say stop right there, wipe your system clean, and reinstall.
You could of course try finding the virus. You say GDM hangs on boot? Do you recall installing a package that was suspicious in any way, or running a program as root that perhaps you shouldn't have been running?

If you have any critical data, I would save it to a removable disk now.

Take a look at the security forum for other tips about compromised systems, but usually it boils down to, the only foolproof solution is wipe, reformat, and reinstall.

It might also just be a retarded yum update gone really bad. In that case, the solution would still be reinstall. Reformatting while you're doing that can't hurt, can it?

JEO
24th June 2008, 11:17 PM
For your system hang after a yum update, try pressing a key early to display the grub boot menu and then press the down arrow to select the previous kernel.

dann
25th June 2008, 05:13 PM
Thanks All -

I tried to other kernel - same story. I can change the console colors like this:

echo -en \\033[32m\\033[8] >/dev/console (makes it a lime green color)

typing "bash" and "reset" don't change the console.


But the console still has the disappearing letter thing. First the A's turn black, then the B's... until the console is black with the the "_" cursor the only thing left.

I was thinking of filling a bug report, but I'm not sure what the bug is? The console is part of the kernel (I think) and bash - well that's one easy.

Anyway - thanks for your suggestions - I might try a reinstall.

soltanis
25th June 2008, 06:55 PM
Actually consoles and TTYs are separate from the kernel, that's bash. But if both your terminal emulators (xterm, gnome-terminal, konsole) and your virtual consoles (Ctrl+Alt+F1, F2, F3...) have this "disappearing" letters...bug....then it's either something wrong with bash (search bugzilla, I guess) or it's a virus/malware/rootkit of some kind.

Reinstalling would definitely solve the problem.

But why don't you try something like a white background first? Maybe the letters are just turning into black letters, and that won't make a difference on a white console. If the letters are turning into the background color, though, then something is up.

dann
25th June 2008, 07:20 PM
Thanks - I changed all the background/foreground colors, and the console is just gone. I'm going to do a reinstall.