PDA

View Full Version : Cannot Change Desktop Background



rhancock
24th June 2008, 07:08 PM
System | Look and Feel|Appearance | Background

No matter what I select, the background will not change. It used to work. What is the underlying program and where are the background files?

PeTzZz
24th June 2008, 08:07 PM
The program name is gnome-appearance-properties. So try running it in the terminal. It may give some useful output when you change the background then. Background files should be in /usr/share/backgrounds/.

rhancock
24th June 2008, 08:14 PM
The program name is gnome-appearance-properties. So try running it in the terminal. It may give some useful output when you change the background then. Background files should be in /usr/share/backgrounds/.


Thanks for the response. When I do this a root, I receive the error:
Unable to start the settings manager 'gnome-settings-daemon'.
Without the GNOME settings manager running, some preferences may not take effect. This could indicate a problem with Bonobo, or a non-GNOME (e.g. KDE) settings manager may already be active and conflicting with the GNOME settings manager.

PeTzZz
24th June 2008, 08:31 PM
Don't do it as root. I can change the background and I get the same message when running it as root in the terminal.

rhancock
24th June 2008, 08:49 PM
Don't do it as root. I can change the background and I get the same message when running it as root in the terminal.

Now i don't get the error message, but I still cannot change the background. I can change the theme, but not the background.

PeTzZz
24th June 2008, 09:43 PM
So no output at all as I understand. You don't remember doing anything that can anyhow affect it? Has there been any updates related to gnome after you last know it was working?

I found almost the same thing reported here in the bugzilla (https://bugzilla.redhat.com/show_bug.cgi?id=451197). I suggest you to add a comment there that you have the same problem and add yourself to the CC list. If you think you have some additional details then add them too.