PDA

View Full Version : Strange problem with Terminal



Cybermatrix
23rd June 2008, 04:21 PM
Hi, first of all I am a Linux newbie so please excuse me if my questions will seem like a beginner question

I have Fedora 9 with the KDE installed, and everything was going fine until today when I decided to deeply explore all the Terminal and Konsole menus...I don't know what I pressed or changed, but when I tried to start the Terminal in order to start writing some commands, I always got the error message:

There was an error creating the child process for this terminal

and I simply can't write anything in it :(

So any ideas what might be wrong and how I might rectify this problem?

Thanks in advance for your time

MSK61
23rd June 2008, 04:38 PM
I'm afraid I can't settle on your problem, but you may reinstall the package. You may erase the package containing the terminal program and install it again.
This may be a multi-step process, since I don't know for now what package provides terminal.

Cybermatrix
24th June 2008, 11:03 AM
Thanks for your reply, I've searched the web for a solution to this problem but didn't have any luck :(

I've also tried to find out what package include the terminal in order to un-install it and install it, but didn't have any luck either :(

Now I am really wondering, is this the first time such an error appear to a Fedora user?!

MSK61
24th June 2008, 11:47 AM
For konsole, you may teyp:

yum provides `which konsole`
This should return the name of the package providing konsole. Then you may uninstall it using

sudo yum erase <package name>
where <package name> is the name of the package returned by the first command.
Then install it again using the command:

sudo yum install <package name>
The same procedure may be repeated for the terminal program, except for substituting "terminal" for "konsole".
I hope this helps.

Cybermatrix
24th June 2008, 12:27 PM
When i try to type anything under Konsole nothing happens...there is only a blinking cursor in the Konsole screen and nothing more :( :( :(

This only started to happen after the Terminal problem started...so any ideas?

thanks in advance for your time

MSK61
24th June 2008, 01:24 PM
While being in the graphical desktop, press Cntl-Alt-F1. You'll be introduced to a full screen console. Log in there and try my commands. Then press Cntl-Alt-F7(Cntl and Alt keys on the left of the keyboard, not the right) and you'll get back to the graphical desktop. See if this may help.

forkbomb
24th June 2008, 02:33 PM
You can also use a different terminal emulator to try uninstalling Konsole.

Careful about two things with regard to the suggestions you've received here so far:
1) You may not have sudo set up, so if you don't, you need to use full root to run those commands


su -
yum whatever whatever

2) Konsole may be so heavily tied to KDE that removing Konsole may necessitate removing all of KDE. I'm not sure where they are, but it might be worth trying to find Konsole's config files to see if deleting/moving/renaming those and then relaunching Konsole will generate a fresh profile.