PDA

View Full Version : F9 no power down on shutdown



bwire66
22nd June 2008, 11:50 PM
After I installed F9 shutdown worked fine and powered the system down quickly. But after using the system for some time and doing various updates (compiz, nvidia, etc, etc) the system started failing to power off after each shutdown.

The last message written to the screen during a shutdown is:

localhost login: Power down.

But it doesn't power down. :(

I'm at a loss on how to resolve this issue. Any ideas?

Thanks.

mark-b
23rd June 2008, 12:37 AM
Try this in your /boot/grub/grub.conf file

title Fedora (2.6.25.6-55.fc9.x86_64)
root (hd0,2)
kernel /vmlinuz-2.6.25.6-55.fc9.x86_64 ro root=/dev/VolGroup00/LogVol00 rhgb quiet reboot=b <--- add to the end of the kernel line
initrd /initrd-2.6.25.6-55.fc9.x86_64.img

bwire66
23rd June 2008, 01:16 AM
Thanks for quick reply. Adding reboot=b didn't help.

BigBadWoofer
23rd June 2008, 01:01 PM
After the last F8 update I have a similar problem. After rpbind shutsdown OK I get another line iw just the OK on it. Then the system hangs and I have to pull power to finish the shutdown. Nothing noticed when I boot up the next time.

bwire66
28th June 2008, 12:40 PM
Bump.

C'mon people - I know someone has got to have some experience in this area. What should I look for; what should I try?

This is seriously annoying.

phe
28th June 2008, 12:49 PM
I am not a specialist in domain, but I have read recently a lot about eComStation (successor of OS/2).
And there is also an known issue about ACPI (an APM).
It are difficult subjects.
I guess you power off problem must be related to these 2 functions.

Nabeshin
15th July 2008, 06:18 PM
I also have a similar problem (http://forums.fedoraforum.org/showthread.php?p=1046804#post1046804) as well, but I feel this may be due to different problems since mine never shut down correctly and yours broke after updating.

I'd recommend trying to add a few kernel commands to your /etc/grub.conf file (assuming you use grub to boot) and see what happens.

Example grub file (try either [acpi=off] of [noacpi] in place of the reddish text).



# NOTICE: You have a /boot partition. This means that
# all kernel paths are relative to /boot/
default=0
timeout=30
splashimage=(hd0,0)/grub/splash.xpm.gz

title Red Hat Linux (2.4.18-0.12)
root (hd0,0)
kernel /vmlinuz-2.4.18-0.12 ro root=/dev/hda3 acpi=off
initrd /initrd-2.4.18-0.12.img

ryptyde
16th July 2008, 02:54 AM
I have had the "noshutdown" problem on an older box since FC6 and what I did was edit the "/boot/grub/menu.lst" file and added "acpi=force" to the kernel line as noted:

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img #boot=/dev/sda default=0 timeout=5 splashimage=(hd0,0)/grub/splash.xpm.gz hiddenmenu title Fedora (2.6.25-14.fc9.i686) root (hd0,0)

kernel /vmlinuz-2.6.25-14.fc9.i686 ro root=UUID=56011567-5834-4c6d-b27b-b20ccb4dc003 rhgb quiet acpi=force

initrd /initrd-2.6.25-14.fc9.i686.img

.

marcrblevins
16th July 2008, 04:30 AM
Test your PSU. I have Windows XP Pro here when selected to shutdown, sometimes it shutdown the motherboard, but not the case itself. Oddball eh?, just hold the power button in for 4 seconds. I already replaced it last year and shocked the computer again, stupid sweater. :P

bwire66
19th July 2008, 06:14 PM
Well, I've played around with the following kernel parm combinations that, on various web pages, someone claimed solved the problem:

apm=off acpi=off
acpi=force
acpi=off
apm=off acpi=force

None of the above solved the problem.

I have no reason to think that the PSU is faulty because no other problems occur and Win XP NEVER has a problem powering down this system on shutdown.

I guess this is one of those Linux annoyances that wont get fixed until I reinstall. Then it will work until...it breaks. :(

drees
23rd July 2008, 07:21 PM
This started happening on one of my machines, too. Not sure if it's because I swapped out some hardware (MB/CPU) or because of a recent kernel (both changed around the same time.

I have Alt-SysRq enabled, sometimes pressing Alt-SysRq-o turns it off, so I know shutdown must be possible.

A.Serbinski
23rd July 2008, 07:44 PM
Well, I've played around with the following kernel parm combinations that, on various web pages, someone claimed solved the problem:

apm=off acpi=off
acpi=force
acpi=off
apm=off acpi=force

None of the above solved the problem.

I have no reason to think that the PSU is faulty because no other problems occur and Win XP NEVER has a problem powering down this system on shutdown.

I guess this is one of those Linux annoyances that wont get fixed until I reinstall. Then it will work until...it breaks. :(

More likely its because you've been blindly throwing things at the kernel hoping that something will work (and probably not knowing what these arguments actually mean).

Try this:
acpi=off apm=power_off

Since acpi isn't working for you, we disable it. We also instruct it to use apm to power off on shutdown. Your attempts to turn apm off are misguided, particularly that first line where you disable both acpi AND apm... no way in hell will it EVER power off with that pair of arguments.

Here are the parameters available for apm= (taken directly from kernel source):

* Various options can be changed at boot time as follows:
* (We allow underscores for compatibility with the modules code)
* apm=on/off enable/disable APM
* [no-]allow[-_]ints allow interrupts during BIOS calls
* [no-]broken[-_]psr BIOS has a broken GetPowerStatus call
* [no-]realmode[-_]power[-_]off switch to real mode before
* powering off
* [no-]debug log some debugging messages
* [no-]power[-_]off power off on shutdown
* [no-]smp Use apm even on an SMP box
* bounce[-_]interval=<n> number of ticks to ignore suspend
* bounces
* idle[-_]threshold=<n> System idle percentage above which to
* make APM BIOS idle calls. Set it to
* 100 to disable.
* idle[-_]period=<n> Period (in 1/100s of a second) over
* which the idle percentage is
* calculated.

bwire66
23rd July 2008, 09:55 PM
More likely its because you've been blindly throwing things at the kernel hoping that something will work (and probably not knowing what these arguments actually mean).

Exactly right - what else can I do...RTFM? Har, har...


Try this:
acpi=off apm=power_off

I'll try this, but it doesn't explain what broke in F9 after the first couple of weeks that is causing the problem.

Thanks for the info.

A.Serbinski
23rd July 2008, 11:27 PM
Are you certain that its an OS change and not a bios change?

angrypanda
26th September 2008, 03:59 PM
Hi,

I've been using FC9 without shutdown problems for about 3 months, then last week - following an update - the machine started to not power off. So I was powering off manually for a while. Then I came in one day and the system wouldn't power on at all (my diagnosis was a failed power supply). Replacing the broken power supply got me powered up again, but I still have the shutdown blues. I.e. it still won't power off.

Either this is some crazy coincidence - failing power supply, dodgy patch; or the patch actually caused my power supply to fail - is this even possible?????? Or is the motherboard on its way out.......?

I haven't touched the BIOS at all, and in my mind ACPI simply can't stop functioning - only the software that tries to access its functionality can be mis-programmed (and get it wrong). So who's to blame? Cos it sure as hell ain't me :cool:

Hope someone has something more enlightening to suggest than adding "acpi=red herring" to the boot command in my grub file.

Cheers, Jon

bwire66
26th September 2008, 11:06 PM
Hope someone has something more enlightening to suggest than adding "acpi=red herring" to the boot command in my grub file.

lol...I don't think anyone actually understands how F9 works with acpi so we are reduced to just throwing darts at acpi problems.

angrypanda
28th September 2008, 09:55 PM
Hi,

Yeah - I guessed that people were trying the "usual suspects" :)
The other thing that happened at around the same time is that I no
longer get the FC9 splash screen - this used to appear after the [udev] ...done
portion of the boot process, and I could click to get back to see details
of the boot. Of course this could just be another coincidence..... or is it.....?

I'm using the NVIDIA beta driver (to help with KDE4 problems) so is most
likely related to that.

Remind me, why does anyone bother with FC9? Only joking......or am I? :p

Cheers, Jon

angrypanda
5th October 2008, 07:55 PM
Hi,

I just installed the latest kernel update (2.6.26.5-45) and my machine seems to be powering down successfully again. Still no splash screen though - but this is probably due to use of the latest beta NVIDIA driver (177.70). Which incidentally, appears to do nothing to fix the horrible task bar corruption you get with KDE4 - yuk!

Cheers, Jon

marko
5th October 2008, 08:01 PM
How about a really crazy idea, like looking in your yum.log to see what package update date stamp might coincide with poweroff not working?

Nokia
5th October 2008, 08:08 PM
Hmm, logs from five months ago ?

marko
5th October 2008, 08:10 PM
Yeah, the log idea works better if you don't sit on the problem that long...

angrypanda
7th October 2008, 10:35 PM
Well Marko, that would be a fine idea if I patched my machine one patch at a time, then rebooted checked that everything was working fine, then selected the next patch, repeated the process, then the next, and the next ............you get my drift???? :rolleyes:

Incidentally, I spoke too soon - my PC is back to not powering off properly once again. Someone, somewhere must have an idea about this. When I shutdown, I can open the text console (ctrl+alt+F7) and see the processes shutting down until I get to "system is down" but I never get the power-off message - is there a shutdown log?

I get infuriated by these problems, since they seem on the surface like they should be easy to fix.....?

Cheers, Jon

marko
8th October 2008, 01:53 AM
I think you're over exaggerating a bit, you said (post#15) it started one week ago before 9/26, have you really updated that many packages that you can't look in yum.log, sort out the ones put in at that time just before the problem and make a guess?

In fact about a week before 9/26 on my box I updated to kernel 2.6.26.5-45 as
noted in my yum.log:


Sep 16 20:07:17 Installed: kernel-devel-2.6.26.3-29.fc9.x86_64
It's a pretty good guess it's the kernel, so why not pick the kernel before
that in your grub menu and see if the power off works again?

angrypanda
9th October 2008, 01:48 PM
Hi Marko,

Sorry for yesterday's stroppiness! I took your advice and tried the oldest kernel I could find (there were only 3), and selected 2.6.26.3-29......I know this is not quite as old as I'd like but anyway....

So the system booted and tried to enter runlevel 5 (the default set in /etc/inittab) and failed because the currently compiled/installed nvidia kernel module was for 2.6.26.5-45 (I expected this).

So the system dropped back to runlevel 3 - and I thought I would try the shutdown (shutdown -h now) - and the system powered down correctly. So I restarted and edited /etc/inittab to default to runlevel 3, then rebooted into the latest kernel - again I was able to shutdown and power-off automatically. As soon as I changed the runlevel back to 5 (and rebooted) the system returned to its default behaviour (i.e. not powering down properly). So it seems to be related to whatever extra "stuff" happens in runlevel 5. Could starting the GUI screw up ACPI processing?

Cheers, Jon

marko
9th October 2008, 10:39 PM
o it seems to be related to whatever extra "stuff" happens in runlevel 5. Could starting the GUI screw up ACPI processing?

Yes, because going from runlevel 3 to 5 isn't just about starting up X, it does lots of other stuff.

From text only mode (run level 3) try starting just X but not changing the run level, this can
be done by just running startx instead of doing init 5


startx

which will get you into your GUI but start up none of those other services. Once in the gui try the shutdown. If that works you're likely right that one of the services that runs in RL5 but not RL3 is the problem. You can then use system-config-services to see what those services are that run in level 5 but not level 3

If startx doesn't work try installing switchdesk as root, then switch back to your user and
run switchdesk <desktop> and then startx

angrypanda> su -
<password>
# yum install switchdesk
#exit (leave root for normal user)
angrypanda> switchdesk gnome (or kde, or whatever desktop you use)
angrypanda> startx

Then you can narrow down the problem. it's possible the motherboard needs
the bios updated