PDA

View Full Version : Java applet - streaming video but no sound



CD-RW
22nd June 2008, 01:05 PM
Fedora 8 default packages (except for livna).

I have installed the nonfree codecs from livna. When I try to watch the following multimedia stream, I get the video OK, but no sound with it. This happens both with Konqueror and Firefox.

http://streaming.linux-magazin.de/events/apacheconfree/archive/jjagielski/frames-java.htm

I have tried opening this URL with totem directly, and I get nothing at all - not even the video without the sound. The same happens with splayer, the front-end to mplayer.

Any ideas please?

Hlingler
22nd June 2008, 04:58 PM
Hm. That link plays fine here.

What version(s) of java/jre/openjdk/gcj or whatnot do you have installed, and what vesion is your browser set to use? What browser are you using? And what all "nonfree codecs" from Livna did you install?

I can't determine for sure exactly what that format is from here, but since you say it's a java applet/streaming video, I would suspect some java config/compatability issue first. Or, it could be missing codecs.

FWIW, Konqueror has always been pretty much a problem for me w/r/t A/V playback, at least for the java and some other stuff.

V

CD-RW
22nd June 2008, 08:30 PM
Thanks for the reply Hlingler. The problem appears to be the operator not turning the volume up high enough!

Seriously, it does work in Konqueror and Firefox. I just had to crank up the volume knob to about 80%. Normally about 15% is quite sufficient to get a good volume level on all other apps.

I just enabled livna repo in smart and yum. Then did yum install *nonfree*. That downloaded all the free codecs from livna, and KDE & K3b nonfree-extras.

Still not sure about using Totem or splayer to load the video. Do they work with Java applets?

Hlingler
22nd June 2008, 11:53 PM
Doh! P.I.C.N.I.C. Been there, Done that. :D

Perhaps there's a "normalize volume" setting/feature or plugin/package responsible for that ? Not sure....

Don't know about Totem either - it's usually one of the first packages to get dumped here in favor of... er, better A/V player(s). And never installed/used splayer. VLC and Xine meet all of my needs.

Well, at least you have a way to get the volume working.

V