PDA

View Full Version : Java ME emulator closes



sudhirb
22nd June 2008, 11:00 AM
I recently installed Fedora 9 with openjdk 6. I also installed the Netbeans mobility pack. Initially I was able to do my development without any hassles. But after a short while, I haven't been able to run the emulator. Whenever I try to run any Java ME application, the emulator window appears just for a split second and disappears. Netbeans says run complete. The same behaviour was observed when I tried to run using the ktoolbar application provided with WTK. The same happened when I ran the following from the command line
/usr/local/netbeans-6.1/mobility8/WTK2.5.2/bin/emulator -Xverbose:all -Xdescriptor:MIDlet.jad. All that i saw on the terminal was
Running with storage root /home/sudhir/j2mewtk/2.5.2/appdb/DefaultColorPhone My development has come to a halt ever since. What should I do so that, the emulator doesn't shut down even before it starts emulating?
By the way, I do not have mobility end to end module enabled in netbeans. Will that effect?