PDA

View Full Version : new update and my nvidia driver broke



boxerriely
21st June 2008, 08:09 PM
after the last update i rebooted my machine and now i can only get a command prompt. the nvidia driver was updated. i am a complete noob so any suggestions would be appreciated

JohnVV
21st June 2008, 08:36 PM
i am on f 8 so this may not apply to F 9. -- and 32BIT ONLY
i noticed that the livnia nvidia update was a .586 , and my kernel is a .686 ,
so ,a mismatch .Also the 586 k-mod was OLDER than the 686 dviver installed
give this a go
FIRST try " yum update "


yum info kernel

(Repo : installed)
(- there will be two installed) example:
-----
Installed Packages
Name : kernel
Arch : i686
Version: 2.6.25.4
Release: 10.fc8
Size : 50 M
Repo : installed
----
find out witch one you have installed 586,686
now run

rpm -qa | grep nvidia
this will tell you what drivers are installed
for example mine is
"kmod-nvidia-96xx"
then
----" REPLACE THIS WITH YOURS"----
yum info kmod-nvidia-96xx
example:
Installed Packages
Name : kmod-nvidia-96xx
Arch : i686
Version: 96.43.05
Release: 12.lvn8
Size : 0.0
Repo : installed
-----
now if there is a miss match
then run" yum remove kmod-nvidia "
then " yum install kmod-nvidia "

boxerriely
21st June 2008, 09:06 PM
i tried the yum remove yum install and when i pressed ctrl/alt/f7 the desktop gui flashed for a second and then to black screen p.s. i am running fc8 the update that did this was a se package update

boxerriely
21st June 2008, 09:36 PM
i think it just keeps install the same i686 driver also the kernel is a i586 but i thought my machine was a i386 i have a 3.2p4 800mhz processor

JohnVV
21st June 2008, 10:32 PM
"the update that did this was a se package update"
not likely that will not effect gnome
boot into text only then and back up the xorg.conf

---- LOG IN AT ROOT ----
cp /etc/X11/xorg.conf /etc/X11/xorg.back1.conf
then see if this file is there "xorg.conf.livna-config-backup"
ls -l /etc/X11
if the file is there
then

cp /etc/X11/xorg.conf.livna-config-backup /etc/X11/xorg.conf
restart
--
if the file xorg.conf.livna-config-backup " is not there post the text of
nano /etc/X11/xorg.conf
you may need to copy the xorg.conf to a floppy or usb to read, on a diff machine it to post on the forum
also instead of ctrl/alt/f7 just reboot
--
also take a look here to see if a setting was " somehow" changed


nano /etc/inittab
near the top should be this line" id:5:initdefault:" IF it says "id:3:initdefault:" then change the 3 to a 5
then hit < control-Ctrl-> and <x> together
and save it as inittab
reboot

Hlingler
21st June 2008, 11:24 PM
i think it just keeps install the same i686 driver also the kernel is a i586 but i thought my machine was a i386 i have a 3.2p4 800mhz processorIf you do in fact have an *.i586 kernel installed on a machine with a P4 CPU, that is a problem.

In most cases, the "X' in "iX86" designates minimum CPU instruction set needed to install/run package, but for kernels, this tag basically designates the OS level: the *.i586 kernel(s) simply won't understand/process higher-level CPU instructions. Or so, this is my understanding of the situation.

I would suggest that you first install/replace any *.i586 kernel(s) with the *.i686 one(s).

I can't help but wonder: how did any *.i586 kernel(s) get installed on this machine? That should not have happened.

Regards,
V

JohnVV
22nd June 2008, 03:12 AM
well
"~]#yum info kernel"
gives me this ( text and more text then)
...
Available Packages
Name : kernel
Arch : i586
Version: 2.6.25.6
Release: 27.fc8
Size : 18 M
Repo : updates
Summary: The Linux kernel (the core of the Linux operating system)
Description: ..."
----
for
~]#yum repolist
repo id repo name status
adobe Adobe Systems Incorporated enabled
fedora Fedora 8 - i386 enabled
fusion Compiz Fusion repository enabled
livna Livna for Fedora Core 8 - i386 - Base enabled
updates Fedora 8 - i386 - Updates enabled
and livna has 586 and 686 for kmod-nvidia-96xx

Hlingler
22nd June 2008, 03:55 AM
Well, yeah, the *.i586 kernels are available in the repos, but that doesn't mean they should be installed. I've been careful to keep an eye on that stuff ever since that fiasco - what was it: FC5 or FC6? - installed *.i586 kernels on most people's machines, including mine. IIRC, that was a PITA and had to be fixed, for the vast majority of users. Because it caused problems with lots of other software, including especially video drivers.

To be perfectly honest, I don't know why *.i586 kernels are even offered: there can't be very many users who need them, and if F9 can even run on such hardware as has such a CPU.

V

JohnVV
22nd June 2008, 04:19 AM
"ever since that fiasco - what was it: FC5 or FC6? - installed *.i586 kernels on most people's machines"
i was part of that too and i think it was fc7 , at least it was only a few days until the first update fixed it
--
what i noticed on that Auto update message ( did not install) the driver was unable to install because a dependency was not found -- wrong kernel installed ( the correct one is installed )
and today there is NO nvidia update ?

boxerriely
22nd June 2008, 06:08 AM
i was wrong about the i586 kernel it is i686. i dont know how to save the xorg.conf to a usb card i do have a card reader installed i think the driver is fine some were somting is just setup wrong.

boxerriely
22nd June 2008, 06:15 AM
this is what happened i tried to start wine to install teversity (wine which i know nothing about ) and the machine froze well i just turned the machine off and back on and no gui. But just before i started wine i installed se pakage update which had nvidia stuff in it dont know exactly what it is. I am really new to linux and really only stumble around in xp. probably shouldn't veer off the path so much. Just really curious.