PDA

View Full Version : Have to run system-display-config @ every login to startx



squidward
21st June 2008, 05:58 AM
Have to run system-display-config @ every login to startx

This problem has been occurring every since I installed the nv kernel a few weeks ago,

As system attempts to startx, the following messages flash by quickly before the announcement that xserver failed to start.
Then comes the "would I like to diagnosis the problem"> etc >enter root psswrd to launch system-display-config, after which xserver does start, but its aggravating to go through this every boot

I also get a black screen when running glxgears, although terminal reports good fps, 3D acceleration does not apperear to be working, Here are the messages I see before xserver failed pops up;

Couldn't start xserver on card0
Couldn't start xserver on card1

The next message that flashes by goes too fast to read, but then the window pops up that says the system is attempting to startx,
after hitting enter, It finally brings up the gdm / login window.....

Any advice on how to resolve the issue would be greatly appreciated. Below is some pertinent info as well as the output of xorg.conf, Thanks in Advance;

[uname@ferrous ~]$ cat /etc/X11/xorg.conf | grep Driver
Driver "kbd"
Driver "nv"

[uname@ferrous ~]$ /sbin/lspci | grep VGA
01:06.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)

[uname@ferrous ~]$ uname -a
Linux ferrous 2.6.25.6-55.fc9.i686 #1 SMP Tue Jun 10 16:27:49 EDT 2008 i686 i686 i386 GNU/Linux

[uname@ferrous ~]$ glxgears
718 frames in 5.1 seconds = 140.934 FPS
680 frames in 5.0 seconds = 134.857 FPS
660 frames in 5.1 seconds = 129.273 FPS

[uname@ferrous ~]$ gedit /etc/X11/xorg.conf
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
# keyboard added by rhpxl
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

w5set
21st June 2008, 06:16 AM
Try using this command as root..
chkconfig --level 345 kudzu off

And see if that might help.

Seve
21st June 2008, 06:17 AM
Hello:
What does this mean ?

I installed the nv kernel a few weeks ago,

Seve

squidward
21st June 2008, 06:45 AM
Thanks for the replys :)

w5set;

[root@ferrous uname]# /sbin/chkconfig --level 345 kudzu off
error reading information on service kudzu: No such file or directory


Seve;

What does this mean ?


I installed the nv kernel a few weeks ago,


When I installed the Nvidia driver, I remeber something about a new kernel version, or kernel headers going by in the installation process,
(installed kmod-nvidia xorg-x11-drv-nvidia & yum install nv*)
I did this following some sketchy tutorial I can't locate... :rolleyes: (yeah, not the best idea in retrospect..)

I have seen several xsever-xorg and nvidia updates go by since then, and I kept hoping the problem would "automagically" resolve itself, but alas, no such luck...

Seve
21st June 2008, 06:48 AM
Hello:
If you have installed the 3rd party nVidia driver, then change your /etc/X11/xorg.conf
from
Driver "nv"
to
Driver "nvidia"
Save, exit and either use Ctrl Alt Backspace to restart your Xserver or reboot and see how it goes.

Seve

squidward
21st June 2008, 07:35 AM
Thanks again for the help Seve

I changed nv to nvidia , same results;

This time when running system-config-display I also clicked the Hardware tab in the Display Settings window and selected Nvidia there instaed of the preselected nv driver, x would not start at all at that point, and dumped me back to system-config-display, where the nv driver was selected again, leaving it alone this time, I was able to startx at the end of the dialouge.

In my X11 i have a file named;

xorg.conf.livna-config-backup

I have also tried renaming this file to xorg.conf with same result on boot, The odd thing is I renamed the original xorg.conf to xor.conf.bkup, and xorg.conf.livna-config-backup to xorg.conf,
Now when completeing system-config-display, it states that it is creating a backup of xorg.conf named xorg.conf.backup, but that file does *not* appear, what does get written is xorg.conf.livna-config-backup

I don't know how relevant it is, But the contents are thus;

# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"

# keyboard added by rhpxl
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Is there a way to remove both the nv and nvidia drivers and attempt the installation again? Kind of just "start over" so to speak?

I am a (reforming) hopeless distro hopper, and am really trying to bite the bullet and stick with this one for the entire six month release cycle...("Back Open SuSe11, Foul Temptress!", lol)
Other than this I have been able to resolve the quirks I've encountered with Fedora9, the abilty to run apps dependant upon 3D acceleration, & log in with out jumping through config hoops every time would be great,

Please keep the suggestions coming :D

Thanks

Seve
21st June 2008, 07:43 AM
Hello:
You should look through your /var/log/Xorg.0.log and see if there are any errors/clues as to why your xorg.conf is being rejected.

You may also want to, once you have logged in type and enter
system-config-display --reconfig

then restart your Xserver

Seve

squidward
21st June 2008, 08:28 AM
Hello,

Tried system-config-display --reconfig

no change, had a look at Xorg.0.log, nothing jumped out at me as incorrect, but I'm not entirely sure what I'm looking for....I can post it if you'd like, but please be advised it is a *huge* file

squidward
21st June 2008, 09:07 AM
Hello,

I think i found the problem, I'm pretty sure the client & the server glx vendor strings should both be Nvidia, The server glx vendor string is: SGI.

Any ideas on how to correct?



[root@ferrous uname]# rpm -qa |grep nvidia
kmod-nvidia-173.14.09-1.lvn9.i686
kmod-nvidia-2.6.25.4-30.fc9.i686-173.14.05-3.lvn9.i686
kmod-nvidia-2.6.25.6-55.fc9.i686-173.14.09-1.lvn9.i686
xorg-x11-drv-nvidia-173.14.09-1.lvn9.i386
xorg-x11-drv-nvidia-libs-173.14.09-1.lvn9.i386

[root@ferrous uname]# glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4