PDA

View Full Version : yum update broke everything



CaseyB
20th June 2008, 04:37 PM
I did a yum update and got a lot of updates, then later I shut down and when I tried to boot up it boots, lets me pick a user and enter a password, but then it freezes when it's loading my personal settings. Anyone know what the problem is and how I can fix it?

crifer
20th June 2008, 04:42 PM
Can you log in text mode (ctrl-alt-F1) ?

CaseyB
20th June 2008, 04:53 PM
Not after I try to log in graphically, it completely freezes. I will try tonight from the login screen before logging in.

rhricik
21st June 2008, 02:05 AM
Suffering from the same problem after getting nvidia update today. further experimentation leads me to believe something is happening between ndiswrapper and the driver. if i disable NetworkManager and plug in network cable, I can get x working. if i try to start wireless - everything locks up and it is button time. when i execute my ndiswrapper script line by line, it seems it locks up when trying to connect to the access point. this also happened on the last kernel/nvidia update. it also removed the BusID line from xorg.conf so nvidia driver wouldn't load after a reboot.

I'm open to suggestions - right now I have wireless shut off so that I can use the laptop, but being wired sort of defeats the purpose of having the laptop!

JohnVV
21st June 2008, 05:05 AM
are you "running"? fedora 8 or 9

rhricik
22nd June 2008, 01:25 AM
JohnVV - if you are asking me, I am running Fedora 9 - was really happy with it until the last kernel update, everything went south after that. Well, cutting edge means you bleed once in a while.

Experimenting even more, it is when I try to connect securely to my access point (WEP 128) that everything freezes up on me with the Broadcom card. Doesn't matter whether NetworkManager is running or not (tried it both ways) Even tried different wireless mini-PIC card, but same thing happens.

Ended up loading Mint Linux 5 on my other laptop, for some reason Fedora 9 just kept giving it fits - but Fedora 8 ran like a champ. Go figure... Pretty impressed with Mint so far - seems to be very, very stable and everything just works the first time around, even wireless.

Oh well, looks like I'm back to wired for now...

JEO
22nd June 2008, 03:57 AM
Casey, it sounds like you probably updated the kernel and there is a bug in the new kernel on your hardware causing it to freeze up. To see if this is the case, early in the boot sequence hit a key to see the grub boot menu and press the down arrow to select the previous kernel and see if that works.

CaseyB
22nd June 2008, 06:50 AM
I have verified that the issue comes from the interaction with the wireless drivers. I booted into the old kernel and disabled the wireless and booted into the the new kernel and it seems to be working fine. At least I have a work around. I can use it wired or boot into the old kernel if I need the wireless.

Rykkan
23rd June 2008, 03:25 PM
I just had the same problem and to fix the Wireless WEP problem just goto http://koji.fedoraproject.org/koji/...o?buildID=52456 and select the proper format and install using rpm -Uvh filename.rpm and reboot and the new kernel problem is fixed in.

rhricik
23rd June 2008, 03:57 PM
The above URL is http://koji.fedoraproject.org/koji/buildinfo?buildID=52456