PDA

View Full Version : Playing audio on FC-9 with xmms, or other



James Board
20th June 2008, 12:53 AM
I just did a fresh install of FC 9, along with a fresh install of xmms (yum install xmms). When I try to play .mp3 files, I get this error:

Due to patent licensing, and conflicts between such patent licenses and the licenses of application source code, MPEG-1/2 audio layer 3 (mp3) support has been removed from this application by Red Hat, Inc
Is that a showstopper? Can I get xmms working with mp3 files on FC9?

What I really want to do is play an audio stream from www.live365.com. I need to choose an application association for file play.pls, application type audio/x-scpls. What application can I use to play music files/streams?

The obvious things (from man -k audio) all failed for one reason or another. Is there a simple way, or a straightforward HOWTO page that explains how to get this working (I'm not using a standard Desktop, so it looks like pulseaudio isn't started for me automatically). Where do I start?

James

James Board
20th June 2008, 01:14 AM
I tried to read the pulseaudio Documentation:
http://www.pulseaudio.org/wiki/Documentation
And their documentation page is broken.

Sunny Penguin
20th June 2008, 01:26 AM
http://sulphur.freshrpms.net/rpm.html?id=86

Load the freshrpms-release-1.1-1.fc.noarch.rpm
yum install xmms-mp3

lots of other good stuff there too; mplayer, dvdrip etc.

James Board
20th June 2008, 01:38 AM
Okay, I did that, and I think I'm getting further. When I try to play an mp3 file with xmms, I get several error mesages:

*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting

** WARNING **: alsa_setup(): Failed to open pcm device (default): Connection refused

I'm trying to figure out how to correctly start the pulseaudio server, assuming there's no workaround. I'm fully willing to dig through all the documentation, but the fact that it's taking so much effort to do something so simple and common, makes me wonder if I'm barking up the wrong tree.

James Board
20th June 2008, 02:52 AM
If I start the gnome desktop, then apparently pulseaudio is started automatically, and everything works fine. So, I'm assuming I have all the software installed correctly. If I don't start gnome, then xmms seems to have problems:

Message: alsa_setup(): Cannot set mmap'ed mode: Invalid argument. falling back to direct write
*** PULSEAUDIO: Unable to create stream.

** WARNING **: alsa_setup(): Unable to install hw params


Anyone know why it would be configured to only work with the gnome desktop? More importantly, how can I configure it so it works with other desktops?

James

Hlingler
20th June 2008, 03:38 AM
XMMS works fine for KDE, XFCE4 and E17 here. F8 and F9. My solution was... maybe not so popular:
yum remove pulseaudio* paman padevchooser --exclude=pulseaudio-libs

Note that pulseaudio-libs is a prerequisite for a number of othe apps and needs to stay installed, but is irrelevant to A/V performance (at least directly).
MPlayer got yanked out too, but I got it back later from Livna. Besides, there's XMMS, Xine, VLC, and tons of other A/V apps. All audio problems were instantly solved.

V

James Board
21st June 2008, 12:03 AM
I tried your "yum remove" advice. No such luck for me.

I then tried to remove xmms and pulseaudio-libs and then reinstalled them, but that didn't work. When I try to play a file, nothing happens, no sound, no error message, and the xmms sliderbar doesn't move, and xmms gives no indication that it was just asked to load an mp3 file.

James

Hlingler
21st June 2008, 12:09 AM
I tried your "yum remove" advice. No such luck for me.

I then tried to remove xmms and pulseaudio-libs and then reinstalled them, but that didn't work. When I try to play a file, nothing happens, no sound, no error message, and the xmms sliderbar doesn't move, and xmms gives no indication that it was just asked to load an mp3 file.

JamesDid you check the XMMS preferences to:
> Disable that dummy MP3 placeholder plugin? and
> Enable the real MP3 plugin?

Under Preferences=>Audio I/O Plugins tab. Please check all preferences/settings.

V

James Board
21st June 2008, 12:20 AM
[QUOTE]

I did not know about the "dummy MP3 placeholder plugin". There's a plugin named "MPEG Layer 1/2/3 Placeholder Plugin" which I now disabled. I don't know what you mean by "real MP3 plugin". No other MP3 plugins are listed.

Under Preferences=>Audio I/O Plugins, I can't tell if the settings are right. I'm now trying to play a simple wav file (generic .wav) so that I can isolate any mp3 problems with other problems simply trying to get audio output working on a Fedora machine that isn't running Gnome, or KDE desktops.

If there is a webpage that describes the process, please let me know. Surely all the other Fedora users aren't going through all this hassle, right?

James

Hlingler
21st June 2008, 12:28 AM
[QUOTE]

I did not know about the "dummy MP3 placeholder plugin". There's a plugin named "MPEG Layer 1/2/3 Placeholder Plugin" which I now disabled. I don't know what you mean by "real MP3 plugin". No other MP3 plugins are listed.

Under Preferences=>Audio I/O Plugins, I can't tell if the settings are right. I'm now trying to play a simple wav file (generic .wav) so that I can isolate any mp3 problems with other problems simply trying to get audio output working on a Fedora machine that isn't running Gnome, or KDE desktops.

If there is a webpage that describes the process, please let me know. Surely all the other Fedora users aren't going through all this hassle, right?

JamesYes, that is the "dummy" placeholder plugin. But you must have lost the real one during the purge.

Re-install the xmms-mp3 package as per Post #3.

We all have different issues with software - maybe XMMS is not so much used. But we'll try to help you work through this, if you want. I assure you that you can enjoy high-wuality audio using XMMS without GNOME or KDE - I am at this very moment! F8-XFCE-LiveCD installed, but no PusleAudio....

V

James Board
21st June 2008, 12:30 AM
How about if I take baby steps? I have a generic wav file in /usr/share/sounds/generic.wav.
I've removed pulseaudio from my system. How can I play that file? I can cat the file to /dev/audio, and it makes lots of noise, so I know my speakers and sound card are working. It would be nice to get xmms to work, but any audio player will do.

James

James Board
21st June 2008, 12:36 AM
I followed instructions from post #3 and yes, I can now select a different plugin, and when I load a file from xmms, it at least prints the file name in the xmms window (the timebar doesn't advance and there's no sound).



James

Hlingler
21st June 2008, 12:40 AM
Are you running XFCE? IIRC, there was another thread... and I think that I had no sound either until...

Right-click on one of the panels and add the volume control applet. Then turn on the volume! IIRC, this was the problem.

V

P.S. If you can't find it and you are in fact running XFCE4, then:
yum install xfce4-mixer

to get that volume control applet plugin.

James Board
21st June 2008, 12:44 AM
No, I don't use XFCE.

Hlingler
21st June 2008, 12:50 AM
Um... what desktop/window manager are you using?

Try:
yum install alsamixergui

and open it to set up audio.

You might even want to:
yum install alsa\-*

to get all possible alsa sound support (generic).

V

James Board
21st June 2008, 03:09 AM
I'm using twm. I know it's ancient, but I like it.

James Board
21st June 2008, 03:35 AM
Hey, something worked. I just ran xmms as root, and I can play MP3 files! But I can't as any regular user. It sounds like maybe I need to put myself in the right group, maybe?

James

Hlingler
21st June 2008, 04:08 AM
OOPS! I forgot! I had to change the permissions on the XMMS executable to SUID root - that means: run the program with root-user permissions:
sudo chmod u+s /usr/bin/xmms

Now, XMMS will run with root-user priority (CPU scheduling) and also with root-user permissions on access to hardware and other software resources, regardless of who starts it.

Not exactly sure if that's any kind of security concern, but for a light-weight personal home PC, I'm not really concerned....

V

P.S. See this tutorial to get all A/V stuff going, including all codecs for proprietary media formats - *.wav and other file types may not play until you do so:
http://www.mjmwired.net/resources/mjm-fedora-f9.html

James Board
23rd June 2008, 09:04 PM
I did the "sudo chmod u+s /usr/bin/xmms" and expected it to work as a non-root-user but it didn't. I'm perplexed. It runs fine as root. Doesn't the sudo command make it appear exactly like I'm a root user? The non-root error messages are:

** WARNING **: alsa_get_mixer(): Attaching to mixer hw:0 failed: No such file or directory
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM default

** WARNING **: alsa_setup(): Failed to open pcm device (default): No such file or directory

James Board
23rd June 2008, 10:12 PM
I tried a different strategy. I enabled the OSS Driver (under Output Plugins for XMMS), added world read/write permissions to the device (/dev/dsp), and now I can play audio as a non-root user. Thanks for your help! I'll probably post a summary file later.

James

James Board
23rd June 2008, 10:16 PM
It seems I need to use alsamixer to set the volume; volume control on XMMS won't work. This is probably because I'm using OSS. Is there a document that explains all this? Alsa, pulseaudion,OSS< etc? Audio on Linux used to be a lot simpler.

James

verylinux
10th July 2008, 01:11 AM
Hi,

I had the same problems as you did after the recent yum update. I am not an expert. So, I did yum remove xmms*. Then I did yum install xmms xmms-mp3. Now xmms works okay, plays mp3 files properly, sound volume is good. But there are still other errors though xmms works.

verylinux