PDA

View Full Version : 403 Forbidden



bundy07
19th June 2008, 09:37 PM
I have re-installed Fedora 9, completed all the updates.
I have installed the MySQL packacge, started the service and started the httpd service
I have gone to http://localhost and get the Fedora test page
I have gone to http://localhost/cgi-bin/phpinfo.php and I get the results I am looking for
I downloaded and extracted phpBB3 to the /var/www/html/ directory, but when I go to http://localhost/phpBB3/install/index.php I get the 403 forbidden message.

What have I missed????

I have tried to edit permissions to the folders, but I am not sure if I have done it right, cause I click the help button and a window pops up says loading at the top, but then another pop-up says The application gnome-help has crashed.......

Is there a problem with the system

hyperspace
19th June 2008, 09:45 PM
Look in the /var/log/httpd directory and see if there is an error log. You will need to be root to get into httpd.

bundy07
19th June 2008, 09:50 PM
I see this line
[Thu Jun 19 15:04:26 2008] [error] [client 127.0.0.1] (13)Permission denied: access to /phpBB3/ denied

hyperspace
19th June 2008, 09:57 PM
I'm no httpd and php expert but it may have to do with a configuration file setting and not permissions for files and directories.

JohnVV
19th June 2008, 10:25 PM
--for reference have you admined a web site before or is this your first--


it's been two years, but IS apache setup !!
did you add
/var/www/html/phpBB3 directory to the /etc/httpd/conf/httpd.conf
<Directory "/var/www/html/phpBB3">
options??
options??
Order allow,deny
Allow from all
</Directory>
or set "public html" to point to the folder for the main forum
...localhost/phpBB3/install/index.php
well the default settings seem to be on cgi-bin worked
and all the required mod's are installed for it mod php5 -- or whatever the new one is-- seems to be
dose the forum need mod_perl ,some things do
and the folders are owned by apache

bundy07
20th June 2008, 12:40 PM
Thanks for all your help, I got it working.

It had something to do with the way I put the folder in the /var/www/html directory, I think. I extracted it into the directory, so I deleted the entire phpBB3 folder, then extracted it elsewhere and copied it over and now it works fine.

I have more experience with VB boards than phpBB, but I have been admins on both.