PDA

View Full Version : How to stop automatically mounting NTFS partitions?



Murrquan
19th June 2008, 04:41 PM
A while ago I told Fedora to mount an NTFS partition on my hard drive. Now it automatically mounts that partition on startup, cluttering my desktop with an extra icon. I can manually unmount it by selecting unmount from the right-click menu, but this adds an extra step to my startup routine.

How do I get it to stop automatically mounting that partition? I checked /etc/fstab, but I didn't see anything NTFS, so I'm guessing that's not the solution.

Hlingler
19th June 2008, 04:47 PM
Yes, it is in fstab: you would want to put the 'noauto' option on the mount line, example:

192.168.0.2:/home/shared /mnt/etower/shared nfs noauto,nolock,ro,users,bg,retry=1 0 0

V

A.Serbinski
19th June 2008, 05:05 PM
He said nTfs, not nfs.

@Murrquan: What did you do to get it to automatically mount to begin with?

Hlingler
19th June 2008, 05:19 PM
I don't see the difference - the was just an example, the noauto option applies to nfs or ntfs, what's the diff?

V

P.S. Further clarification: As I read it, the 'noauto' option can be used for any mount command in fstab, regardless of type.

A.Serbinski
19th June 2008, 05:28 PM
Simply that nfs must be mounted explicitly from a script of from fstab, whereas ntfs (or other local filesystems) does NOT need to be in the fstab.

A.Serbinski
19th June 2008, 05:30 PM
Note that he said that he checked the fstab and it wasn't in there.

Murrquan
19th June 2008, 05:35 PM
@Murrquan: What did you do to get it to automatically mount to begin with?

I think I just clicked on the partition from either Places or the Nautilus sidebar. It prompted me for root authorization IIRC, and then mounted the partition. Now it's mounted and on my desktop every time I start up.

Hlinger, thank you for the assistance, but I'm not sure where to put that. Here are the contents of my /etc/fstab:


UUID=1da77fce-34aa-47f1-94b8-b3c711bedcf9 / ext3 defaults 1 1
UUID=8b05178c-a283-4eb7-a477-696e9995fe9b /home ext3 defaults 1 2
UUID=72454ed3-9fc5-4ded-8e0d-1f78d06539bb /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
UUID=937718a6-3c0f-4fe5-ad3f-c5ae64629cab swap swap defaults 0 0

I don't see any mention of NTFS partitions there, so I'm not sure what to do. Perhaps the problem lays elsewhere?

Hlingler
19th June 2008, 05:36 PM
So far as I know, nfs does not have to be mounted from script or fstab, but can be done from CLI.

However, he did in fact say it wasn't in fstab, which I missed, so all that is moot. You're on the right track.

V

A.Serbinski
19th June 2008, 06:09 PM
script=automatic cli, so its the same thing.

@Murrquan: This looks like its a gvfs/gnome-volume-manager thing. What version of Fedora are you using? If its F9, its gvfs, if its F8 or older, its gnome-volume-manager. The first time you mounted it, it probably created a key in your keyring providing it with authorization to mount. What you might want to do is go into your keyring manager and remove the key assigned for it. This *might* work, or it might not.

Truth is that gnome-mount is a real pain to manage. You might want to read over this thread on the same topic: http://forums.fedoraforum.org/forum/showthread.php?t=171454

sidebrnz
19th June 2008, 09:28 PM
I have a secondary drive with several old DOS partitions on it, that I need on the rare occasions I go into Windows. When I first installed F 9, they were all on my desktop, but I managed to get rid of them. (Alas, I don't remember how.) After the last kernel update, they all appeared on the desktop again. Yes, I can unmount them but I doubt that they'll stay away when I log out and back in. I can't tell nautilus not to show partitions on the desktop, because I need my main C: drive and one other showing. (That's how I had it before.) I'm not trying to hijack the thread, just adding the info that this might be related to a recent update in case that's any help.

Murrquan
20th June 2008, 07:57 PM
Truth is that gnome-mount is a real pain to manage. You might want to read over this thread on the same topic: http://forums.fedoraforum.org/forum/showthread.php?t=171454

Many thanks! I implemented the solution they gave there, creating a new file named /usr/share/hal/fdi/policy/10osvendor/99-redhat-storage-policy-fixed-drives.fdi with the following contents:


<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->

<deviceinfo version="0.2">
<device>
<match key="@block.storage_device:storage.hotpluggable" bool="false">
<match key="@block.storage_device:storage.removable" bool="false">
<merge key="volume.ignore" type="bool">true</merge>
</match>
</match>
</device>
</deviceinfo>

And it worked like a charm.

It had the unusual side effect of turning off system sound, though, like the little "pings" from clicking on things. Even after I restarted the system again. At least, until I went to System -> Preferences -> Hardware -> Sound, verified that they were, in fact, turned on, and played each one from the dialog box. After that they all worked again. Come to think of it, this may not be a side effect so much as an unrelated weird occurrence ... par for the course with Fedora, it seems. ^.^

Thanks, everyone!