PDA

View Full Version : FC8 yum/package update problems



Upaut
11th June 2008, 07:25 PM
I'm a bit of a noob to Linux, but this really shouldn't be that big of a problem, even with a book sitting next to me.

First off, yum seems to get into a loop, repeating this:

--> Running transaction check
---> Package muine.i386 0:0.8.8-3.fc8 set to be updated
--> Processing Dependency: mono(glib-sharp) = 2.10.0.0 for package: muine
--> Processing Dependency: mono(gdk-sharp) = 2.10.0.0 for package: muine
--> Processing Dependency: mono(gtk-sharp) = 2.10.0.0 for package: muine
--> Processing Dependency: fedora-release = 8 for package: yum-fedorafaq
---> Package perl-DateManip.noarch 0:5.44-4.fc8 set to be updated
--> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-DateManip
--> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-DateManip
--> Processing Conflict: mesa-libGL conflicts xorg-x11-server-Xorg < 1.4.99.901-14
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package muine.i386 0:0.8.8-3.fc8 set to be updated
--> Processing Dependency: mono(glib-sharp) = 2.10.0.0 for package: muine
--> Processing Dependency: mono(gdk-sharp) = 2.10.0.0 for package: muine
--> Processing Dependency: mono(gtk-sharp) = 2.10.0.0 for package: muine
--> Processing Dependency: fedora-release = 8 for package: yum-fedorafaq
---> Package perl-DateManip.noarch 0:5.44-4.fc8 set to be updated
--> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-DateManip
--> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-DateManip
--> Processing Conflict: mesa-libGL conflicts xorg-x11-server-Xorg < 1.4.99.901-14
--> Restarting Dependency Resolution with new changes.

And since this is a fresh new installation of FC8, Package Updater claimed 684 updates. I've tried letting PU handle the updates, only to have it sometimes freeze up on "Resolving dependencies for updates". It does, however, return with errors such as:

Missing Dependency: fedora-release = 8 is needed by package yum-fedorafaq
Missing Dependency: perl(:MODULE_COMPAT_5.8.8) is needed by package perl-DateManip

Am I totally missing something obvious to prevent either Yum or Package Updater from finishing their jobs?

JohnVV
12th June 2008, 01:09 AM
here is an idea to update start gedit as root

su - ( your password when asked )
gedit

go to /etc/yum.repos.d
and open ALL ( BUT fedora.repo,fedora-updates.repo ) the files and change this


enabled=1
to
enabled=0
then give
-
yum update
-
a try
there may be miss configed repos pointing to the wrong site
and take a look here
http://www.mjmwired.net/resources/mjm-fedora-f8.html#yum
but use su - instead of sudo

wtg_photos
12th June 2008, 01:49 AM
also you can use the --skip-broken option for yum





su -
yum -y update --skip-broken

it will update what it can then you can repeat till it boils it down to the ones that are really broken

forkbomb
12th June 2008, 03:01 AM
also you can use the --skip-broken option for yum





su -
yum -y update --skip-broken

it will update what it can then you can repeat till it boils it down to the ones that are really broken
Be warned that --skip-broken (and similar dependency force options in RPM and various package managers in general) is dangerous. I once successfully used that switch to make a broken system even more broken.

JohnVV
12th June 2008, 03:52 AM
the idea of leaving only fedora.repo,fedora-updates.repo working is to narrow down the list from 684 to a more reasonable # .Then hopefully the missing dep's wont be an issue .
maybe!
if not then get new copies of the repos
http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Everything/i386/os/Packages/fedora-release-8-3.noarch.rpm
http://rpm.livna.org/livna-release-8.rpm
(Note: the Livna repository is NOT compatible with the Freshrpms repository.)
so DON'T install fresh with livina
--
also you might want to run
yum update kernel
FIRST

JohnVV
12th June 2008, 07:46 AM
it accered to me that didn't fedora 8 dvd get released with the 586 kernel BUT was listed as the 686 kernel , and this was causing all kinds of problems

so it might be best to run

yum update kernel
FIRST