PDA

View Full Version : Don't have access to move files



maxicooper
9th June 2008, 04:02 PM
Hi all!

I'm new to the Linux world and am trying to set up my system. In order to install the Flash Player for the Firefox I need to move some files to the plugins folder under Mozilla. Yet, when trying to do so from the termina. This is what I get:

[maxicooper@localhost install_flash_player_9_linux]$ sudo mv libflashplayer.so /usr/lib/mozilla/plugins
[sudo] password for maxicooper:
maxicooper is not in the sudoers file. This incident will be reported.


Can anyone give me a hint on what to do?


Thanks in advance,

Max Cooper

PabloTwo
9th June 2008, 04:33 PM
Hello maxicooper, and welcome to the Fedora Forum-

In Fedora, users are not automatically setup for using the 'sudo' command, as witnessed by the error message you got. Have a look at this link for how to do that, and many other things.

http://www.mjmwired.net/resources/mjm-fedora-f9.html

If you're not using F9, just substitute whichever version you are running in the url above.

But in the meantime, you can get permission to write to locations outside of your user account by becoming the root user with the 'su -' command.

You really don't want to 'mv' (move) that libflashplayer.so file from where it is installed. The preferred method is to create a symbolic link to it in the /usr/lib/mozilla/plugins folder.

su -
ln -s /path/to/libflashplayer.so /usr/lib/mozilla/plugins/
Use the actual path in place of /path/to. You could also create a symbolic link to that flashplayer plugin file directly into your Firefox plugins directory which would work just as well but doing so would not give access to that plugin by other mozilla applications.

maxicooper
9th June 2008, 04:58 PM
Thanks Pablo.

I've did what you told me to but since I was missing another step I had to look up for more instructions. When doing so, I found out how to run the installer. After doing so, it told me:

[root@localhost install_flash_player_9_linux]# ./flashplayer-installer
ERROR: Your architecture, \'x86_64\', is not supported by the
Adobe Flash Player installer.

What I tried then was to download the .rpm version of the plug-in and install it. When doing so it said:

[root@localhost Desktop]# rpm -Uvh flash-plugin-9.0.124.0-release.i386.rpm
error: Failed dependencies:
libX11.so.6 is needed by flash-plugin-9.0.124.0-release.i386
libXext.so.6 is needed by flash-plugin-9.0.124.0-release.i386
libXt.so.6 is needed by flash-plugin-9.0.124.0-release.i386
libfontconfig.so.1 is needed by flash-plugin-9.0.124.0-release.i386
libfreetype.so.6 is needed by flash-plugin-9.0.124.0-release.i386
libglib-2.0.so.0 is needed by flash-plugin-9.0.124.0-release.i386
libgobject-2.0.so.0 is needed by flash-plugin-9.0.124.0-release.i386
libgtk-x11-2.0.so.0 is needed by flash-plugin-9.0.124.0-release.i386


Could you give me any hint on what to do?

Thanks again!

PabloTwo
9th June 2008, 05:12 PM
Why don't you try

su -
password
yum install flash-plugin
and let yum take care of all the dependencies. Or, you could use yum to install the rpm package you have already downloaded and it will grab the deps online.

su -
yum localinstall flash-plugin-9.0.124.0-release.i386.rpm
That should install the flashplayer plugin to something like: /usr/lib/flashplayer/libflashplayer.so
(working in Windows right now so can't check install path for certain).

maxicooper
9th June 2008, 05:19 PM
This is what happened:

[root@localhost /]# yum localinstall flash-plugin-9.0.124.0-release.i386.rpm
Loaded plugins: refresh-packagekit
Setting up Local Package Process
Cannot open file: flash-plugin-9.0.124.0-release.i386.rpm. Skipping.
Nothing to do
[root@localhost /]# su -
[root@localhost ~]# yum install flash-plugin
Loaded plugins: refresh-packagekit
fedora | 2.4 kB 00:00
updates | 2.3 kB 00:00
Setting up Install Process
Parsing package install arguments
No package flash-plugin available.
Nothing to do

Any other ideas?

PabloTwo
9th June 2008, 05:36 PM
Maybe you should mention which version of Fedora you are using. If you are using F9, then perhaps the 'flash-plugin' package is no longer available in the repos as it was for earlier versions of Fedora (I'm still running FC6).

When you are already the root user, as evidenced by your command line prompt: [root@localhost /]#
You do not need to use the su command again.

When using the 'yum localinstall filename.rpm' command, you need to either be in the directory where that rpm file resides or specify the full path to it on the command line.

The flashplayer plugin should install to: /usr/lib/flash-plugin/libflashplayerso

maxicooper
9th June 2008, 06:41 PM
I'm running F9. Where can I check if the flash-plugin package is available?

marko
9th June 2008, 06:47 PM
This has all the instructions needed, note that the i386 and X86_64
have different instructions

http://www.mjmwired.net/resources/mjm-fedora-f9.html#flash

For f9 64bit that's:



su -
<root password>
mkdir -p /usr/lib/mozilla/plugins
yum install nspluginwrapper.{i386,x86_64} pulseaudio-libs.i386 libflashsupport.i386
yum install flash-plugin
mozilla-plugin-config -i -g -v

PabloTwo
9th June 2008, 06:54 PM
OK.. I gave you some bum information. The flash-plugin package isn't available from the Fedora repos, but comes from the Adobe repo, which you can install. Check back at the link I first provided you for instructions on how to install that. How you install flashplayer plugin support seems to be dependent on whether you're running x86 (32 bit) or x86_64 (64 bit) Fedora. You already have the 32 bit flashplayer plugin rpm file which you can install with yum, if you're running 32 bit

yum localinstall flash-plugin-9.0.124.0-release.i386.rpm

But having the Adobe repo installed will ensure you get any new updates to the flashplayer whenever they become available in that repo and whenever you do a 'yum update'.

maxicooper
9th June 2008, 07:03 PM
Great man, I was missing that last command.

Thanks to all, I'm now using flash on Firefox.