PDA

View Full Version : Shutdown problems and Nvidia



Jezster
14th July 2004, 09:12 AM
Hi All,

I have managed to build my system and got everything installed I need. However when installed the Nvidia driver (following the www.fedorafaq.org guide) my system now locks during shutdown.

Does anyone know why this might occur... I believe that it happens when the system reaches the 'Sending Term signal' stage.

Many Thanks,

Jez

Picomp314
14th July 2004, 09:26 AM
attach your /etc/X11/xorg.conf

Jezster
14th July 2004, 10:20 AM
I will, once I've rebooted :) The wife is not a linux fan.

J.

Jezster
14th July 2004, 02:31 PM
Here you are...




# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
# Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell D1626HT"
DisplaySize 380 290
HorizSync 30.0 - 107.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce FX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Picomp314
14th July 2004, 03:02 PM
what version of the Nvidia drivers do you have installed?
try changing the 'DefaultDepth' to 16 and 'Depth' to 16 as well

Jezster
14th July 2004, 07:49 PM
I'm running the lastest version 6106 I believe...

J.

everest
15th July 2004, 12:23 AM
Jester your going to want to remove the line under Module that says

Load "dri"

That causes a conflict with the nvidia drivers so once you get that out of there you should be all set (i hope)!

merith
15th July 2004, 03:01 AM
By the looks of your configuration file above you are running Fedora Core 1 or less? My FC2 file displays XOrg at the top as opposed to XFree86.

Anyway the only freeze problems I encountered between nvidia and FC1 was when I booted the system with the new graphical boot screens. When I turned them off(in grub ) the system started ok.

Jezster
15th July 2004, 03:35 AM
Nope, I'm running Fedora Core 2 and that is the xorg.conf file. I guess the message might have come from the installer. I've checked the two other machines in the office and they have the same header line in the xorg.conf file :(

The "load dri" line is hashed out and therefore will not read.

To summarise the problem again... When I shutdown the machine the system stops responding at the 'Sending Term Signal' line and then I have to power off without the disks correctly stopping. I'm going to review my log files when I get home for hardware confliction. It just seems stange that this has only occurred since installing the Nvidia driver.

merith
15th July 2004, 03:49 AM
The only example I have is a FC1 setup here and I looked at the file and the only differences I can spot are:
* Within the section "Screen" then subsection "Display" I dont have a viewport entry.
* I added the option "NoLogo" "true" to the device section(as the driver I built off displayed the anoying nvidia screen and I wanted to get rid of it). Though this should not make a difference.

Other than that the file is the same. Home some of it helps.

Picomp314
19th July 2004, 08:40 AM
judging from the behavior you describe i believe that the Nvidia drivers must be causing a conflict with another program