PDA

View Full Version : Unable to update from updates-testing



gbuergisser
5th June 2008, 06:14 AM
I'm trying to get some packages from the update-testing repo but it simply doesn't work. I have no idea what I'm doing wrong. yum always keeps telling me that there are no updates available. But they are, one can see them when opening the repo URL in the webbrowser.
Any help is greatly appreciated!

Here's what I want to do and also how my repo file for yum looks like:


yum --enablerepo=updates-testing update evolution
Loaded plugins: fedorakmod, refresh-packagekit
Bad id for repo: Fedora 9, byte = 6
Setting up Update Process
Could not find update match for evolution
No Packages marked for Update



[updates-testing]
name=Fedora 9 - i386 - Test Updates
failovermethod=priority
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/9/i386/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-testing-f9&arch=i386
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test

[updates-testing-debuginfo]
name=Fedora 9 - i386 - Test Updates Debug
failovermethod=priority
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/9/i386/debug/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-testing-debug-f9&arch=i386
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test

[updates-testing-source]
name=Fedora 9 - i386 - Test Updates Source
failovermethod=priority
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/9/SRPMS/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-testing-source-f9&arch=i386
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test


By the way - what is this message "Bad id for repo: Fedora 9, byte = 6" about? How can I get rid of it?

glennzo
5th June 2008, 07:56 AM
Here's what I get when I search for evolution with updates-testing enabled.

[glenn@toshiba ~]$ sudo yum --enablerepo=updates-testing list evolution
Password:
Loaded plugins: fastestmirror, presto, protectbase, refresh-packagekit
Setting up and reading Presto delta metadata
updates-testing | 2.3 kB 00:00
primary.sqlite.bz2 | 456 kB 00:09
No Presto metadata available for updates-testing
No Presto metadata available for livna
No Presto metadata available for fedora
No Presto metadata available for adobe-linux-i386
No Presto metadata available for fusion
Loading mirror speeds from cached hostfile
* updates-testing: mirror.umoss.org
* livna: livna.cat.pdx.edu
* fedora: mirror.nyi.net
* adobe-linux-i386: linuxdownload.adobe.com
* fusion: techfreaks4u.com
* updates: lesloueizeh.com
Excluding Packages in global exclude list
Finished
19 packages excluded due to repository protections
Installed Packages
evolution.i386 2.22.1-2.fc9 installed
Available Packages
evolution.i386 2.22.2-1.fc9 updates-testing
Here is my updates-testing.repo file, which doesn't look quite like yours.

[updates-testing]
protect=yes
name=Fedora $releasever - $basearch - Test Updates
failovermethod=priority
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/$releasever/$basearch/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-testing-f$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test

[updates-testing-debuginfo]
protect=yes
name=Fedora $releasever - $basearch - Test Updates Debug
failovermethod=priority
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/$releasever/$basearch/debug/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-testing-debug-f$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test

[updates-testing-source]
protect=yes
name=Fedora $releasever - Test Updates Source
failovermethod=priority
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/$releasever/SRPMS/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=updates-testing-source-f$releasever&arch=$basearch
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test
You may need to make a change or 2 to your file using mine as a template and then try again.

gbuergisser
5th June 2008, 08:28 AM
Thanks for your reply. The only real difference between our repo files is that yours has symbolic values for the Fedora version and architecture and mine has hard-coded values.
I really don't have a clue why my yum still lists 2.22.1 for Evolution :confused: ...



[root@pcbue2 etc]# yum --enablerepo=updates-testing list evolution
Loaded plugins: fedorakmod, refresh-packagekit
Bad id for repo: Fedora 9, byte = 6
updates-debuginfo | 1.9 kB 00:00
fedora | 2.4 kB 00:00
updates-testing | 2.3 kB 00:00
Not using downloaded repomd.xml because it is older than what we have
updates | 2.3 kB 00:00
fedora-debuginfo | 1.9 kB 00:00
Installed Packages
evolution.i386 2.22.1-2.fc9 installed

glennzo
5th June 2008, 08:52 AM
I think that your problem is here, Not using downloaded repomd.xml because it is older than what we have. Try yum clean all and then try yum --enablerepo=updates-testing list evolution. See if evolution.i386 2.22.2-1.fc9 is listed then.

gbuergisser
5th June 2008, 08:58 AM
I've done the clean before. I've done it again and it is still 2.22.1...
What can I do? Any idea about the other strange message 'Bad id for repo: Fedora 9, byte = 6'?


[root@pcbue2 src]# yum clean all
Loaded plugins: fedorakmod, refresh-packagekit
Bad id for repo: Fedora 9, byte = 6
Cleaning up Everything

[root@pcbue2 src]# yum --enablerepo=updates-testing list evolution
Loaded plugins: fedorakmod, refresh-packagekit
Bad id for repo: Fedora 9, byte = 6
updates-debuginfo | 1.9 kB 00:00
primary.sqlite.bz2 | 194 kB 00:00
fedora | 2.4 kB 00:00
primary.sqlite.bz2 | 6.1 MB 00:08
updates | 2.3 kB 00:00
primary.sqlite.bz2 | 904 kB 00:00
fedora-debuginfo | 1.9 kB 00:00
primary.sqlite.bz2 | 1.3 MB 00:01
Installed Packages
evolution.i386 2.22.1-2.fc9 installed

glennzo
5th June 2008, 09:09 AM
No idea on that Bad ID for repo error. I actually Googled it and came up pretty empty. You know you're in trouble when you Google something and the first hit is a link to the forum thread you're currently reading. :rolleyes: Hang tight. Someone will come along soon and straighten both of us out. In the interim, look around for some of the other 'maintenance' commands for yum. There's more than just clean all but I don't use them too often and as such don't even remember their proper names.

Edit: Open a terminal and type man yum. Have a look at the CLEAN OPTIONS section.

gbuergisser
5th June 2008, 09:41 AM
Glenn, thank you. Your final suggestion to RTFM has finally helped me to solve the problem. The updates-testing repo is disabled by default (as specified in the repo file). Thus one has to use --enablerepo='*' additionally to the clean all.
Thanks for your patience. :)

glennzo
5th June 2008, 09:54 AM
Well, if I said RTFM I did it in a nice way ;) The idea was that since I don't use too many of the additional yum commands I'm not all that familiar with them. I looked at man yum and saw the clean options section and just figured that the info you needed was there.

You're welcome. Glad that I could be of some assistance.